VPN and VPS Setup

@BigDaveAZ Yes that is on my to do list. It has taken me the better part of ten years to get my windoze PC to where I was sort of happy. Now I have to start over… but I am very glad to be making the journey as I feel I have stepped out from under a cloud into a bright new world. On windoze I was using PureVPN (paid for 5 years) based in Hong Kong before the CCP take over. I believe they are now in the BVI. Had the choice of multiple cities in most countries via a GUI. On Ubuntu I am stuck with running it from the CLI with no choice of city just country. For USA it always routes me through New York… that is when it is working… at the moment when I run it I cannot access the interweb.

1 Like

@Minty Nord allows you to pick the city and country via the CLI. I haven’t played with the OpenVPN so I am not sure. Here is the NordVPN instructions. I will look for OpenVPN. Cheers!!

1 Like

Hey, @Minty!
I haven’t tried PureVPN, so I am not certain of the commands it offers. When in terminal, try to see if it comes with a dedicated manual page, so that you can see the analytical options:

man purevpn

This will produce (if it has the manual entries) all the details of the options you can use. The same goes for ProtonVPN, NordVPN, and Surfshark that I have personally tested.

If you are looking for an official GUI, then ProtonVPN comes with one for Linux. The only thing you’ll need to be mindful, when using ProtonVPN is to disconnect before you reboot or shutdown. Otherwise, a DNS leak-prevention network tunnel will remain and when you start your system, it will seem like you have no Internet. :slight_smile:

purevpn --connect US

followed by

purevpn -i

says I am connected through New York but a lot of web sites fail to load due to “Time Out” e.g. cannot use Brave Search. If I try

purevpn -c

it fails to connect. I am trying to get in touch with their support, but that is a problem as well.

I really need to get a VPS and set up a VPN that way. Have the LMS session, so when time permits I WILL get there… I fear I have a lot to learn about time management from you?

Hey @Minty!
I haven’t used PureVPN personally, so I can’t be 100% certain if it performs the same “trick” as ProtonVPN. So, let’s look at this one step at a time.

First, open up a terminal and check to see if it can see IP addresses:

ping -c 3

If displays 0% Packet Loss, then you have Internet access, just not name resolution. In that scenario, execute:

ip link

And please send me the output of that command.

Try to execute a:

purevpn --disconnect

And then check the following to see if you get any packet losses:

ping -c 3 search.brave.com
ping -c 3

Please let me know of the results.


Hey @Minty!
It appears you do have Internet. What does the:

ping -c 3 search.brave.com

Give you?


1 Like

Hey @Minty!
It would appear that you have normal connectivity to the Internet and the name resolution works. At this point, I’m starting to think if it’s a browser extension issue that blocks you. Do you have another browser, like Brave to give it a shot?


It does not happen all the time, so I agree it could be Firefox not playing nice with the VPN. As long as I am not in the middle of a download, or I cannot wait, I will disconnect the VPN, refresh the page and as soon as it loads I reconnect the VPN. Not a big deal… just annoying.

Thanks, as always, for the input.

1 Like

Give Brave and LibreWolf a try. It’s always good to have backup browsers. :slight_smile:

Hello friends,

If someone with VPN setup experience has a few minutes to read through this and let me know any suggestions, I’d appreciate it.

I am trying the Wireguard setup on a VPS now. I have the VPS account, but I’m having trouble completing the setup. I’m using this tutorial: How to Set Up WireGuard VPN on Ubuntu (A Step-by-Step Guide)

I made it to Step 4 above and then received the following error:

“Job for wg-quick@wg0.service failed because the control process exited with error code.
See “systemctl status wg-quick@wg0.service” and “journalctl -xe” for details.”

I opened journalctl -xe in a text editor (nano) and it shows:

“Defined-By: systemd
— Support: http://www.ubuntu.com/support

— A start job for unit wg-quick@wg0.service has begun execution.

— The job identifier is 8265.
Oct 24 09:53:32 racknerd-a195ad wg-quick[40868]: wg-quick: `wg0′ already exists
Oct 24 09:53:32 racknerd-a195ad systemd[1]: wg-quick@wg0.service: Main process exited, code=exited, status>
— Subject: Unit process exited
— Defined-By: systemd
— Support: http://www.ubuntu.com/support

— An ExecStart= process belonging to unit wg-quick@wg0.service has exited.

— The process’ exit code is ‘exited’ and its exit status is 1.
Oct 24 09:53:32 racknerd-a195ad systemd[1]: wg-quick@wg0.service: Failed with result ‘exit-code’.
— Subject: Unit failed
— Defined-By: systemd
— Support: http://www.ubuntu.com/support

— The unit wg-quick@wg0.service has entered the ‘failed’ state with result ‘exit-code’.
Oct 24 09:53:32 racknerd-a195ad systemd[1]: Failed to start WireGuard via wg-quick(8) for wg0.
— Subject: A start job for unit wg-quick@wg0.service has failed
— Defined-By: systemd
— Support: http://www.ubuntu.com/support

— A start job for unit wg-quick@wg0.service has finished with a failure.

— The job identifier is 8265 and the job result is failed.”

What does this error mean?


I seem to have a VPN set up now. When I check different “What’s my IP?” websites, though, they have me all over the country, including my hometown on my actual ISP. The VPN is supposed to veil your true IP and therefore location, correct? How do I know if I have the VPN set up correcly?

I think this may be related to your IPv6 settings… Check this thread out where Vasileios answered.