Openvpn client on Linux Mint still shows real IP

I set up #Openvpn on a VPS, got the client side working on my Mac and iPhone but can’t seem to make it work on my #Linux Mint.

I used the Network Settings to load the .ovpn, when I turn it on then check my IP via browser, it still shows the real IP.

Does anyone know what’s wrong and what to do here? Please help!

Hey @Ai !
I trust you were able to download the settings file from your VPS and create a new VPN connection based on it, correct?

1 Like

Yes, @vasileios, one who doesn’t seem to need sleep! :wink:, I used the Network Manager to import that .ovpn file, and can actually turn it on and off form the icon at the dock. Thought I get the “it’s connected” notification, it still shows the real IP when I check via browser.

I even found somewhere to try the OpenVPN 3 client from the terminal, got it to show the VPS ip but when I do that the browser gets the server not found error…

Tell me about it! I’ve been trying not to turn into a night-owl again, with little success so far.

Per the OpenVPN, perhaps some services leak through. I’m not sure where its settings are to tunnel all traffic through it. Per the 3.0 version, it sounds like either a DNS resolution issue or a secure port that is not open. I tend to lean toward the latter.

1 Like

:laughing: I’ve been trying not to be a night-owl for years now… Still am one, it’s getting worse because I’m addicted to learning and making as many things Linux as possible…

One of the things I tried was to change nameserver to 8.8.8.8 in the resolv.conf, but it seems Network Manger would always overwrite it to search my ISP and set the name server to 127.0.0.53

Yes, the resolv.conf file is not a persistent solution - unfortunately. The best way is to direct it via your actual connection (Network Manager) or your VPN server. At this point, I’m wondering if you should instruct your VPN server to also become its own DNS as well. One thing I’d recommend is to avoid the 8.8.8.8 - as it’s a Google address. At least replace it with 1.1.1.1, which is CloudFlare. :slight_smile:

1 Like

Okay, I tried making the .ovpn (from an install script) with 1.1.1.1. that didn’t work on the Linux machine but it does on apple things.

What does it mean to “direct it via my actual connection or my VPN server”? And how do I do that?

I thought I have to provide the IP + port to set up the .ovpn already…

OMG, this is too weird…

When I go to whatsmyip.org, I get the VPN ip.
When I go to whatismyip.org, I get the ISP ip but not exactly pointing at my location (with a IPv6 address)… still scary though… Wonder if I can solve this problem by requesting an IPv6 address for my VPS?

I guess my OpenVPN client is working all the along, just not good enough…

Ah, yes. IPv6 is another beast to tame and needs its own configuration. Also, that protocol can cause quite a few network issues, so I would highly recommend you disable it at your router level (and then your computer, so that it doesn’t look for it). Once you do that, connect to your personal VPN and check your IP once again.

What happens in this case is that your IPv6 propagates your IPv4, depending on which IP reaches the whatsmyip first. Then it correlates the information via your ISP. And traditionally, the location shows where the local Network node is located for the Internet. Thus, it’s not your home. :slight_smile:

1 Like