Tutorial: Running Windows from inside of Linux

Update!!!

I went into the system BIOS and there was a setting to allow virtual machines that was disabled. I enabled it and restarted and VMware Player started right up.

I have had the same issue. I had thought it was that my CPU didn’t support virtualization.

I was about to suggest that, as it’s something we encountered before.

In short:
When you try to boot into Windows VM and it crashes on start, 99% of the time it’s because Virtualization is not activated on BIOS. :slight_smile:

Bravo on getting it done @Gr8_4w4k3n1n9!

Vasileios, I finally got around to taking my Surface Pro 3 to linux. I’ve tried Xubuntu since I thought it was one of the lighter versions. I loaded it on a usb stick and checked the sha256sum was correct. It almost finishes loading and gets hung up trying to fix the partitions. I pulled the usb stick and tried to start it up and all I get is booting into the eufi. I can’t think of anything to do to get past that. It will still boot into a live session however and seems to work fine. I noticed somewhere in the installation process that it was using 256.1GB to load. That may be why it almost gets through the installation and then hangs up. Any suggestions, like maybe an even lighter version of linux? Thanks

PS I did disable the TPM and Secure Boot.

Hey @Mike19!
I’d recommend you give the new Ubuntu LTS a shot. The older installations come with Kernel 5.11, which does not support any of the Surface hardware, hence it appears to be stuck. Kernel 5.12 and onward, a lot of Surface support was added and the process is heck of a lot faster.
Give it a shot with the original version (Gnome), which is much more touch-screen friendly.

Vasileios, sorry I bothered you. Just needed to keep on researching. For anyone else the tutorial for these problems it as: How to use manual partitioning during installation? - Ask Ubuntu

1 Like

Vasileios, Success. I have my surface pro 3 running ubuntu and windoz safely tucked inside its little sandbox. Feels really good!!! I could not get the 3D acceleration to work however. That may be because I’m a little short of resources on the surface. Did it work on yours? The reason I ask is that I couldn’t get windoz to show up on my smart TV thru the HDMI cable. I was hoping the VM tools would solve that, or maybe I’m just missing something here.
Thanks

1 Like

Hey @Mike19!
Yes, the VMware tools provide 3D acceleration, but it’s something you’ll need to install inside of your Windows VM. When you downloaded the VMware Tools, they have an ISO file inside the directory structure of the uncompressed file. The process you’ll need to do is simple:

  • Shutdown your Windows VM
  • Go to the VM settings, under CD/DVD tab
  • Select the ISO option (instead of the hardware device)
  • Browse to the location of the VMware Tools folder and select the Windows.ISO file.
  • Boot into your Windows VM and open up the CD/DVD device there and run the setup64.exe (if memory serves me well).
    This installation will upgrade all your VM drivers, which will enable hardware acceleration.

If you need better speed, I haven’t personally tested it, you can purchase the Professional Edition, which fully enables DirectX inside your VM. Once I put enough $ aside, I’ll grab it and test it appropriately. I’m still in the process of rebuilding here in the US, as I came in with a very tiny suitcase (I didn’t intend to move here, but my now wife thought otherwise :laughing: )!

1 Like

@vasileios same thing happened to me but at least it was only a couple of hundred miles and it was the best decision I ever made. Congratulations on finding love, my friend. I wish everyone could - the world would be so much calmer with everyone finishing their “Honey Do” list. off-topic, I know. Sorry. Cheers

1 Like

I hear you there, @BigDaveAZ!
I had to suffer two… insufferable relationships prior to this one. So, let’s say I placed a hefty down-deposit! I’m now 11,000km from where I used to be, but I regret nothing. I absolutely adore this country and I’m glad to have found all of you!

I finally tried this on the 2011 MBP. After trying VirtualBox. VirtualBox is a great concept but… Slow as molasses. I decided to put VM with Win10 on my desktop instead of Home. Will be wiping the drive and starting over with a configuration for my wife with Win10 and as current as I can find of Mac on Linux Mint DE. Looking for the Mac tutorial now.

1 Like

I am working with an old machine that only has 6GB of ram that I installed Linux Mint on. Should I still use 4GB for the VM / Windows? Am I asking for trouble?