Tutorial: Running Windows from inside of Linux

@BigDaveAZ Most people have no problem opening and using Excel files in LibreOffice Calc, their spreadsheet program that’s compatible with MS Excel. I’ve been using Calc for some years.

1 Like

I have been using it and I have not found a quick and easy filter that allows each column to be sorted and combined with that sort on more than one column. I suppose I could dive in to any documentation - I have Office360 until November, at the very least. If you know of any really good Calc training - I would be very interested in going through it. Thanks. Cheers!

@BigDaveAZ As I understand it, the Jeff.pro group is targeted at helping people move into Linux and learn how to use the system. At this stage, that likely doesn’t include teaching everyone how to use any program they might want to use in Linux. That’s something we all have to learn on our own. But we can give you tips on how to do that. Also, this topic is about using Windows inside of Linux. So that’s not related to how to use Excel. However, I will give you some tips here to help get you moving in the right direction. There is plenty of free help at the LibreOffice website for using any of the suite’s various tools: The LibreOffice Help Window

The concept of sorting in Excel and in LibreOffice Calc is the same. There might be different steps to take, but you do it similarly, by defining a range, since you normally have data in cells which are related by row, as in a name, address, city, state, zip database. Once you have the range defined, then you can make changes according to how you want to treat the data.

If you know how to do a process in Excel, you can figure out how to do it in Calc by observing the features of Calc and using them like you’d use those features in Excel.

I believe I remember that when starting up LibreOffice the first time, it now lets you define how you want the menu interface to look. Choices include the older look, as done early in Excel days, with a few toolbars at the top, to the Ribbon look that later developed in Excel. How you have your Calc set up may be different from how I have mine set up. I’ve gone with the simpler format of that past, where menus play a greater role. In the case of sorting data, the Data menu is the place to begin.

Calc also has built in Help. It may be downloaded to your pc or on the web. Pressing F1, the help key in most programs, will bring up options. If your Help wasn’t installed with the program, you can click the popup that shows up when you press F1 and click the link for Online help at the LibreOffice website.

A simple search for “how to sort in LibreOffice Calc” will bring up all sorts of options.

You can also go to YouTube or other popular video sites and do the same search as above, to find videos demonstrating how to do various tasks in Calc.

1 Like

Regarding Excel, I had the unfortunate task of building a balance sheet the past couple of days. I tested out both LibreOffice Calc and OnlyOffice Spreadsheet. When I imported CSV data, I noticed that Calc would pick up all the details and deal with the currency as text. On the other hand, OnlyOffice would recognize the symbols on the text and it would automatically shift the cells to become currency. Also, the CSV included dates within quotation marks. Calc picked up those marks and I had to manually remove them. OpenOffice removed them automatically and assigned the cells to be defined as dates with no manual input.

Naturally, you can copy/paste cells and tables between the two applications without a problem. So, if you have lots of cells in Calc that need cleanup, copy them, paste them in OnlyOffice and it will clean them up on paste. Then you can re-copy them and move them back to Calc. :wink:

1 Like

Well I was really excited to try this but it looks like that software is discontinued :frowning:

I worked through this and was stopped when I attempted to start my VM. Getting the error: Could not open /dev/vmmon: No such file or directory. Please make sure that the kernel module ‘vmmon’ is loaded.

Vasileios, I’m thinking about taking my dual booted Surface laptop and going with the VM. My particular Surface only has 185gb of storage and you recommended 256gb at the top of this thread. Can I squeeze them into my machine if I use a lighter version of Ubuntu or Mint? I know you mentioned having a Surface, so maybe you’ve solved this. I don’t think I’m able to take my Surface apart and try and insert a bigger hard drive into it. Will a 2Tb ssd plugged into the usb port make up the difference?

Hey @Mike19!
Yes, you can. Or you could use a network server to store your files as well. It all depends on what kind of files you’re using and how many applications you install.
Last week I did the opposite transformation. I turned a VM into a physical machine, so both are very doable. All you’ll need to do is boot from a Live USB (make sure the distro has at least a 5.12 Kernel so that you get near full hardware support). Then, connect an external drive that has more free space than your Surface’s system drive.

Once those are connected, run Gnome Disks or just disks, select your system drive, then the top right “hamburger” and hit the “Create Disk Image” - like I have in the screenshot.

Once that is done, when you create a new VM, instead of selecting a new Virtual Drive or installing a new OS, you can browse for that generated file - which will then act as your main drive.


Hey @KVS and welcome to the forums!
Which software are you referring to?
Both VirtualBox and VMware are up to date and they have continued support.

Hey @Dan!
Are you running kernel 5.16 or later? If yes, then they still haven’t updated the compilation modules needed to use that specific version. At least not since I tried it last week.

Here’s more info. I did read something about doing some procedure using HHS but I had to go out before I could explore more…

Installation was successful.
dansch2002@Sylvia:~/Downloads$ inxi --full
Host: Sylvia Kernel: 5.4.0-105-generic x86_64 bits: 64
Desktop: Cinnamon 5.2.7 Distro: Linux Mint 20.3 Una
Type: Laptop System: HP product: HP EliteBook 850 G6 v: N/A
serial: <superuser/root required>
Mobo: HP model: 8549 v: KBC Version 52.6B.00
serial: <superuser/root required> UEFI: HP v: R70 Ver. 01.12.00
date: 01/06/2022
ID-1: BAT0 charge: 43.7 Wh condition: 43.7/56.3 Wh (78%)
Topology: Quad Core model: Intel Core i5-8265U bits: 64 type: MT MCP
L2 cache: 6144 KiB
Speed: 800 MHz min/max: 400/3900 MHz Core speeds (MHz): 1: 800 2: 800
3: 800 4: 800 5: 800 6: 800 7: 800 8: 800
Device-1: Intel UHD Graphics 620 driver: i915 v: kernel
Display: x11 server: X.Org 1.20.13 driver: modesetting
unloaded: fbdev,vesa resolution: 1920x1080~60Hz, 1920x1080~60Hz
OpenGL: renderer: Mesa Intel UHD Graphics 620 (WHL GT2) v: 4.6 Mesa 21.2.6
Device-1: Intel Cannon Point-LP High Definition Audio
driver: sof-audio-pci
Sound Server: ALSA v: k5.4.0-105-generic
Device-1: Intel Ethernet I219-V driver: e1000e
IF: enp0s31f6 state: up speed: 1000 Mbps duplex: full
mac: e8:d8:d1:70:4c:94
Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi
IF: wlp58s0 state: down mac: 4c:1d:96:70:03:69
Local Storage: total: 931.51 GiB used: 183.58 GiB (19.7%)
ID-1: /dev/nvme0n1 vendor: Crucial model: CT1000P2SSD8 size: 931.51 GiB
ID-1: / size: 457.54 GiB used: 58.39 GiB (12.8%) fs: ext4
dev: /dev/nvme0n1p5
System Temperatures: cpu: 37.0 C mobo: 34.0 C
Fan Speeds (RPM): N/A
Processes: 287 Uptime: 17h 01m Memory: 23.30 GiB used: 3.06 GiB (13.1%)
Shell: bash inxi: 3.0.38

Host: Sylvia Kernel: 5.4.0-105-generic x86_64 bits: 64

So I guess I am running kernel 5.4.0. Right? I’m still in the painful period of not knowing my way around. I’ve been using Mint as my daily driver and liking it, A lot. I have one application called TheBrain that stopped updating their linux version a few release cycles ago. Funny thing about this is I used to manage a small 40 virtual computer VMware data-center part time for a truck dealership (total miss match for what they needed!) so I’m familiar with VMware. What would you suggest? VirtualBox? Or do they update this stuff frequently? Should I wait?

I did run across this article and made an attempt to follow the procedure. I didn’t have any luck.


Yes, your Kernel is 5.4, which makes me wonder.

VmMon and VmNet may not be properly installed. How about forcing them to re-install via:

vmware-modconfig --console --install-all

And see if that helps?

dansch2002@Sylvia:~$ sudo vmware-modconfig --console --install-all
[sudo] password for dansch2002:
[AppLoader] GLib does not have GSettings support.
Stopping VMware services:
VMware Authentication Daemon done
Virtual machine monitor done
make: Entering directory ‘/tmp/modconfig-OhK75M/vmmon-only’
Using kernel build system.
/usr/bin/make -C /lib/modules/5.4.0-105-generic/build/include/… M=$PWD SRCROOT=$PWD/.
make[1]: Entering directory ‘/usr/src/linux-headers-5.4.0-105-generic’
CC [M] /tmp/modconfig-OhK75M/vmmon-only/linux/driverLog.o
CC [M] /tmp/modconfig-OhK75M/vmmon-only/linux/driver.o
CC [M] /tmp/modconfig-OhK75M/vmmon-only/linux/hostif.o
CC [M] /tmp/modconfig-OhK75M/vmmon-only/common/memtrack.o
CC [M] /tmp/modconfig-OhK75M/vmmon-only/common/apic.o
CC [M] /tmp/modconfig-OhK75M/vmmon-only/common/statVarsVmmon.o
CC [M] /tmp/modconfig-OhK75M/vmmon-only/common/vmx86.o
CC [M] /tmp/modconfig-OhK75M/vmmon-only/common/sharedAreaVmmon.o
CC [M] /tmp/modconfig-OhK75M/vmmon-only/common/cpuid.o
CC [M] /tmp/modconfig-OhK75M/vmmon-only/common/task.o
CC [M] /tmp/modconfig-OhK75M/vmmon-only/common/moduleloop.o
CC [M] /tmp/modconfig-OhK75M/vmmon-only/common/crosspage.o
CC [M] /tmp/modconfig-OhK75M/vmmon-only/common/comport.o
CC [M] /tmp/modconfig-OhK75M/vmmon-only/common/phystrack.o
CC [M] /tmp/modconfig-OhK75M/vmmon-only/bootstrap/monLoaderVmmon.o
CC [M] /tmp/modconfig-OhK75M/vmmon-only/bootstrap/monLoader.o
CC [M] /tmp/modconfig-OhK75M/vmmon-only/bootstrap/vmmblob.o
CC [M] /tmp/modconfig-OhK75M/vmmon-only/bootstrap/bootstrap.o
LD [M] /tmp/modconfig-OhK75M/vmmon-only/vmmon.o
Building modules, stage 2.
MODPOST 1 modules
CC [M] /tmp/modconfig-OhK75M/vmmon-only/vmmon.mod.o
LD [M] /tmp/modconfig-OhK75M/vmmon-only/vmmon.ko
make[1]: Leaving directory ‘/usr/src/linux-headers-5.4.0-105-generic’
/usr/bin/make -C $PWD SRCROOT=$PWD/.
make[1]: Entering directory ‘/tmp/modconfig-OhK75M/vmmon-only’
make[1]: ‘postbuild’ is up to date.
make[1]: Leaving directory ‘/tmp/modconfig-OhK75M/vmmon-only’
cp -f vmmon.ko ./…/vmmon.o
make: Leaving directory ‘/tmp/modconfig-OhK75M/vmmon-only’
make: Entering directory ‘/tmp/modconfig-OhK75M/vmnet-only’
Using kernel build system.
/usr/bin/make -C /lib/modules/5.4.0-105-generic/build/include/… M=$PWD SRCROOT=$PWD/.
make[1]: Entering directory ‘/usr/src/linux-headers-5.4.0-105-generic’
CC [M] /tmp/modconfig-OhK75M/vmnet-only/driver.o
CC [M] /tmp/modconfig-OhK75M/vmnet-only/hub.o
CC [M] /tmp/modconfig-OhK75M/vmnet-only/userif.o
CC [M] /tmp/modconfig-OhK75M/vmnet-only/netif.o
CC [M] /tmp/modconfig-OhK75M/vmnet-only/bridge.o
CC [M] /tmp/modconfig-OhK75M/vmnet-only/procfs.o
CC [M] /tmp/modconfig-OhK75M/vmnet-only/smac_compat.o
CC [M] /tmp/modconfig-OhK75M/vmnet-only/smac.o
CC [M] /tmp/modconfig-OhK75M/vmnet-only/vnetEvent.o
CC [M] /tmp/modconfig-OhK75M/vmnet-only/vnetUserListener.o
LD [M] /tmp/modconfig-OhK75M/vmnet-only/vmnet.o
Building modules, stage 2.
MODPOST 1 modules
CC [M] /tmp/modconfig-OhK75M/vmnet-only/vmnet.mod.o
LD [M] /tmp/modconfig-OhK75M/vmnet-only/vmnet.ko
make[1]: Leaving directory ‘/usr/src/linux-headers-5.4.0-105-generic’
/usr/bin/make -C $PWD SRCROOT=$PWD/.
make[1]: Entering directory ‘/tmp/modconfig-OhK75M/vmnet-only’
make[1]: ‘postbuild’ is up to date.
make[1]: Leaving directory ‘/tmp/modconfig-OhK75M/vmnet-only’
cp -f vmnet.ko ./…/vmnet.o
make: Leaving directory ‘/tmp/modconfig-OhK75M/vmnet-only’
Starting VMware services:
Virtual machine monitor failed
Virtual machine communication interface done
VM communication interface socket family done
Virtual ethernet failed
VMware Authentication Daemon done
Unable to start services

Same results (see above)

Hi Vasileios! Nice to meet you :slight_smile: I’ve seen you in so many videos. I was referring to one of the comments using VMware’s vCenter Converter to convert a physical machine into a virtual machine. That was the product that was discontinued. I wanted to do it that way because I have a laptop with Windows freshly installed on it already. So I have used your instructions to set up a VM on my Ubuntu laptop and once I go to open my Windows VM, the VMware totally shuts down.

I did some further research on the matter and - in some cases - a couple of commented out commands are what causes this issue. There are a few people that encountered this, so one guy did the corrections (and follows the files directly from VMware) and posted it on GitHub in the following address:

If you have not used GitHub before, you can utilize:

sudo apt install git

Since you already have the development tools available (for compilation), that should be the only utility you will need.
Once installed, go to a downloads folder and type in:

git clone https://github.com/mkubecek/vmware-host-modules.git

It will clone the entire folder and you can:

cd vmware-host-modules

From there, you can use:


Or open it with via the default text editor (since it’s long, so that you don’t have to scroll). The instructions are old, but the files are up to date, so the versions should be changed to the latest ones, which are 16.2.3.

In short, you can immediately initiate the modules by typing:

wget https://github.com/mkubecek/vmware-host-modules/tree/workstation-16.2.3
tar -xzf workstation-16.2.3.tar.gz
cd vmware-host-modules-workstation-16.2.3
sudo make install

If that works for you, then you might consider replacing the original installed tarballs with the ones you picked up from GitHub. First, make sure that you are in the vmware-host-modules-workstation-16.2.3 directory and execute the following:

tar -cf vmmon.tar vmmon-only
tar -cf vmnet.tar vmnet-only
sudo cp -v vmmon.tar vmnet.tar /usr/lib/vmware/modules/source/

If you ever need to re-install them (or didn’t install them to begin with), you can do so - with the new tarballs via:

sudo vmware-modconfig --console --install-all

I hope this approach will help.

Hey @KVS!
This happens because the Virtualization option of your CPU is not enabled in BIOS. You will need to restart your system, enter your BIOS and enable it from there. Once done, then your VM will work as intended. :slight_smile:

I am just now revisiting this issue.
I tried steps and settings above and it is still crashing. I also installed VMware tools in terminal and it still crashes upon trying to open.
I have uploaded some screenshots below.
I did a search for issues and some people have talked about a setting in the BIOS that needed to be changed on some computers.