Install Mint on Windows system - set up for Dual Boot

Hi - I am trying to install MINT OS on a HP Spectre. I have tried to partition the disk drive to allow for Windows and Mint to run. However, when I try to install Mint the partitions are not visible and I cannot proceed with the install unless I overwrite the entire disk drive, which I do not want to do. Would someone kindly direct me how to achieve this.

Thank you

I tried to set up a new drive (D) for Mint.

however, I cannot find the partitions in the Mint install

for some reason the 1TB drive with windows partitioned won’t mount in the Mint OS. I am not sure if that is supposed to be the case or it is because of file formats.

@analyst1776, could you clarify; are you trying to set up Mint on the same physical drive as Windows?

yes, the 1TB drive visible on the screen shot above.

It looks to me like you made a virtual drive. If you are trying to dual boot, you just shrink the Windows volume and don’t format it or anything.

I did shrink the windows volume and had the remaining space “unallocated”, it still was the same situation. When I go to install Mint, there are no visible partitions. All I see is the 1TB physical drive, even though it has partitions visible in the Windows environment.

Oh. I am sorry, but that is about as far as my knowledge goes on that topic.

@vasileios will probably be able to help.

Hey @analyst1776!
And thank you @Tacodogg for the tag!
@analyst1776 - I would recommend you re-assign the entirety of the drive back to Windows (C:) and reunite the partitions into one. When you enter the Linux Mint installation process, tell it to install Linux alongside Windows and it will do the separation for you.

Thanks for your help @vasileios I know I am in good hands.

I reunited the entirety of the drive back to Windows (C:). However when I enter the Lint installation process I do not see any option to install Mint alongside Windows or for any separation to occur. Please see screen shots below.

1 Like

when I select ‘install now’ this is the prompt I receive:

when I select ‘new partition table’ this is the prompt I receive:

when I select ‘continue’ this is the next prompt:

this is the view form ‘Disks’ application:

If I try to format the disk this is the prompt I receive:

still stuck here.

@vasileios help a brother out please!

Hey @analyst1776!
I’m on the finishing line for the behemoth trilogy on Arch and Gnome (first segment was published yesterday, second one by tomorrow, and third on Monday), hence my delay. I’m a bit zombified, so I apologize.

I see your system has Intel RST enabled? I’d recommend entering your BIOS and changing the drive controller to AHCI. However, if you do so, your Windows will complain, provided that it’s installed in there. If you don’t have it installed, I’d recommend installing Windows first (with the AHCI controller setting) and then launching the Linux Mint installation process. At that point, it will recognize that there’s another OS installed and it will offer you the option to install Mint alongside it.