Having inssues installing MS On My Virtual Machine

I have Virtual Box running POP OS Gnome very new to all this using USB with MS 10 recommended from here seems to be doing nothing for a very long time now

Help pleASE

VirtualBox is a good solution. However, in terms of hardware (and options) support, including increased performance, I would recommend VMware Player.

We have a tutorial here on how to do it effectively. :slight_smile:

Ok I know I have been at this literally all day. I tried that earlier and I just did it again. Here you go screen shot,what am i doing wrong? Hence why I went to the other one which also did not work but I just keep trying I get a win here and there hopefully you guide me to one with this PRETTY PLEASE!!!

I just checked VMware and it appears that they updated their version, hence the names no longer work.

What I would highly recommend is that wherever you see the name (in the code I include) that says:
Do not type the entire version number. Instead, press TAB, and the system will recognize the file automatically. If it doesn’t then press TAB again so that it shows you all the available files that share the name.

As of the moment of me writing this, the file name has changed to:

Ok I am using Virtualbox I gave up on VMplayer now I get as far as created the VM and when I try to load the MS 10 from USB it is not finding it Remember I am a complete beginner at Linux. Desperate to get this resolved so I can get off my Windows machine and convert it to linux for my hubby! I took a few days away tried again got a little further now having this issue

Hey @Rkppersonal!
You don’t need an actual USB to install Windows on any Virtual Machine. Just the ISO file, which you direct your VM (at the settings of your Virtual Machine) to add it as a CD/DVD ROM device. :slight_smile:

2 weeks but I finally got it tonight via the iso file cause USB would not work !!! YEA !!! Step One now I have to get quickbooks on it Hopefully that is a simple process LMAO BUT I Persevered and got it!!! YEA!

1 Like

Awesome! Nobody said it would be easy, but then again, nothing worth doing ever is! Bravo!

Ok it works great but apparently QuickBooks does not every time I download QuickBooks to it it crashes quits stops or something. I do not think QuickBooks works in it. Are you aware of it working in it? I have not factory reset my computer and redone the Virtual 3 times ( Now an expert lolo ) no matter what QB will not work if it does not work then I will do QB online I guess which sucks mush more expensive, The the question is I want the VM to keep my gmail and QB separate from all other new stuff. Being an absolute beginner at this seemed like the best way or am I wrong? (PROBABLY but still committed)

I haven’t tried QuickBooks as an app, though it would save me ages when I do the corporate taxes. I have the online version. Though I know that TurboTax for corporations runs on the VMware version of Windows. I haven’t tried it on VirtualBox.

Vasileios, I’m trying to set up VMware on my updated kubuntu 22.04. This latest version stops the install with this notification: “Before you can run VMware, several modules must be compiled and loaded into the running kernel.” Hitting the “Install” button gets me this: “Build environment error! A required application is missing and Modconfig can not continue. xzCheck the log for more details.” OK, what now? BTW, this version of Kubuntu 22.04 did not give me an option of manually partitioning my hard drive and so I don’t really know if this is going to work in the long run with a Windoz 10 install.
Thanks again for all your help. I’m working on three different computers today and seems like I’m finding little glitches in each one.

Hey @Mike19!
You remind me of the time I was prepping a course for configuring Gnome. At that time, there was a major update and blew me out of the water, forcing me to postpone the last section. :laughing:

Your case is simpler though. The compilation requires to have development tools installed, which is why VMware protests. I’ve tested it lately and they have updated their kernel support to the latest version, so it’s all good with that.
To get the development tools, all you need to do is open up the terminal and execute the following:

sudo apt install build-essential

Once that is done, try to run VMware again and see how it goes. :slight_smile:

OK, I got further down the road on my Surface laptop. Still running Kubuntu 22.04 with the KDE Plasma desktop. The Kernel Module Updater still complained that it was missing a couple of modules: i.e. vmmon and vmnet. I started the install process and it was interrupted by this warning: “unable to install all modules. See log /tmp/vmware-talon65/vmware-13182.log” for details. (Exit code 1) Without sending you a screen shot of about 1000 lines of code, I think what it’s complaining about is the 5.15.0-40 kernel. It is reading in “symbol versions” to the vmmon/vmnet modules and ends up with invoking /sbin/modinfo and exiting with status 256. My guess is that something is still missing from the kernel?
Also of note, I ran a sudo update/upgrade on my VAIO, and both my ASUS and Surface laptops this morning and none of them now allows for switching between virtual windows by ctrl/alt/righ/left arrow. All of them were working that way before the upgrade??? I also added the kde plasma desktop to my ASUS laptop trying to make all three computers function the same. Life is like a box of chocolates, you never know what you are going to get. All three function differently using the same software. The ASUS laptop now boots into a virtual keyboard looking for my log on credentials; once I minimize it the plasma log in screen appears and we go from there. I’d like to get rid of the keyboard popping up. I’ll start looking for plasma forums and see if anything comes up that might help with that issue.
Thanks for all your help. Hope you got some time off over the 4th and enjoyed time with your family. I read somewhere that Vasily in Russian means king; does that translate in Greek to Vasileios?

Hey, @Mike19!
In short, yes, Vasileios originates from the Greek Vasilias which indeed means king. Also, Vasileio means kingdom. Though these are semantics that I don’t take much into account. We are what we do in life. :wink:

Per your continued issue, let’s see if your kernel is missing the headers portion, which is necessary to compile modules. I’ll add an extra utility in there, just in case. Open up a terminal and execute the following:

sudo apt install dkms
sudo apt install linux-headers-$(uname -r)

Then try VMware again and see if it produces the same issue.

Well, I think what you are doing in life pretty much makes you “The King” of linux knowledge. You need a little emoticon of a penguin wearing a golden crown. Your new lms on nextcloud looks fantastic! That one is really going to blow my mind. Are you sure you don’t want to copyright your pdf document? That could turn into a very useful book that might make you some money.
I solved the problem of the virtual workspace switcher. The updates must have reverted the shortcut keys to their default value. I had to manually go back into the system settings and reassign the keys that I wanted to use for workspace switching. In the process of researching, I was trying to download some additional wallpapers and on my Surface laptop I kept getting and error that said I had too many occurances of streaming going on. I found out that is a known bug in KDE. But it reminded me of the errors we’ve been seeing while trying to get the proton vpn to work, where it times out with 10 tries.
I’ll try the code you suggested in the morning. I’m still concerned about not having the option to manually partition the hard drive during the installation of 22.04. it left me with a logical volume that took up the entire disk. We’ll see how that goes.
Thanks again, I don’t know where you find the time for my little nit noys (as the Vietnamese called them) while you are working on such a massive project.

1 Like

OK, it installed dkms, but claimed I already had the latest linux-headers and did nothing. Got the same result when trying to install vmware. I could be that 22.04 is still too much on the bleeding edge to make this work. Apparently, vmmon and vmnet are still the missing modules.

1 Like

Hey @Mike19!
I admit I had to run several tests to verify that NextCloud would be flawlessly installed. I didn’t want it to be faulty as personal and private files are important. Last thing I wanted was to give you guys something that won’t work or risk you losing your data. I verified every aspect of it and it works perfectly. I am now using it as my own cloud solution as well.

Per the VMware modules, that is troublesome. We know it’s not the kernel and it’s not the development tools you have. So, let’s try to dig deeper this time. Open up a terminal and execute the following:

sudo vmware-modconfig --console --install-all

It will most likely fail, but it will give you the exact errors that are happening. Can you copy and paste them here? (or take a screenshot)

Vasileios, you were right; it failed. I’m not sure where the log is that you need me to copy. I took a look at the vmware-installer log from a few days ago. It looks like it had problems from the start. “GLib does not have GSetting / Unable to install modules”
“[AppLoader] GLib does not have GS / Failed to setup build environment” Then it appears to try and make some sort of correction "Attempting to change symlink /usr/lib/vmw and then into “Installer running / Command Line Arguments:” It cycles through this 10 times and gives up. That’s the same behavior as the protonvpn-cli installer where it goes through the 10 cycles and then gives up. I did save the terminal session into a text file. Let me know where I can find the log that you need and I’ll send it along as well. Thanks

Hey @Mike19!
Let’s see if we can get past this. Thank you for posting the output. :smiley:
Open up your terminal and execute the following command:

sudo apt install libglib2.0-dev libglib2.0-dev-bin

And then retry with VMware and ProtonVPN to see if that helps.

1 Like

Vasileios, thanks for your persistence. I’m still getting the same results. I did find the boot log, I think. It’s called syslog. When I try to copy it, I only get the part that is on the current screen instead of the whole thing - which I doubt you’ve got time to dig through with all you’ve got going on. I think I see something in there that looks suspicious: “Starting LSB: This service starts and stops VMware services” followed by “Started crash report submission” then “Started Network Manager Script Dispatcher Service” “kerneloops.service: Found left-over process 1029 (kerneloops)” then further down I see “Starting VMware services:” then “whoopsie.service: Deactivated successfully.” then “Virtual Machine monitor#033[71Gfailed” Another one is “Disable MBO/OCE due to misbehaving AP not having - (can’t see the rest of the line).” There were other failures during the boot up process that don’t show up in this log. Something about the GRUB not reading all of the different kernel versions. Here’s the offended part of it "Memtest86+ needs a 16-bit boot, that is not available on EFI, exiting. Warning: os-prober will not be executed to detect other bootable partitions. Systems on them will not be added to the GRUB boot partitions. Check GRUB_Disable_OS_Prober documentation entry.

There must be something wrong with the new 22.04 kernel; but that’s only my uneducated guess. I’m kind of like a chicken looking at a watch; it’s interesting but I don’t have a clue as to what I’m looking at.

BTW, here’s an off-topic question for you. I’ve been all over the forums looking for a decent answer but none of them get it quite right. How do you change ownership for a new external hard drive that’s just been formatted to ext4. Mine has root as the owner and I couldn’t copy files to it until I did the chown command and got it to accept files to copy, but it still shows (in Dolphin) that root is the owner???

Thanks for all you and Jeff do. I am a licensed ham radio operator, but have been inactive for awhile. That was really interesting about the LoRa mesh, makes me want to get back into the hobby. Just not enough time I’m afraid.

1 Like