Dual boot question

I have Linux installed next to windows on a HP laptop. Everything works great but shouldn’t it give me an option at startup as to which OS I want to start? It doesn’t and I want it to.

Hey @Mikeybob!
Is it Linux that is installed and doesn’t allow you to boot into Windows?
If yes, which distro have you installed?

The original OS is windows 10. I partitioned the hard drive and installed Linux mint cinnamon. When I turn the pc on unless I hit the esc button and change the boot order, it goes straight to windows and doesn’t give an option for the Linux os.

In that scenario, you’ll need to go into your Mint, open up a terminal and execute:

sudo nano /etc/default/grub

Look for the GRUB_DEFAULT parameter, which should be changed to “=0” - if other than zero. In short, make sure you have the following parameters:


This will have the first option selected, and give your GRUB 5 seconds of menu before it continues.

Once you perform the updates, execute:

sudo update-grub

–to implement these changes.

I have this………

Do I still need to change the timeout to =5 ?
What does the timeout style=hidden mean ?

The time out as I know it is just the time you have to push which one you want before the default boots.
What was your GRUB_DEFAULT before you changed it? Just wondering because the second OS installed is the one that boots first.
Did you get it figured out?

The grub default was 0 I didn’t change it. I did change the timeout from 10 to 5 and implemented the change. Haven’t rebooted the machine yet to see if I have an option to start Linux or windows.
Windows 10 came on the laptop and I recently installed Linux but am keeping windows also (for now). I will eventually remove windows.

As I’m seeing your GRUB configuration file, you could comment (put a # at the beginning of the line) the GRUB_TIMEOUT_STYLE=hidden.
This will make the Menu appear when you boot.

Once you so that and save (CTRL+O then Enter, then CTRL+X to exit), then execute:

sudo update-grub

Then reboot.

Are you saying the line should look like this? With # in front?

Exactly. The # will negate the command and allow the boot menu to be visible.

Did that and upon reboot it went to windows without an option to start Linux. Had to restart and change boot order to get into Linux. out of curiosity, using Gparted, I looked at the partitions. I don’t have a swap partition! What’s the safest way to correct this? please bare with me, i’m green at this stuff.

1 Like

I restarted the laptop tapping f10 and went into the boot menu. I noticed in the boot order, windows boot was above Linux. I just assumed that meant windows had priority. Using the f6 key, I swapped them so that Linux is on top. Saved and exited. Restarted the laptop and low and behold the screen showed up to give me the option to start Linux or Windows. I will admit I don’t know a lot about computers but being a 65 year old machinist, I can figure it out eventually.
Thank you very much to those that helped me out along the way.

1 Like

Hey @Mikeybob,
When your system has enough RAM, the installation can bypass the creation of a SWAP partition. So, it’s perfectly good. If you, however, do start running out of RAM, then we can arrange to create a virtual memory partition for you. It’s not hard, but just has a little process to do it. :slight_smile:

That is awesome!
Yes, Linux does take a bit of patience, but once you solve it - it is one of the most rewarding feelings. Congratulations!

@vasileios, as time permits, would you take a look at my Windows 7 Pro/Linux Mint Cinnamon dual partition issue? I’ll tag you in the thread. Many thanks, Steve

Hey Vasileios,
Hoping you are doing well.
I’m having similar issues with my MBP. Installed Mint, updated, upgraded and rebooted. All good. Installed Ubuntu and after that I get no grub menu and only boots to Ubuntu. I tried all the above including update-grub. Still no grub on boot. Reinstalled Mint (Replaced) and now no grub and only boots to Mint. Thinking I’ve forgotten something basic about Macs. I’ve had dual boot on this computer before with no problem. I have quad boot on the HP laptop and runs flawlessly with full list in grub every bootup. I tried the above from terminal in Mint with the same results.

Hey @GrillerMiller!
You’ll need to go on ahead and edit the grub configuration file, which is at:


You can do this by:

sudo nano /etc/default/grub

Look for the line that has the following:


And make it look like:


Save and exit (CTRL+O & Enter, then CTRL+X).

Also, you can set the menu timer:


If all the above don’t work, then try to look for (or change/add) the following line:


Last, but not least, make sure you have OS-Prober installed:

sudo apt install os-prober

Once that is installed, go back to:

nano /etc/default/grub

Move to the end of the file and make sure the line reads:


Save, exit, and then execute:

sudo update-grub

And you should be set.

Thank you for that. Except still no grub. However for timeout I have =10 which shouldn’t be a problem. In fact, when grub should be displayed there is a 10 second pause with nothing but a solid cursor. Then boots to Mint. I’ll send a snapshot of the nano screen.

I was able to arrow down twice and hit enter during the 10 second pause, still blank screen, then it booted to Ubuntu instead of Mint. Seems its there but still hidden.
“quiet_splash” ?
If I comment out that line, what happens?
I’ll answer that. Still no grub but displays the boot and shutdown.

Hey @GrillerMiller!
Do you have OS-Prober installed? Also, for it to work, there’s usually a commented line at the very end. Were you able to check that out?