Won't Boot into Linux

Folks, I promise I’ve attempted searching here yet may have missed an answer so forgive me potentially repeating this problem. Long story short I successfully installed Linux Zorin onto my Lenovo laptop as the only OS and was so pleased I thought I’d install it onto my Desktop but on a separate HD so windows and it would be completely separate. Well the USB stick worked as always, created my HD partions (A 3tb HD) and proceeded to load Zorin onto the HD. Install went well etc. Now comes the issue. From the USB I can run Zorin no worries but nothing I do will get my Desktop to start Linux. No matter what, the system always boots into Windows. Mother board is an ASUS and it is old (2010) but runs well and it knows all about UEFI. It sees the UEFI Ubuntu HD and of course also sees the UEFI Windows HD not to mention the ATAPI Old CD drive etc… I also have the Boot Order set with the Ubuntu HD first inline (laughingly I tell it to use windows LAST after all other things have been tried) but NO MATTER what , the system boots straight into Windows. Re-Install the USB stick, choose USB on boot-up and Linux opens from the stick. (This is the Try it and install it USB) Although I wanted to keep Windows for a while (my business computer so am chicken but…) I’m about at wits end and may completely erase all Windows stuff from the other hard drive (as in reformat removing any mention) and try another install…but really? How is this possible. OK, thats it. Any thoughts are more than welcome. I appreciate all the help, Sincerely, Price

Hey Price/@Pridanc !
The reason your system boots directly on Windows without an option for Zorin is that, during installation, the bootloader (Grub) was installed on the second drive and not the main one.
One quick way of doing it is to hold down the Escape key (or F10, depending on the shortcuts your BIOS gives you) to bring up the Boot Menu (outside of BIOS) and then select the second drive, where you have Zorin installed. Once you select it, your Zorin boot menu should appear and you can boot into it.

Once your Zorin loads, login and start a terminal. Type in the command:

lsblk

Please take a picture/screenshot of the output and post it here (you can drag and drop it on your response window here to attach it). I’ll need that one to identify the actual names of your drives. What we’ll do is to install Grub (Linux bootloader) onto the Windows main boot. It will then identify all operating systems and install an option to boot either into Linux or into Windows directly from when you start your system, without having to activate the hardware boot menu. :slight_smile:

1 Like

Vasileios, many thanks for jumping in to help but I’m not sure this is the problem but I’m game to try?

The reason I say this is because of your own words “bring up the Boot Menu and select the drive where you have Zorin installed.” I’ve done that not to mention I have the Zorin drive as the first drive for the system to use. See the picture. The lower left shows the drive with Zorin as first.
20220109_105024

And even when I bring up the Boot Menu to manually choose, as you suggested, no matter which line I choose (not including the windows one as that is obvious) only Windows opens.

When I have the Zorin USB stick in place and boot up the machine, bring up this Boot Menu, I can see the USB stick. Then when I click on that USB choice the machine starts into Linux.

As I’m typing am I just now noticing that there is something odd here in the Boot Menu? Why does the Ubuntu line not mention the actual hard drive like the other lines do?

Of course, equally as strange to me is that you can see in the first picture the UEFI Ubuntu disc is in order to be picked first. (and the UEFI Window disc is last)

Moving on, I’m happy to boot into Zorin using the USB stick and then type in the command you show above (lsblk) to get you that information so let me know.

I am so grateful for your help in this.

Hey @Pridanc!
You’re very welcome!
On the actual drive description, you will notice that the same thing goes for the Windows Boot Manager. The others are just the hardware devices themselves. If you select them, your system will try to find if there is any boot sector on them, that’s why you see them as hardware descriptions.

Now, there is another issue that might be going on. More often than not, when Windows does an update, it overwrites the Linux boot sector, which results into only Windows loading. This is rather common.

You might want to boot from the Zorin USB, then go to the menu and type in Boot Repair and run it to repair the most common issues. Chances are this will fix your issue quite fast.

Otherwise, we will go manual (via the lsblk). :slight_smile:

Valileios, sorry for the delay but I’ve been away which means not next to the computer we are trying to get to run Linux (Zorin)
Here is a copy of the lsblk report.

FYI, Boot Repair brought up this screen which didn’t help me so I’ve run the lsblk report per your request. I include this as it may be a clue.


So many thanks. Of all the forums I’ve visited and asked, your is the first to appear to read and consider options before responding. TY for that! Price

Thank you for posting both captures, @Pridanc!
I see your main boot drive being the sda (with the sda1 being the boot partition). There will be a bit of a process to “root” into your current Zorin installation. However, before we do that, I’ll need to make sure which partition we’ll need to root into.
From your live USB, can you go to the start menu and run the Disks application?
Once you do, please select your Linux installation drive. A long bar (which is rather thick) will appear on the right side of the window, with 4 sections/partitions. Can you select all four and send me a photo of each?
From a first glance, I assume:

  • sdd1 is your Zorin’s boot sector
  • sdd2 is your swap file
  • sdd3 is your root/system partition
  • sdd4 is your /home partition.

I’ll need a confirmation to know where we’ll be rooting so that we can source Grub’s configuration before we install it on the Windows boot manager area.

Vasileios, I’ve included 5 pictures. One to show “all” off it. The next four show each partition as you requested.
All


Partition 1

Partition 2

Partition 3

Partition 4 (last partition)

Thank you kind sir! Let me know what to do next and I’m on it.
Sincerely Pridanc

Thank you so much for posting the pictures!
Can you please mount Partitions 2 and 3 and open each on your file manager to see the directory structure (just the top level)? This is a rather unique setup of partitions.

Thank you!

Vasileios,
Thanks for the response but I’m not sure how to do what you ask.

I’ve always admitted that I’m ignorant but trainable! Which means I can follow directions. I’m one of those who want to use a tool, but other than fixing my mistakes, I have no desire to know how to make the tool!

I will check this forum more often but I used to get a notice when you (or anyone) responded but not this time as I’m here only because I just happen to look.

Sincerely, P

Hey @Pridanc!
The mount process sounds like a mountain, but it’s actually simple.
Open up the Disks application, just as you did before and press the “Play” button right under the big bar of the right panel. Do that for the Devices /dev/sdd2 and /dev/sdd3 that you’ll see right under the Size of each partition.

Once you mount them, the partitions will be in one of the following locations:

/mnt
/media/your_username - (your_username will appear as your actual user name)

When you spot them, please take a screenshot of the directory of each so that I get an idea of what is included in each.

Vasileios,
Thanks for the guidance. Once I did as you mentioned, I find that only one of the two partitions you requested info on has anything in it? Let me know your thoughts and TY.




All the best, Pridanc

Hey @Pridanc!
Thank you for sending out the screenshots!
These partitions appear quite odd if I may say so. Especially since your /dev/sdd2 is completely empty. Can you execute the following terminal command and send me its output?

sudo parted /dev/sdd

I’d be interested to see if the list it produces has the “boot” flag on the first partition of the drive.

By the way, when you first installed Zorin, did you go for manual partitioning?

Vasileios,
Don’t forget, since I do not know what I am doing, clear directions are most often needed. Here is the screen I entering the info you suggested . I see nothing but you might?

And yes I manually created the partitions following directions from the Zorin Forum. I am more than happy to do something else as this has been tough. FYI, I also manually created partitions on this laptop I am responding to you from and it works just fine. It is likely I’ve done something wrong but have no idea what that might be.

I just had a thought but I may be simply forgetting what happened during the install. This laptop has only one hard drive but as you can see, my desktop has several with the clean 3tb drive the one I’m trying to use for the Zorin install. Could it be that the install is using more than one HD confusing itself or did I have to choose which HD for Zorin to install when I chose “Install”?

OK, I realise my questions may be silly and apologize for that.
TY, Pridanc

Hey @Pridanc!
On your command, you’ll need to leave a space between parted and /dev/sdd.

As it comes to your system, how many operating systems do you have installed?

Per the manual partition, I generally recommend it only for advanced purposes. The ideal setup for this would be:

  1. 512MB or 1GB for the boot partition (mounted at /boot)
  2. A swap partition equal to the size of your RAM (it has no mount point)
  3. A root folder for the entirety of your system drive (mounted at /)
  4. Select the installation of GRUB on your default, main boot drive (normally the SDA)

Hey Vasileios,
If you look at that previous picture you will see that I did add the space and I ran it again and from that you can see the results.f

Here is how I setup the HD manually.

Let me know how to run the sudo parted /dev/sdd in a way that could help you better?

And again, feel free to tell me to erase the HD completely and to start over.

There are 3 HD’s on my desktop and one of them carries Win10. I’d like to leave it this way until I’m 100% happy with Zorin and my understanding of Linux on this office computer before I erase Windows. I’m HAPPY to do that now since we are all struggling to get the computer to start the Zorin HD…when starting Zorin from the USB stick is simple.
All the best and I can not thank you enough for helping.
Pridanc

Hey @Pridanc!
First, you’re very welcome!
Second, thank you for all the detailed screenshots you posted! Now I get the full picture per the boot failure.

I’ll begin with the /dev/sdd1 and the Boot Loader as those two go together.
In order for your installation to work, you’ll need to set it up as either an ext4 or fat32 and select its mount point as /boot. This means that the partition will need to be formatted. This is what hinderes you from installing the boot loader on that specific partition. However, if you install Grub (Linux Boot Loader) on /dev/sdd1, every time you want to boot into Linux, you will need to do so from the BIOS boot menu, which can be an inconvenience.

In general, the Linux boot loader should be installed on the same device where your Windows Boot Manager is installed. From there, Linux will detect all the operating systems you have installed and will produce a startup menu for you to select which OS you want to boot into.

Something to keep in mind is that some of Windows 10 updates will overwrite the Linux boot loader, so it’s good practice to always keep your Zorin USB available, as it comes with a Boot Repair app that will restore everything (once you boot from it).

Next is your virtual memory, or swap.
The way the /dev/sdd2 will not behave in the way you wish it to. Swap files do not need mount points, so the /swap will not function as an ext4 format. You’ll need to select it and change the partition type to swap for it to work.

Let’s now go to the rest.
If you separate the root partition (mount point /) and your home folder (mount point /home), you may soon encounter low space issues on your root area. That’s because every app you install, including all temporary files, shall go into that partition. So, unless your system is lean and you do not seek to compress or de-compress huge files, space will become an issue sooner or later.

Since you have a rather big drive, I’d recommend you assign at least 100GB for your root (/dev/sdd3) partition, so that you are comfortable for anything you’d wish to install.

Finally…
This is just for safety, just in case something happens and “the peanut butter hits the fan.” When you boot from your Zorin Live USB, select Try and open up the file manager. Go to Other Locations and open up the additional, small drives/partitions it has in there until you find the one that holds the EFI folder. Use a blank USB and copy that entire partition to it. That folder will contain the Windows EFI file. Believe it or not, if your boot partition ever gets corrupted (FAT32 is not exactly the most reliable file system), all you have to do is format it as bootable from Linux, and just copy/paste that folder back in and Windows will once again boot. That’s for an absolute worst-case scenario if you happen to accidentally delete the boot loader partition or if it fails at any point. :slight_smile:

Please let me know how it goes!

TY for your response Vasileios.
I am now at the point of starting over and here is why.

I appreciate you and all the help you’ve provided, along with many other good people, but there is always an issue when someone with computer knowledge try to help others who have zero knowledge. There is so much left out and there are way too many assumptions. I know I am great at following directions but they have to be complete, as in every single step.

I’ve been lucky enough to write instruction manuals for more mundane things and always from the point that the persons reading are metaphorically blind. As in I intentionally give them all the words it takes to get from point A to point B without them falling and getting hurt along the way. There can be no room for assumptions or incorrect thoughts. Every piece of information is complete, exact as to what is needed, and explanations if they are needed otherwise left out to keep the guidance clear, exact and to the point.

Anyway, thank you for your incredible patience and I know you will continue to help many way smarter than me. I will move on to some other way to make this work and at the moment feel that erasing all HD’s, creating a new USB installation drive is, fingers crossed, the only way this will work. Too much is missing here so I will let the installation create all the partitions it needs to work.

I will never understand how the computer will start into Linux from the USB stick (after choosing it in the BIOS) yet will not start from my choice of the Linux HD installation from within the BIOS (just like the USB stick) an installation which was ironically from the same USB stick that booted up! This does not compute to this old dinosaur.

I will be forever grateful for your words and guidance.
Pridanc.

1 Like

Hey @Pridanc!
It is only natural that you’re going through this process. We all learn best through trial and error. That’s my story as well. In the beginning, I was afraid I’d mess up the bootloaders and would install different operating systems by disconnecting the other drives. After the trials, I found what works best and now I’m running 3 operating systems on the same bootloader. I can reach it as high as I want, but it does require a bit of caution.

The automatic process, especially when you only have two operating systems, is quite straightforward.

Per the step-by-step, each system has a different setup. In your scenario, you have multiple drives and you’re installing on the last one. Others want to separate partitions on the first drive. Other wish to do so on the second drive. Hence, each time the setup differs. :slight_smile:

Please let me know if you need anything further.

Vasileios,
I’m baaaack. :grin: OK, so here is what I’ve done.
Cleaned off my 3tb hard drive.
Pulled my other two drives out of the computer
Started the computer into Linux via the USB Zorin Linux stick.
Installed Zorin on what is now the only HD in my computer. I let the install do everything by itself with no personal intervention. By that I mean I did not manually partition the HD but let the Zorin install make all its own choices. Once done the computer said to reboot and I did.

Of course I got nothing but this screen:


So I entered the BIOS utility to pick what I wanted the computer to start with. This first picture shows Ubuntu as the first thing for it to look at but what was odd is that it still shows Windows Boot Manager? What? Windows no longer exists on this computer. nor any other drive for the computer to see so how is this possible?

I went into the BIOS Utility and told it that the Windows boot manager was gone. See the very bottom of this picture where Boot Option #3 (Used to say Windows Boot Manager) has been disabled.

So now when I open the BIOS utility to pick what I want the computer to use at startup you see this:

And the box two to the right of the UEFI Ubuntu disc says N/A when you touch it with the pointer.
The computer will still not boot into Linux by itself at startup but nor will it boot into Linux when I go to the boot menu which STILL mentions Windows Boot manager. :rofl:

However, all in all I’m in a better mood since we only have to get the computer to open Linux from the one hardrive that is here.

Lets all remember that the computer boots into Linux perfectly from the USB Stick so what is the installer not doing to the HD that stops the computer from starting into Linux by itself or even after I specifically tell it to start “Ubuntu”?

Here is a look at the three partitions made by the USB Zorin installation stick on my 3tb drive



Here is a look at the files on the drive:

Vasileios, I can feel that we are almost there so lets keep on pushing!
All the best,
Sincerely,
Pridanc

@Pridanc,

You are so right. Man, I feel your pain. I wish I could shout this from the rooftops…

“there is always an issue when someone with computer knowledge try to help others who have zero knowledge. There is so much left out and there are way too many assumptions. I know I am great at following directions but they have to be complete, as in every single step”

I try to do all my own research when I hit a wall in my Linux education and I cannot tell you how frustrating it is to be told to type <something something --etc> into The Terminal with no explanation as to what each part of the command means or what it is doing; or you get explanations that use words like “distro” or “server” or “bash” and just assume everyone knows what those words mean. I end up going down a rabbit hole doing research on top of research, until I forget what it was I was trying to do…