Won't Boot into Linux

Dear goodness… I just saw that I had a draft response on this topic that I was never able to send - due to the overwhelming schedule. I so apologize for this.

Also, @Minty - thank you for posting and reviving this topic so that it came back to my attention.

Generally speaking, it all depends on what it is one needs. There are so many BIOS versions and computer configurations out there that’s impossible to keep track - let alone have a respective system to run all the tests. For a long time I’ve been erasing my three laptops back and forth, just to be able to get more information. However, this turned out to be quite time-consuming, which made me lose track of the responses I wanted to give.

Each laptop has undergone around 12-14 distros so far! I eventually picked up several SSDs and installed a different distro on one desktop system, two different ones on the two laptops and one more laptop is still a guinea pig.

Eventually, I bought another two desktops so that I can do my standard work!

In any other scenario, one can always search “what is…” and fill in the blanks. However, the information out there is enormous - and it gets easier when there’s a preset goal as to what someone wants to achieve.

Keep in mind that a lot of people know the solutions, but even they don’t know (or choose not to tell) all the details about each command. It can be time consuming.

For the terminal side, I have the some of the basics explained here:

Imagine, it’s about 1 hour long and I only cover the basics.

Also, if you are part of the LMS, there’s a 3-part series for Arch Linux, which may be one of the toughest distros to install, but I take the time to explain every command and every option in there in layman’s terms.

@Pridanc -
1 MB for the boot sector isn’t enough to store the basic RAM Disk. Normally, the minimum size for the sda1 should be 256MB (I tend to put in 512MB or more - for safety).

What I would recommend is to perform a new install of Zorin - if you’re still up for it. First, select the “Try Zorin OS” and pull the files (by copying your home folder into an external drive) via the File Manager.

Then, run the Install icon on the desktop and go through the process until it asks you for the partitioning. I recommend doing a manual one.

Select your 3TB drive and then select the “Reclaim Space” (if applicable - as it has been some time since I installed Zorin) Select the existing partitions and remove them all. Then, create the following Partitions:

Mount Point: /boot
Size: 512MB
Type: FAT32 (or DOS/EFI Boot)

Type: SWAP
Size: 50% the size of your RAM should do the trick
This one has no Mount Point.

Type: EXT4
Size: The remaining size of your drive
Mount Point: / (root)

At the bottom, it should have the location of the BootLoader installation. It’s a drop-down menu. Select it and you will see the Windows Boot Loader (Manager). Select that one.

Then, continue with the installation normally. Next time you restart, you will be presented with the Grub BootLoader, which will give you the option of either booting into Zorin or into Windows.

Keep in mind that some Windows updates may overwrite the Grub BootLoader, which will disable your ability to boot into Zorin. That’s where the Boot Repair App comes in handy.

1 Like

Just subscribed to your Rumble and Truth Social.

Did I mess up by giving sda1 only 1MB?

Hey @Minty!
First of all, thank you!
Second, it’s best to give the boot area at least 256MB of space, for all intends and purposes.
As you correctly went into Gparted, you can select to release a GB from the beginning of /dev/sda2 and then resize your /dev/sda1 to occupy that space. Then, you will be fine.

However, make sure you do this from a Live USB disk, as you can’t intervene on the drive structure of a running system. :slight_smile:

Eυχαριστώ Vasileios,

Before your reply I did try to resize my partitions, but got the warning about making my system inoperable, so quick exit out of that.

I still have my Ubuntu ISO on USB. As I am nervous about screwing up, would you be so kind as to to list the steps needed.

Να είσαι καλά, @Minty!

If done from a Live USB, the resizing does not produce any issues - and I’ve performed this before several times. So, I’m not sure why you got that message.

In any case, we could avoid resizing the system partition and simply slide it. For that to happen, we’ll need to resize the data partition, making it 1GB less.

In short, the steps are:

  1. Select your /dev/sda3 and right-click on it to select “Resize/Move”
  2. Make it 1GB less and choose to free the space from the beginning of the partition (this may take time, since it’s the biggest partition)
  3. Select the /dev/sda2 partition, right click on it and select - again - “Resize/Move”
  4. This time, slide the partition to the right, so that it creates a gab between itself and the boot area (you won’t see the boot partition on the slider window just yet)
  5. Select the /dev/sda1 partition, right click on it, and again hit the "Resize/Move’ option
  6. Drag the right side of the partition bar on the new window until it covers all available space
  7. Once the above are done, hit Apply and go for a cup of coffee - as it will take a while.

If you get any warnings, please take a screenshot and post them here. :wink:


The warning came up because I tried to resize while using my system, not from a live USB.

I did not expect a reply so quick… I thought you would be resting up for the Beginners Workshop.

I’ll try to do the resize tomorrow after I have created a backup.

Εκτιμώ ότι πάρα πολύ

1 Like

Hey @Minty!
I picked up a comms laptop, so I don’t have to re-cable or move stuff over and over again. So, my response times have gotten a bit better. That - of course - will depend on how my schedule will go in the near future. :smiley:

The notice you received when you initially tried the resizing is correct. In general, do not try to perform and drive changes on the system you are actively on. Do it from a different distribution (that utilizes a different drive) or from a Live USB. :wink:



1 Like