Wifi Not Working with Kali on Mac

I am using a WiFi adapter (AWUS036ACS) to connect to the internet but am receiving a “device not ready”. I want to use this as a replacement for the internal Broadcom WiFi due to issues with outlined in this post. The Broadcom WiFi connect typically needs a system reboot in order to work. My goal is to leverage the AWUS036ACS as the primary device for WiFi, but the adapter doesn’t register.

I followed this tutorial, it worked initially, however, it no longer registers.

Bus 001 Device 002: ID 0bda:0811 Realtek Semiconductor Corp. Realtek 8812AU/8821AU 802.11ac WLAN Adapter [USB Wireless Dual-Band Adapter 2.4/5Ghz]

Operating System: Kali GNU/Linux Rolling
Kernel: Linux 5.15.0-kali2-amd64
Architecture: x86-64
Hardware Vendor: Apple Inc.
Hardware Model: MacBookPro12,1 :computer:

Hey @labeef and welcome to the forums!
On Kali, there is a dedicated driver that is reported to work with your adapter:

sudo apt install realtek-rtl88xxau-dkms

After installing, either reboot or disconnect and reconnect your adapter.

If that doesn’t work, we’ll need to compile it from source:

sudo apt update
sudo apt install git build-essential libelf-dev linux-headers-`uname -r` debhelper dp


cd ~/Downloads
git clone https://github.com/aircrack-ng/rtl8812au
cd rtl*
sudo make dkms_install

Then you can reboot and give it a shot. :slight_smile:

1 Like

Thanks @vasileios!

I was able to install compiling by source. However, the WiFi Network Realtek 8812AU/8821AU still says “device not ready”. I’ve disconnected from the WiFi Network Broadcom and Subsidiaries BCM43602 but it seems that is the only network that is available.

My goal is to use the Realtek 8812AU/8821AU WiFi adapter to replace the native Broadcom since it has much better coverage.

Do I need to somehow activate the Realtek device via the CLI?

Thanks again for your help! The videos are great!

1 Like

Hey @labeef and thank you for your kind words!
First, let’s disconnect your external WiFi. Then, activate your Broadcom and execute the following command (you’ll need Internet for that):

sudo apt install tlp

Once it installs, type in:

wifi toggle

Then connect your Realtek and see if it now works. If not, try:

sudo systemctl restart NetworkManager.service

And check again.

1 Like

Running the following commands seems moves the Realtek from “device not ready” to “disconnected” which seems to be what I want. However, it does seem like I’ll need to do this every time I reboot.

sudo airmon-ng check kill
sudo systemctl restart NetworkManager.service

My WiFi network only appears under the “Connect to hidden WiFi network” option which displays the following error…

Connection is not available on wlan0 because profile is not compatible with device (mismatching interface name)

In short, the Broadcom Network displays my network NETWORK_NAME and NETWORK_NAME 1. I’m not sure why two versions show up which could also be another issue. It was working at one point but this duplicate network name seems to be causing the issue.

Thanks again!

Hey @vasileios,

I was able to remove my main network through network config options. However, it seems like my wlan0 network access point is associated with the Broadcom MAC address.

wlan0     IEEE 802.11  ESSID:"NETWORKNAME"  
          Mode:Managed  Frequency:5.785 GHz  Access Point: BROADCOM:MAC:ADDR
          Bit Rate=24 Mb/s   Tx-Power=31 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
          Link Quality=59/70  Signal level=-51 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

wlan1     IEEE 802.11bgn  ESSID:"STRANGE_UNICODE"  Nickname:"<WIFI@REALTEK>"
          Mode:Managed  Frequency:2.437 GHz  Access Point: REALTEK:MAC:ADDR   
          Bit Rate:72.2 Mb/s   Sensitivity:0/0  
          Retry:off   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=100/100  Signal level=-27 dBm  Noise level=0 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

Is there a way to associate the wlan0 with my Realtek WiFi adapter?

Hey @labeef!
Changing the device name can be a tricky one, especially when there are two of them. However, you can try to cycle them around (by temporarily renaming wlan0 to wlan2 and then shifting it to “1” when you make wlan1 into wlan0).

One pathway I found for it is in the following article, but I don’t have a system with two WiFi devices to check it out.


(It’s for the Raspberry Pi, but the distro is based on Ubuntu as well)

1 Like