WiFi Issues

I’m new to Linux. Turned on the laptop this afternoon and have no internet access. Installed Mint about two months ago. All has been working great. I was on a Jitsi meeting more than a week ago and all was well. When I check for my network the following morning, I was told it was unavailable. I made sure all updates are installed. Restarting the laptop didn’t help. Restarting the WiFi didn’t help. I checked the Driver Manager, and the driver is there. A suggestion I found online is to dump the network manager and use the wicd alternative. Tried this and got the message ‘Package wicd is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source.’ Next line is, ‘E: Package wicd has no installation candidate’ Any other ideas? Can I just install another driver from Stream? I have looked and tried various suggestions here, and found no solution. My last option is to start with a different laptop and install Cinnamon, but I’d like to understand what the issue is so I can fix it before moving to the next laptop conversion.

We’re you running a VPN, specifically Proton?

2nd, if you’re internet won’t work, package search/install won’t work unless you download the package to a usb then bring it to the down system. Caveat, using dpkg install sometimes fails on dependencies that are not installed and you have to apt install them and reinstall the pkg

Back to Proton:

If this was the case, open a terminal an run up link show

Post output.

Also you can run lspci to check if your network card is listed.

Is this a laptop, brand?

Older HP I found had an issue of no internal BIOS battery and relied on laptop battery. Possible solution, shutdown, unplug, remove battery for a min or two, reinstall battery and boot, enter BIOS and set the correct time and date, save and exit and boot normal.

Hope some of these help!

Thank you so much for your reply! Not using VPN at this point, but checked anyway (since someone else set this up for me after running into issues beyond my experience) and there definitely is no VPN running,
I ran lspci and came up with the info below with specs on the network card close to the bottom? Like I said, I’m new and just getting me feet wet,
I have a Dell laptop with Linux Mint 20.3, Cinnamon 64-bit.
tee@tee-Latitude-E6420:~$ lspci
00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
00:19.0 Ethernet controller: Intel Corporation 82579LM Gigabit Network Connection (Lewisville) (rev 04)
00:1a.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b4)
00:1c.1 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 2 (rev b4)
00:1c.2 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 3 (rev b4)
00:1c.3 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 4 (rev b4)
00:1c.5 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 6 (rev b4)
00:1d.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation QM67 Express Chipset LPC Controller (rev 04)
00:1f.2 RAID bus controller: Intel Corporation 82801 Mobile SATA Controller [RAID mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 04)
02:00.0 Network controller: Broadcom Inc. and subsidiaries BCM4313 802.11bgn Wireless Network Adapter (rev 01)
0a:00.0 SD Host controller: O2 Micro, Inc. OZ600FJ0/OZ900FJ0/OZ600FJS SD/MMC Card Reader Controller (rev 05)
0a:00.1 Mass storage controller: O2 Micro, Inc. Device 8231 (rev 03)

Here’s other info I gathered in some of my attempts last week to fix the issue.tee@tee-Latitude-E6420:~$ inxi -Fxxxz
System:
Kernel: 5.4.0-125-generic x86_64 bits: 64 compiler: gcc v: 9.4.0
Desktop: Cinnamon 5.2.7 wm: muffin 5.2.1 dm: LightDM 1.30.0
Distro: Linux Mint 20.3 Una base: Ubuntu 20.04 focal
Machine:
Type: Laptop System: Dell product: Latitude E6420 v: 01 serial:
Chassis: type: 9 serial:
Mobo: Dell model: 0P6K8J v: A00 serial: BIOS: Dell v: A13
date: 05/17/2012
Battery:
ID-1: BAT0 charge: 45.9 Wh condition: 45.9/48.8 Wh (94%) volts: 12.4/11.1
model: Samsung SDI DELL 5CGM4A7 type: Li-ion serial: status: Full
CPU:
Topology: Dual Core model: Intel Core i5-2520M bits: 64 type: MT MCP
arch: Sandy Bridge rev: 7 L2 cache: 3072 KiB
flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19954
Speed: 798 MHz min/max: 800/3200 MHz Core speeds (MHz): 1: 799 2: 798
3: 798 4: 799
Graphics:
Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics
vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:0126
Display: x11 server: X.Org 1.20.13 driver: modesetting
unloaded: fbdev,vesa resolution: 1366x768~60Hz
OpenGL: renderer: Mesa DRI Intel HD Graphics 3000 (SNB GT2)
v: 3.3 Mesa 21.2.6 compat-v: 3.0 direct render: Yes
Audio:
Device-1: Intel 6 Series/C200 Series Family High Definition Audio
vendor: Dell driver: snd_hda_intel v: kernel bus ID: 00:1b.0
chip ID: 8086:1c20
Sound Server: ALSA v: k5.4.0-125-generic
Network:
Device-1: Intel 82579LM Gigabit Network vendor: Dell driver: e1000e
v: 3.2.6-k port: 4080 bus ID: 00:19.0 chip ID: 8086:1502
IF: eno1 state: up speed: 100 Mbps duplex: full mac:
Device-2: Broadcom and subsidiaries BCM4313 802.11bgn Wireless Network
Adapter
vendor: Dell Inspiron M5010 / XPS 8300 driver: wl v: kernel port: 4040
bus ID: 02:00.0 chip ID: 14e4:4727
IF: wlp2s0 state: down mac:
Drives:
Local Storage: total: 238.47 GiB used: 174.75 GiB (73.3%)
ID-1: /dev/sda vendor: Toshiba model: THNSNJ256GCSU size: 238.47 GiB
speed: 6.0 Gb/s serial: rev: 0101 scheme: MBR
RAID:
Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci
v: 3.0 port: 4060 bus ID: 00:1f.2 chip ID: 8086.282a rev: 04
Partition:
ID-1: / size: 233.18 GiB used: 174.75 GiB (74.9%) fs: ext4 dev: /dev/sda5
Sensors:
System Temperatures: cpu: 53.0 C mobo: 35.0 C sodimm: 41.0 C
Fan Speeds (RPM): cpu: 0
Info:
Processes: 252 Uptime: 3h 54m Memory: 7.65 GiB used: 3.11 GiB (40.6%)
Init: systemd v: 245 runlevel: 5 Compilers: gcc: 9.4.0 alt: 9 Shell: bash
v: 5.0.17 running in: gnome-terminal inxi: 3.0.38
trayce@trayce-Latitude-E6420:~$

Does your wlp2s0 show up under ip link show as well.

I see inxi reports it down but I think inxi reports the card even if the WiFi car is’nt up where ip link wont show the card if its off by rfkill switch or another issue.

Here’s what I get:
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eno1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP mode DEFAULT group default qlen 1000
link/ether d4:be:d9:4f:da:14 brd ff:ff:ff:ff:ff:ff
3: wlp2s0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000
link/ether 84:4b:f5:5c:21:be brd ff:ff:ff:ff:ff:ff

Ok, so obviously at this point in time you have intent on it working with the Ethernet right?

Does sudo rfkill list return any results.

If you unplug Ethernet can you access your WiFi through the network manager in systray, was it possibly disabled after an update or due to bad signal strength?

This looks like it’s just “off” with no UP in the <> and state showing DOWN, as in no IP address:

: wlp2s0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000

Typically any real issue you wouldn’t even see the wlp2s0

I’m hoping to get away from Ethernet since it cuts in and out. It’s currently not connecting either. WiFi shows as unavailable. No way to turn it on.
Here’s what I get when Ethernet is disconnected.
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eno1: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN mode DEFAULT group default qlen 1000
link/ether d4:be:d9:4f:da:14 brd ff:ff:ff:ff:ff:ff
3: wlp2s0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000
link/ether 84:4b:f5:5c:21:be brd ff:ff:ff:ff:ff:ff

Ethernet is back. It’s a new cord, so I know that’s not an issue with cutting in and out. It may be the port on the computer,

Some routers have a Wi-Fi on/off switch on them, check to make sure it wasn’t accidentally turned off as well, a quick check there would be any other devices currently connecting to the same Wi-Fi?

Can you try sudo ip link set wlp2s0 up
Followed by ip link show again.

Also, when was the lat power cycle of the router/Wi-Fi?

We have all of our devices connected and running without issue. I rebooted the router when I discovered the issue a few weeks ago. It didn’t resolve the issue. I can try that again now as my husband is working from the office today and I won’t dump him off-line!

Rebooting the router again didn’t correct the issue.

Here’s what I got:
tee@tee-Latitude-E6420:~$ sudo ip link set wlp2s0 up
[sudo] password for trayce:
trayce@trayce-Latitude-E6420:~$ ip link show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eno1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP mode DEFAULT group default qlen 1000
link/ether d4:be:d9:4f:da:14 brd ff:ff:ff:ff:ff:ff
3: wlp2s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UNKNOWN mode DEFAULT group default qlen 1000
link/ether 84:4b:f5:5c:21:be brd ff:ff:ff:ff:ff:ff

Ignore the tee/trayce. I didn’t see my real name in there to change :slight_smile: I should just use a great fictitious user name! Yours is a great one!! Proud to be a Deplorable!

1 Like

So i see you wlp inside <> reports LOWER_UP now, try scanning for a Wi-Fi connection an attempt to connect.

How do I scan for WiFi? Through the terminal? If so, I tried nmcli dev wifi list and got:
IN-USE BSSID SSID MODE CHAN RATE SIGNAL BARS SECURITY

I would just check the tray icon for the time being and see if your ssid shows up

Tray icon under network connection shows our WiFi network and that I was connected 14 days ago. When I go into network settings, it shows as unavailable, and I can’t turn it on. I’ve previously looked at the Network Proxy to see if there’s anything there that I could mess with. It’s currently set to manual. Is it as simple as setting this to automatic?
When I select that, I get a warning web proxy is used when a Configuration URL is not provided. This is not recommended to unlock for untrusted public networks.
Our network in locked, so no issue regarding security, but I feel like know enough to get me in trouble…so haven’t wanted to mess with anything in here without someone far more knowledgeable to help me.

When I’m in the Network Connections it shows the Ethernet wired connection that I’ve been using and the WiFi which shows ‘auto’ and lists our WiFi. Since this says auto, I assume it would auto connect, which is why I hesitated to set to automatic in the Network Proxy.