Volume Busy message that doesn’t resolve

When formatting the USB in to install Linux Cinnamon I get an message after download when I go to eject.

MacBook Pro, 2.2 GHz Quad-Core Intel Core 17
16GB 1600 MHz DDR3
Graphics Intel Iris Pro 1536 MB

Here’s what I’ve tried so far…

Formatted USB to Mac OS Extended (Journal) and downloaded:
• Etcher for MacOS
• Linux Mint OS – Cinnamon 64-bit (which is same as Mac I’m trying to install Linux on)
• Right Clicked on sha256sum.txt and sha256sum.txt.gpg and save link as and downloaded onto USB.

Files were saved as read only.

Reformatted USB to FAT32 ( a site said it works fine with Linux and Windows), and got a message:

“Volume in busy One or more applications are keeping the volume busy.
Cancel or eject anyway”

I waited a while to see if tit was a matter of a file that needed to continue to download, but no such luck.
I ejected anyway.

Next I watched a video (from this site) on creating USB with usbimager.
I deleted previous downloads from USB and downloaded:
• USB Imager
• Linux Mint Cinnamon

When I try to eject the USB I get the same message as before:
“Volume in busy One or more applications are keeping the volume busy.
Cancel or eject anyway”

I attempting to prep for replacing windows with Linux, I tried to access the BIOS and found Boot Mode is normal, so no BIOS.

I know that Macs may not have a BIOS, but EFI. Not sure what to do.

This may be silly to even ask… May be the USB itself is not happy?

And when you search online did you try “How you install Linux Mint on (your specific mac model and year)” and see if the videos you watched missed something or it’s not right for your machine and/or MacOS version…

This is a very odd issue indeed…

Thank you so much for your reply.
There are never silly questions…I wondered about the USB and have another I can try to use tomorrow. I’m actually downloading from sites using the USB on a machine that already has Linux Cinnamon on it. I used the same USB today to try other options for downloading Linux, and didn’t have the same issue. Today I seemed to be ‘missing’ the tools shown in videos, like a burn option for etcher, but I am very new at this and am sure it’s something I’m doing wrong or that I’m looking in the wrong place.
I did look for something specific to a mid-2014 Macbook Pro, but not specifically to the OS; that’s a good idea!!
I have someone who can install Linux for me, but they do it through Windows (I have no idea how or why they would do it this way, and I want to get far away from anything Windows).
Again, thank you for your thoughts. I’ll try them tomorrow!

I am not familiar with anything MAC OS related but this is the general idea.

When using a write program to create bootable disks for PC they are written for the majority share PC/Laptop systems which recognize fat32 formatting.

I cannot vouch for what MACs recognize. I would search specifically for your Macbook Pro model as I guarantee someone has already done a “write and install” from the stock OS.

Give this tutorial a read.

Thank you so much for your reply!
I’m slow to start on this today because it’s discouraging. Going to try fat32, which I recently read can also work with Mac.
Also trying a different USB.
I’ll definitely check out the tutorial.
Thanks again!

1 Like

I so understand feeling discouraged. It took me many weeks and lots of searching to get Linux onto my Chromebook. And I actually reverted to ChromeOS the last time to do the final install to help me understand the process the little better and to make sure it’s a clean install.

I’ve been on this for a year and had changed distros many times on the Chromebook… Once you’ve done a successful install, it will get easier each time you do it and even though on a different machine you might have different problems to solve, it won’t be so painful anymore.

Since I seemed to have more troubles with my installation than most, I had to dig further and that forces me to see and try more things with Linux. And everything does add up to what I can do and understand now!

I can’t wait to read about what steps you did to do a successful installation!

Well…my p/w wouldn’t work on the Mac…Why? I have no clue, so I wiped it. Now back to figuring out the creation of a USB. Really hope it’s smooth sailing once I manage that.

I reformatted the USB to FAT32. No errors or busy volume. I believe Linux Cinnamon is installing on the Mac…time will tell.

1 Like

What am I missing?
After erasing the drive I was able to through Disk Utility, I put the USB into the Mac and pressed command and R, then the power button, and that started the process. I was asked to choose my network and put in the P/W. There was a spinning globe as the process continued for about 13 minutes. I was told to hit return for English, and this took me to Recovery Mode where I had the option to reinstall an OS. Old Apple OS X was visible as was the USB stick, opened the boot folder. I clicked Restore and selected the USB for source and hit the image button on the right, selected Linuxmint-20.3-cinnamon and open. At this point, all files are locked despite having extracted them…
Put the USB in the other machine, deleted the unextracted version, and tried to eject the USB and I get the Volume Busy message again. Why would that be?
I’m thrilled that I’ve gotten this far…

I am a bit confused by your descriptions… Also assuming you are wiping out OS X for Mint

  1. Were you able to make an installation USB by using Etcher or USB Imager? (Asking just in case you were assuming you can use OS X’s recovery method to install Linux on a Mac… even if you chose the .iso file you downloaded…)

  2. If Yes for #1, right after power-on try the “Option” key to boot straight from the Installation USB…
    (this is Step 4 of the link @MrDeplorableUSA provided: How to Create a Bootable Ubuntu USB Drive for Mac in OS X)

Please also read this to understand the key-combo for Mac: A Quick Guide to macOS Boot Modes and Startup Key Combinations

Since many have gone down the same roads, it’s best to follow their steps when going through this as a newbie but always read through the entire instructions before trying… that saved me a lot of pain!

Imager. Since I wiped it, I didn’t think I needed etcher. SO I’ll go back to that and try the suggestions you’ve made.

Thank you!

Different USB.
Formatted to USB exFAT, which should work with Mac - Had the Volume Busy issue.
Formatted for Mac: OS X Extended (Journaled) - Nothing copied onto the USB because it’s read only. I unlocked it, and am still having trouble getting info. on it. I think this is the reason for the “Volume Busy” message.
I’ll try another brand USB tomorrow…

1 Like

Life has been very busy. I’m hoping to get to work on this tomorrow, but we’ll see…

1 Like

I would suggest you go back to the reply I made, read the entire tutorial GUI or CLI sections including the “errors”.

It was written to include that information because it didn’t fail.


1 Like

Thank you! That’s what I’d gone back to before my schedule went crazy again. Do I need to format the USB I’m going to try next with OS X Extended (Journaled)? Also, since the machine is basically wiped, I don’t have access to drag the Etcher download into Applications, so there are some steps I’m not sure how to accomplish with a basically wiped laptop. This is yet another day without time (or brain cells) and a meeting tonight, so perhaps I’ll get back to it tomorrow.

you are going to have to have functioning system to create the bootable USB. Is there another PC/Laptop that does work at this point?

I have a Mac desktop (that’s in line after the MacBook Pro). I’m on a Dell that’s got Linux Mint, but can’t format the USB to OS X Extended (Journaled), if needed, but can format the USB from the Mac desktop. Someone else took care of the Dell I bought specifically to learn on. Turns out there was an issue with it that was far beyond my experience.

This instructions for using a Mac want it “first” formatted for a Mac so the drive is recognizable on a Mac system to write a bootable USB for any system not just a Mac.

I suggest using the Mint machine to write it.

I can’t say for certain as I haven’t done a Mac but a bootable USB is a bootable USB across the board regardless for a PC/Laptop or Mac product.

Can anyone that’s done a Mac from a USB made on PC/Laptop confirm?

The installation USB I used on my Mac desktop is done on a Linux/Chromebook with Etcher… Just to be safe, I always formatted the USB in FAT (with zero out option) before creating, so I have a pure blank USB ready for Etcher…

So, I think you are right that the installation USB can be created on any OS/computer…

Thank you both. I’ll get back to creating a USB and go through the tutorial MrDeplorableUSA posted…I’m really new at this, so am sure I’ll have more questions.