VMWare Install

Vmware has installed. When I try to create a new virtual machine and click finish it gives me the following:

Unable to create virtural machine: No permission to perform this operation.

What do I need to change?

Hey @bbrlou77,
Are you running VMware from a fully installed Linux distro? The reason I’m asking is that you would normally get the permissions issue if you were running from a Live USB. :slight_smile:

I am sorry, I should have let you know the distro. I am running Ubuntu Budgie 21.10 on a Lenovo G510 computer. No USB.

Ah, if it’s the 21.10 version, which is the short-term version, it’s likely you would be encountering mundane issues. These short-term editions are like the testing grounds for the next big upgrades of the LTS ones. I would recommend you go with the 20.04 LTS version of Ubuntu Budgie. Besides, this coming April the next major LTS will be released (22.04) - so you can upgrade to all the newest bells and whistles under a stable environment. :wink:

Should I try the 20.04 LTS and not the 21.04 LTS?

I guess there is no Ubuntu Budgie 21.04 now. I believe there use to be. :slightly_smiling_face:

Yes, each .10 version replaces the intermediate .04 one. So, the 21.10 replaces the 21.04. Similarly, the 23.04 will be replaced by the 23.10.

So, yes, the 20.04 (not the 21,04) will definitely work with VMware (I installed it on two different 20.04 based systems - one Ubuntu and one Zorin). :slight_smile:

Thanks for your help. Merry Christmas!!

I tried it with Ubuntu budgie 20.04 and get the same message.

I tried it this morning. I appeared to load but it kicked out of VMware when it finished. I restarted and open the virtual machine and nothing.

When I “Power On” the virtual machine the VMware terminates.

1 Like

You can call me if you want. 405.520.2786

Hey @bbrlou77!
Merry Christmas indeed! Again, I apologize for my delay. Festive seasons take a toll on time, especially in families. :slight_smile: Something I am getting used to here in the US, as I’ve been more on the solo side when in Greece.

I looked up this strange issue you’re facing and it comes out that it can pop up in a variety of situations. One of them being the firewall. However, since you’re on a new installation and you’re getting the same message, I am ruling that out. Here is something that I believe applies to the issue you’re having:

VMware stores a list of virtual machines under /etc/vmware/vm-list - which, at times, even when you remove the virtual machines, the references still stay there. Try to remove them and give it another shot.

In some cases, you might spot some .lck files, which are the locks that deny access (permissions).

Thanks for responding. I though maybe you went home for Christmas. I have reloaded everything and it still quits when I power on the virtual machine. I have taken a screen snapshot of /etc/vmware but I am not sure how to send it to you. There is no vm-list and no lck files. Also there are two other directories /etc/vmware-installer and vmware-vix. The /etc/vmware-installer directory has a lck file. When I open it, it shows blank. The vmware-vix has a bootstrap file which points to /usr/bin. /usr/bin has several vmware directories.

I went back to scanning the internet. There was one forum where someone mentioned enabling something virtual in the Bios. So I checked the computer Bios.There was a single item called Intel Virtual Technology which had to do with the virtual. It was diabled. I enabled it the booted the system.

I started Vmware and the virtual machine ran. I let it run but it terribly terribly slow. I had to stop it but the linux desktop was running slow so I rebooted the computer. I haven’t ran Vmware again yet but at lest I am making progress.

1 Like

Same issue here, am running Linux Mint 20.2 x86_64
I installed Windows 10 Pro, when I try to run, nothing. I have another machine that is a dual boot, that runs the VMWARE fine from the same Mint installation. Not sure what is different.

Update: I went into BIOS - Enabled Virtual and now it seems to be working. My machine is a Lenovo ThinkPad Intel i7.

1 Like

VMware is running. When I try to run the virtual machine for Windows 10, I created, It gives me a not enought memory error.

Hey @bbrlou77!
Can you open up a terminal and execute the following command?

sudo apt install inxi

And then please send the output of the following command?

inxi --full

Thank you!

Is there any way I can send you a file?

Host: lou-Lenovo-G510 Kernel: 5.11.0-43-generic x86_64 bits: 64
Desktop: Budgie 10.5.1 Distro: Ubuntu 20.04.3 LTS (Focal Fossa)
Type: Laptop System: LENOVO product: 20238 v: Lenovo G510
serial: <superuser/root required>
Mobo: LENOVO model: INVALID v: 31900058WIN
serial: <superuser/root required> UEFI: LENOVO v: 79CN50WW(V3.09)
date: 10/20/2014
ID-1: BAT1 charge: 33.3 Wh condition: 33.3/42.8 Wh (78%)
Topology: Quad Core model: Intel Core i7-4700MQ bits: 64 type: MT MCP
L2 cache: 6144 KiB
Speed: 2322 MHz min/max: 800/3400 MHz Core speeds (MHz): 1: 2504 2: 2405
3: 2511 4: 2316 5: 2426 6: 2408 7: 2481 8: 2497
Device-1: Intel 4th Gen Core Processor Integrated Graphics driver: i915
v: kernel
Display: x11 server: X.Org 1.20.13 driver: modesetting
unloaded: fbdev,vesa resolution: 1366x768~60Hz
OpenGL: renderer: Mesa DRI Intel HD Graphics 4600 (HSW GT2)
v: 4.5 Mesa 21.0.3
Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio
driver: snd_hda_intel
Device-2: Intel 8 Series/C220 Series High Definition Audio
driver: snd_hda_intel
Sound Server: ALSA v: k5.11.0-43-generic
Device-1: Qualcomm Atheros AR9485 Wireless Network Adapter driver: ath9k
IF: wlp2s0 state: up mac: ac:b5:7d:88:e2:ce
Device-2: Qualcomm Atheros AR8162 Fast Ethernet driver: alx
IF: enp3s0 state: down mac: f0:76:1c:6b:2c:98
Local Storage: total: 931.51 GiB used: 18.91 GiB (2.0%)
ID-1: /dev/sda vendor: Western Digital model: WD10JPCX-24UE4T0
size: 931.51 GiB
ID-1: / size: 915.40 GiB used: 18.91 GiB (2.1%) fs: ext4 dev: /dev/sda2
System Temperatures: cpu: 83.0 C mobo: N/A
Fan Speeds (RPM): N/A
Processes: 277 Uptime: 8h 29m Memory: 7.68 GiB used: 2.01 GiB (26.2%)
Shell: bash inxi: 3.0.38

Hey @bbrlou77!
Via the forums, it would depend on the filetype and its size. What is it you wish to send?

Per your system, it has a decent amount of RAM (8GB), with 2GB utilized by the system. One worthwhile notice is that you have an on-board graphics chip (Intel), which operates on the main RAM as well. That normally variates between 1-2GB on average. Saying it’s 1GB, you have 5GB total of available RAM - minus whatever VMware is utilizing for its interpreters.

How much RAM do you allocate on your VMware Windows?