Unable to mount / unmount USB drives in Zorin OS 17

Edit 2: – MYSTERY! Read post below this one :grinning:

Edit 1: – SOLVED ISSUE #2. Thank you @Narcosis

Sorry, I jumped the gun. I should have checked for similar issues. The following instructions solved my issue. I now mount the USB drives to my user space.

– Original Post Below –


I have a fresh install of Zorin OS 17 and I’m loving it with the exceptions listed below.

  1. My external monitor does not work even with the latest NVidia drivers, in X11 or Wayland.
  2. Trouble using USB disks (expanded below as this has priority over the issue #1)

I’m experiencing an issue with not being able to mount or unmount USB drives. I have tried 2 different drives that used to work in Elementary OS and in various USB ports but nothing helps. It says I need root access to mount or unmount the drives. The “disks” app indicated that the drive was owned by root.

Gparted shows a warning message when I attempt to format the drives to fat32. I can format to NTFS or ext4. However, if I use ext4 then the command line mount command complains about the drive type when using the following command:

sudo mount -t ext4 /dev/sdb1 /media/usb -o uid=1000 -o gid=1000

What formatting should I be using for backup disks for my home folder as well as for Timeshift backups? Should it be ext4 or fat32 or some other format?

I have attached hwinfo output for your reference as well as a screenshot of the output for “getfacl /media”. What additional information can I give you? Any assistance you can provide will be most appreciated.

Thank you for your help!

hwinfo.txt (4.5 KB)

Screenshot from 2024-01-15 12-37-06


While applying the instruction above (Edit 1) solved my issue, which was that I was prevented from mounting and unmounting USB drives, all of a sudden I was again able to automatically mount to “/media/$USER/” without any trouble.

So, it appears that there was a glitch in the system that apparently corrected itself! This is disturbing as I don’t know how to recreate the issue and I don’t know how it was magically resolved.

Having said that, Zorin OS is a pleasure to use and I find that I can do many things using a graphical UI based app that I used to do on the command line in Elementary OS. I highly recommend Zorin OS for new comers to Linux. It installs most of the stuff that you would need to install yourself on other distros and makes your tech life a little easier.

While I’m comfortable using the terminal, I prefer not having to use it at all, if I can help it. Zorin OS brings me closer to that ideal.

I am still unable to get an external monitor to work though. Back into the breach! :grinning: