Unable to locate package <package_name>

Folks, I upgraded my Ubuntu to 22.04 and now my Brave browser is dead. The app comes up but won’t go anywhere… not even to it’s own Extensions. I get Error 159 no matter what I do. I also get a pop-up that says VirtualShield has crashed.
(I had tried VirtualShield briefly a long time ago but their version wasn’t working for me on my version of Ubuntu. I never bothered to figure out how to remove it.) i tried to uninstall V/S but I get the error in the title.
Don’t know if that’s my ultimate problem or not as I also tried to remove Brave and I get the same error “Unable to locate package Brave”.

I"m still able to surf via FireFox. Thinking of doing a clean install as there are other packages I want deleted but I had some articles in an online cart that I didn’t want to lose and would really like to complete that transaction before I wipe everything clean.

Any guesses as to how to get my Brave browser working ?

thanks
David

The post at the bottom of this page may help you.

Hey @Omega_Man and welcome to the forums!
In reference to what @Phobos posted, I believe it has to do with the upgrade process. The repositories change when the upgrade is done, so, it is wise to disable any extra repositories added from the Software Utility before commencing the upgrade. I’d think that Ubuntu had it automated - which is most likely the case.

Nonetheless, I installed Brave live on Ubuntu 22.04 in one of our Live LMS Workshops, so I know it works. What you can do is go to your Software Center, find the Brave repository (it’s probably disabled) and remove it entirely. It will ask you to run a database update, so accept it and close the window.

Then, go to this post:

And follow its instructions to run the script. It will refresh everything and Brave will be up and running again. :slight_smile: