Ubuntu wifi drivers for MacBook 2011

Hi there have been trying to sort out the correct driver for my MacBook pro 2001 as the one I am using seems a bit unstable. Someone left the answer on our telegram chat but its completely over my head to execute the information they listed. I just don’t understand the computer terms and terminal commands. Could you help me figure out the driver and how to install? Thank you.

[In reply to Jeffrey Peterson - jeff.pro]
I installed PoP_OS on my 2011 MBP and its working great. Only hiccup was it did not recognize my wifi so i had to plug into my ethernet directly to download the driver. This link helped me locate what driver i needed to find and install.
I was able to figure out that this is my hardware

1 Like

I had a similar issue with my mac. I found that mint and ubuntu did recognize the WiFi card but did not enable it. In Mint I went to Administration → Driver Manager and enabled the Wifi. Smooth sailing since :slight_smile:

Thank you. I think I need a new driver but it was kind of you to try to help.

This is what Ubuntu has for the driver :
Using Broadcom 802.11 Linux STA wireless driver source from bcmwl-kernel-source (proprietary)

Hey Suzanne Its Mike, the one who posted the article on telegram about the drivers. You are so close. Based on the screen cap above your wifi card is [14e4:4331] if you go back to that article and follow the steps again youll see it on that list.

at the point where you install the driver the command will read as follow:

sudo apt-get install firmware-b43-installer

Keep going, you got this.

1 Like

This line is the one from the list that identifes your wifi card and shows the driver you need.

Thank you, Mike. It was so kind of you to take the time to help. I’m having a hard time with this because I went into software update/ drivers and chose not to use the old driver for the wifi. When I rebooted the internet no longer works even though I am plugged into a cable and see good strength. I’m sending this from another computer. I tried to go back to software/drivers to install the old driver but it keeps timing out. I’ll keep trying.

I must have deleted the file completely because now my Ubuntu sees the hardware but can not connect to the internet even with a cord. When I go to Software and update it shows the driver but when I choose it nothing happens for a long time then it times out. I’m really stuck. Can anyone help? Is there a way to get it from another computer and copy to USB. I’m so confused!

Hey Suzanne, Not sure what the best course of action would be at this point as im still new to this as well. As a last resort maybe redo the install of ubuntu. Im currently running PoP_OS which is working well on my mac. Maybe someone else with more experience can chime in to help sort this out. Sorry I cant be of more help.

Thank you. I must have done something wrong. I’ll try to repost and I will look into PoP OS. Perhaps it’s better suited to our machines. It was kind of you to take the time to try and help me.

1 Like

Also look at Linux Mint. Lot of people say to use Ubuntu but it has more issues than the rest. Mint is a real good one if all you are doing is putting it on a computer.

Did you get it to work?

No. I’m so confused. It won’t even boot to the usb. It sees the net connection until I boot into Ubuntu and thats my only os. I bought it used so I don’t have the os disks.

Anyone who’s interested to make those pesky Broadcom WiFi drives to work, here’s the ZIP file for the firmware required. Download it, uncompress it, then enter the folder via terminal and type:

sudo ./install.sh

If that doesn’t work, then type:

sudo bash ./install.sh

Here’s the firmware file:
firmware-b43-installer.zip (30.4 KB)

1 Like

Hi @vasileios
Took the plunge & Ubuntu now running on my iMac 2013, but having I guess the same issue as in this thread. Currently cabled in to get internet, which is working fine, but no wifi. Searches through Troubleshooter and askubuntu aren’t giving me quite the right answers.

Your response seems like what I need, but still too new to quite understand how to follow the instructions you’ve mentioned. Just to be sure as well…is the process you’ve mentioned above what I need for what I’ve got below?
Network controller: Broadcom Inc. and subsidiaries BCM4360 802.11ac Wireless Network Adapter (rev 03)
Cheers in advance

And a follow up…ended up partitioning in Ubuntu Zorin. I guess they may have done extra work on wifi drivers, as I connected to my wifi without having to do anything. It was already indicated in wifi options through Zorin. So a plus for them.
Meanwhile…I think I’m also starting to understand how to use Terminal. Uploading Brave now! Woohoo!!

1 Like

@vasileios might be stupid question, but how am i supposed to download this file, if i have no internet?

Im asking on different computer.

When i installed Zorin i had Wifi working perfectly, but im still looking for distro to keep and want to try Budgie

thank you

1 Like

@vasileios while i was trying Budgie from USB i managed to get Wifi working, by clicking on Broadcom from Software/Updates menu, so i decided to install and replace Zorin, and now when i do the same after installed, get message "cannot download packages whilst offline (257)

What can i do?
thank you

1 Like

That’s always the trick with the WiFi installation. Always have an Ethernet cable at the ready to connect your system with your router. Otherwise, it will be a lot of trial and error to grab files from another system via USB (as every time a new dependency may pop up, which means a new download!). :slight_smile:

However, I believe you have solved it (in another thread), so, congratulations! :smiley:

1 Like

I hope this solves the problem I have in Mint

Thank you!

1 Like

Once the correct firmware/driver is installed, it will work for all distros. :slight_smile:

1 Like