Ubuntu 20.04.3 - no Wifi adapter / no Bluetooth!

I did a clean install of Manjaro. The ‘run pamac’ option does nothing at all. I found an option to enable AUR, found some random nvidia options, but they just sit forever checking conflicts, etc.

I think I’ve reached the end of the line with this.

Thanks again for your patience and assistance. Muchly appreciated!

The reason it’s seemingly sitting forever is because it’s compiling a lot of stuff in the background. However, there’s another way to install the Nvidia drivers. I have it as a tutorial here - in case you decide to stick around.

Nothing to lose! I’ll give it a go!!

1 Like

I’m always at your disposal, should you need anything!


Don’t forget to send me that Nvidia tutorial!! :nerd_face:

I really appreciate your willingness to help others pick all this up. Can obviously be a minefield!! So important we build our own alternatives to the Big Tech oligarchs. It’s happening! Social media, indie journalists, failing MSM, blockchain, truth being exposed (election fraud, fake pandemic/vax mandates, US borders) etc. etc. Exciting, though difficult, times! Once one domino falls…

Linux is definitely our future. Especially if the community can get it going on mobile devices, with an easy migration path for app/game developers. Unity will be a big part of that - very indie dev focused.

If I can’t get this going with one last try, I’ll def keep my eye on Unity etc. in the Linux sphere. They seem to be getting there.

This forum is a good place!

Darn! My brain got side-tracked, didn’t it?!

The tutorial is here and it should work exactly the same with Manjaro. I know because I did it on Arch (the “father” of Manjaro).

Keep in mind: The command to install DKMS on Manjaro is:

sudo pacman -S dkms

As Manjaro uses pacmac instead of apt. :slight_smile:

And yes, helping people and having them smile at the end of the day - well… it makes my day. Honestly. They say that “If you want to see a good change in the world, then become that change.” - In short, it’s the “Lead by example” approach. :slight_smile:

1 Like

One thing’s not clear - you mention driver manager … how do I get to that?

Driver manager is for the Ubuntu/Mint distros. You don’t have to worry about that. As long as you haven’t attempted to install Nvidia on your fresh Manjaro Installation, you should be fine.

1 Like

“Be the change you want to see in the world” :innocent:

1 Like

I ran thru your tutorial - I think it worked ok but here were some errors that I couldn’t easily copy/paste (and they were long).

I think the driver was installed ok (although I’m not sure Unity is behaving any better)- how can I check which driver is installed?

Normally it shouldn’t produce any errors, but let’s check nonetheless.
From your menu, type in nvidia-settings - if the driver was installed correctly, it will appear and show you which GFX card you have with all the extensions (and versions) installed.

I assume you mean in the console…

ERROR: NVIDIA driver is not loaded
ERROR: Unable to load info from any available system

Here we go again.

There were 2 different lines starting with ‘linux /boot/vmlinuz’ (not kernel), so I entered a 3 (after a space) at the end of both of them. They both already had a 3 (something like ‘settings3’ - can’t remember)

I’ll do another clean linux install…

But I’ll need you here if I do the Nvidia setup again, so I can tell you what’s happening =)

We’ll have to setup the timezones then! Yesterday I wasn’t on the forums as I’m working non-stop to finish a video for our LMS platform. :slight_smile:

What’s LMS?

If you’re around this afternoon / evening (your time) I’ll do the clean install now

Did a clean Manjaro install so can do Nvidia drivers any time that works for you.

I have the downloaded Nvidia file.

I’m 17 hours ahead of you, so if you want to know what the future looks like, I’m your man :wink: :stuck_out_tongue_winking_eye:

LMS is the Learning Management System. It’s a set of courses we have for $20 subscription, where we add courses every week (and has weekly live Workshops).

You’re in the future indeed! :smiley:

I’ll be around today, so we can get through with it. :slight_smile:

First, I would recommend you open up a terminal and run:

sudo pacman -S dkms

This will set the pre-requisite app to install the driver module.


Ok so I’ve booted and added a 3 to the end of the line in the GRUB boot parameters.

Interestingly, only one line this time… so far so good

So during the process I have a message:

WARNING: Unable to determine the path to install the libglvnd EGL vendor library config files. Check that you have pkg-config and the libglvnd development libraries installed, or specify a path with --glvnd-egl-config-path.

The only option is ‘OK’ so I chose that…