Ubuntu 20.04.3 - no Wifi adapter / no Bluetooth!

Hello!

Brand new to Linux.

Just installed Ubuntu 20 on a new laptop - replaced Windows completely.

Horrified to find that there is no WiFi adapter so can’t connect to internet!

Also no bluetooth!

More than disappointed and alarmed.

Can anyone help?

Hello @ObergonSteve and welcome to the forums!
There’s no reason for concern, this can be common in quite a few scenarios. Can you please let me know of the exact model of laptop that you have?

Also, please boot into Ubuntu, press your Windows key and type in the search bar: terminal.
Open it up, maximize the window and type the command:

lspci

Can you take a photo with your phone and upload it?

Hey Vasileios! Thanks for coming to the rescue haha.

Trying to take the plunge and ditch Microsoft and Apple for good. Wasn’t expecting to be digging into the world of drivers etc. but I guess that was naiive of me. =)

Laptop is ASUS ROG Zephyrus 14in FHD 144Hz R7-5800HS RTX3050 512G SSD 16G RAM

Photo to follow:

That’s one really beautiful system! And loaded! :wink:

Since it’s a brand new one, it will need a brand new Kernel. This means you will have to move your system from your 5.11 to the 5.14 one. I am looking at pictures of the laptop and I’m not seeing an Ethernet port. To upgrade the Kernel, we’ll need to wire your system directly to your router.

In this scenario, I’d recommend a cheap USB-C (or USB-A, which ever is easier for you) to Ethernet adapter.

Once you have it, boot into Ubuntu, tap your Windows key and type in terminal.
Then type:

sudo add-apt-repository ppa:cappelikan/ppa
sudo apt update && sudo apt upgrade -y
sudo apt install mainline

Then, using the same way you started the terminal, type in mainline and select the latest (top) Kernel. Once it’s installed, reboot and you will be running on the latest one. :slight_smile:

Please let me know how it goes.

What I typed above is also what I’m using for my Surface Laptop 3.

Yes it’s a cool laptop and good value too. I’m a game developer and need the GPU grunt. Intending to get Unity installed on Ubuntu…

Anyway, your instructions worked! 5.14.12 installed =)

Awesome! I’m glad it helped! I used to work a little bit with Unreal Engine too, until Epic told me to try it on Windows for its Virtual Production capacity… until they unified it all again and now - I believe - can be used in Linux too.

So what next to get WiFi up and running? And then bluetooth

Can you open up a terminal and execute the:

lspci

Command? If possible, please shoot me a photo of the results so that I know what you’re looking for - in terms of model. :slight_smile:

Actually - things are not good. I just rebooted and it won’t boot up. Goes to GRUB (whatever that is)

Photo of lspci output above… (yesterday)

I’m blind! My apologies. Today has been extra hectic.
I discovered something for you, which I hope will help. :slight_smile:

But the laptop won’t boot any more…

ie. can’t get Ubuntu up

Normally that menu waits for you to hit enter (unless it has a timer).
If the normal Ubuntu selection doesn’t boot, you can go back to the advanced boot options and select the latest 5.11 Kernel. Please let me know how it goes.

Yup. Head back to the advanced section of your boot menu and select a 5.11 kernel. Also, when you load up, uninstall the latest kernel you installed via the mainline app.

Reached my post limit! This is getting very frustrating…

So I tried the commands as suggested and all good until the last command …