Trouble deploying CyberPanel on VPS

Hello @LiwiLiwi and welcome to the forums!
I suppose this would be your personal encounter with the phrase “never say never!” :wink:
Great work!

@vasileios and/or anyone else who has an idea - I have my vps and cyberpanel setup but i am having trouble sendingreceiving mail on my main domain it says that SSL was not setup properly but on the auto created subdomain ( there is an error message that just states there are no emails for this domain. when setting up my thunderbird it says it cannot connect to the server.

the directions given to setup mail hosts is given

I will send a screen shot from TB when I get back to that computer. Any ideas?

Hey @BigDaveAZ!
Once you click the “Fix Now”, the SSL will be correctly applied for your off-line clients. Then, select the following ports:
993 for IMAP &
465 for SMTP.

Also, your username should be your full email address.

Please let me know how that goes. :slight_smile:

Last but not least, if you’re on Linode, you’ll need to ask them to unblock the SMTP ports so that you are able to send emails. If you’re on any other VPS provider, you might want to check their firewall (as some have it externally) and make sure it allows those two above ports. :slight_smile:

@vasileios Thanks for the advice. I am able to fill in the account setup “form” in Thunderbird but I am unsure what to put in for authentication method, my choices are: Normal Password, Encrypted Password, Kerberos/GSSAPI, NTLM, TLS Certificate, OAuth2. No matter which option I choose I get
BTW when I clicked “Fix Now”, I got a banner that said it was fixed but the pink banner saying it is not configured properly is still there. I feel I am so close to getting this up and running. Cheers and Happy New Year!

Hey @BigDaveAZ!
Happy New Year!
In this scenario, go to the SSL tab on the menu on the left and select the Mail Server. Then, re-issue the SSL. Once done, go back to your email and re-fix it - if the red banner re-appears.

The password style should be the “normal” one. You don’t need anything more as the connection itself is an SSL one. Please let me know how it goes. :slight_smile:

@vasileios this is what I get when trying to “re-issue” the SSL.

was I supposed to choose

also, should I keep ubuntu or convert to cloudlinux - which apparently can take care of the debugging the email server with a few clicks in the UI.

Hey @BigDaveAZ!
Yes, it was for the
Regarding CloudLinux, I haven’t personally tested it, so I can’t give you a definitive answer. I believe it’s one of the CyberPanel’s supported operating systems (others being Ubuntu and CentOS - both of which I used for my tests).

@vasileios when I do the SSL for I get the same pink box. I am going to try converting to cloud linux (EDIT: CloudLinux costs money so we wont be doing that). I will wipe and try again, I guess, after a little more playing around. Thanks for all your help brother. Here is an incomplete list of the OSes available on my host. do you recommend using a previous version of Ubuntu with some of the extra add-ons?

1 Like

Hey @BigDaveAZ!
You are most welcome! I’m thinking that the OS doesn’t have much to do with the errors you’re getting, unless your VPS provider’s local repository has version mismatches - which can happen during “update season”. If you’re feeling brave, I would recommend giving CentOS 7 a shot. The difference there is that instead of “apt” you use “yum” and the yum update does the job of apt update && apt upgrade in one shot. Other than that, all the other commands are the same. My own personal server runs on it.

I would have created the course server under CentOS, but I landed on a version mismatch on Linode and a version of OpenLiteSpeed was missing. Hence I switched the course to Ubuntu.

If you do decide to try CentOS, let me know if you hit any obstacles. I’m pretty adept in it too. :slight_smile:

@vasileios Dude, you absolutely ROCK!!

@vasileios Here is what I have for server settings - SMTP

Not quite sure what’s up when I try to send mail I get
and when I try to receive mail I get

I am frustrated with this - I follow directions - pretty well - But that doesn’t mean I am a quitter. I must forge on and claim my freedom from Big Tech once and for all. Even if I have to switch to CentOS to do it. I just feel I am so close to making this work…

I was looking up at my previous responses. Were you able to check to see if your VPS provider has an active firewall? It appears that your comms are blocked.

@vasileios that was definitely the next part of “playing around” I will be calling them tomorrow morning. Thanks for the due diligence, man. I appreciate it.

1 Like

@vasileios I am having the same problem and ran the CyberPanel more than 12 hours ago.

All steps up to running Cyber Panel for the first time seemed fine. I did the DNS → Create Nameserver, entered my domain, ns1.domain, IP address of the linode VPS where CyberPanel/etc is running, and ditto for ns2.

If I went back to Create Nameserver, everything is blank…however, I did see some stuff flash up on the left pane so looks like I have some things running. When I go to NameCheap and put in my ns1/ns2 info, I get the Oops like above. I tried pinging on my local machine to the ns1 server but it is not seen.

Anything else I can try to help me diagnose this? I’m not familiar with the CyberPanel logs but don’t see anything glaringly obvious.

Hey @Trueblade!
Which VPS service provider are you using? Some have external firewalls which block all kinds of communication minus http(s) and SSH. And in order for the DNS to work, the firewall must have port 53 open. The end of the CyberPanel installation has an output list of all the ports that need to be opened for each service to work properly.

Oh thank you for answering this. I’ve been following along on lesson 17 and 24 as you had it so I’m on linode.

I checked CyberPanel → Security → Firewall, and it shows port 53 for both udp (connectionless) and tcp on the list for firewall rules.

My output from the setup matched yours - no red ports closed. I just looked back and 53 is definitely green for both tcp & udp for DNS service.

Let me know anything I can check on linode, CyberPanel, /var/log, etc to help diagnose this. Lesson 17 went smooth (for VPN setup) so this 2nd server (VPS) seems like it should be smooth too.

I just tried namecheap again to enter ns1 and ns2 (for my new registered domain) and still get the “Oops” message.

I read a bit on the CyberPanel DNS stuff and seems like if I go to panel → DNS → Add/Delete Records is supposed to show something. It hadn’t been for awhile but it shows entries for the various tabs and relating to my mail, ns1, ns2, or main domain name. But local machine ping to ns1 is still host unknown since not hooked into a main DNS yet.

Hey @Trueblade!
The CyberPanel runs inside your VPS. I was referring to the service provider and the panel you use to create new VPS servers. Many of those providers have Firewalls that run outside the server, so - no matter what you do inside your OS - no change will come.

@vasileios Well - I finally got a hold of my host and they are not blocking any ports, I checked my firewall and it is not blocking any of the ports I need. what do you suggest? I need this to work by tomorrow or I will cancel this host and maybe try another. Do you suggest trying again with centOS instead? and will you help me with that? 30+ years with tiny (micro) Shaft and a couple of strokes is making this challenging. I will follow your suggestions, Oh wise one.

BTW - I changed some settings in OpenLiteSpeed and now instead of the error message it hangs on sending (see picture) and never finishes - grrr - but getting closer

this is the error message I get now


Hey @BigDaveAZ!
Can you screen-capture CyberPanel’s Firewall rules?
Or just execute (on SSH terminal) the following command (as sudo su):

firewall-cmd --list-all

I went ahead and switched to CentOS with cyber panel. I have everything working, kind of. I can access the webmail and send and receive email (after 5.5 hrs on chat hold for a solve that did not work). I am trying to setup Tbird right now - fingers crossed :crossed_fingers: