Trouble deploying CyberPanel on VPS

I’m trying to deploy CyberPanel on my VPS but I hit a roadblock that I can’t get past. I am root but when I run the command it tells me there is an invalid option and I don’t know what to do to get past this. Please help if this makes sense.

root@localhost:/home/xxxx# wget -Ο
wget: invalid option – ‘�’
wget: invalid option – ‘�’
Usage: wget [OPTION]… [URL]…

Try `wget --help’ for more options.

Hey @ksquirrel81 and welcome to the forums!
I just checked it. It would appear that the -O (the letter itself) must be from a character set other than English/Latin, hence the error. Delete the O and then re-type it. It will work. :slight_smile:

Hey Vasileios! Thank you so much! That did work! Thank you!

I got almost to the end and something else stopped it. I’m guessing that I will have to start the cyber panel install over once this is resolved. What do you think? Here is what it says:

The following packages have unmet dependencies:
libmariadbclient-dev : Depends: libmariadb-dev (= 1:10.3.32-0ubuntu0.20.04.1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
above command failed…

Where do I go from here?

Oh, man! That’s something I faced when I was going for the initial installation on CentOS. Let’s see if you can install it on your VPS manually. While logged in there (and being root or sudo su -) execute the following:


Then execute:

apt install ./ibmariadbclient-dev_10.3.32-0ubuntu0.20.04.1_amd64.deb

Please let me know if that goes through.

So close! Yes I am logged in as root. The first one (wget) did execute. But the 2nd one (apt install) did not. I tried copying it, and also typing it all out manually just to make sure. Here is the error I get after executing the apt install line:

E: Unsupported file ./ibmariadbclient-dev_10.3.32-0ubuntu0.20.04.1_amd64.deb given on commandline

Thank you for helping me out with this!

Unsupported file seems quite interesting as an output. Can you please execute the following command (on your VPS) and send me its output?

uname -a

I’d like to see the distro, kernel and the version it’s running. Thank you!

Here is what I get when I execute that command:

Linux localhost 5.4.0-91-generic #102-Ubuntu SMP Fri Nov 5 16:31:28 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux
You have new mail in /var/mail/root

I hope this is helpful. Thank you again for the assistance! I apologize for the delay.

No worries, @ksquirrel81!
I had to prepare another LMS meanwhile, which includes installing Windows inside your Linux OS (and it can basically run almost every Windows app).

It would appear that this may be an issue with your VPS provider’s repository. As far as I am aware, each of those providers keeps a copy of the respective distribution’s repository on their local servers to accelerate all installation processes. This one must have an issue.

What I would recommend is to rebuild the node (VPS), which means to reset it back to its “factory settings”. Then, before you begin the process, run the following command:

apt-add-repository deb focal multiverse
apt update

This will also add the main Ubuntu multiverse repository, which contains the packages you need. With some luck, there will be no version conflicts. That’s what you got when you tried to deploy CyberPanel.

Please let me know how it goes.

Thank you Vasileios. I should be getting better at the process of building a VPS!

Sounds like a project for this weekend! I’ll let you know how it goes.

1 Like

Practice makes perfect, indeed. Though one thing that I realized is that there are more than few differences in the ways distros are deployed with each VPS provider. That’s where most of the issues emerge from.

That’s good to know. My VPS is from Linode.

In that scenario, they should be repairing their repository soon. I know they had the same issue with their OpenLiteSpeed for CentOS a few weeks ago. Though my personal server is up there, running on CentOS normally. :laughing:

Earlier we solved another issue on the VPN Server. It turned out, the VPS provider had an extra firewall externally, which blocked the default OpenVPN port.

I just heard from one of our admins, who just went through with the CyberPanel deployment. This means that Linode fixed their repository issue. :slight_smile:

Oh that’s great! I was just trying to decide if I wanted to wait it out or not. Looks like I’ll be trying this again! Fingers crossed. Thanks for letting me know.

1 Like

Awesome and you’re very welcome!
Please let me know if you encounter anything else. :slight_smile:

I did rebuild my VPS and everything worked fine this time. Yay! Thank you so much!

One question I do have is about the DNS Name Server. I did create a name server on my cyber panel as shown in the LMS. But when I try to enter that into Namecheap custom DNS, it just spins for a few seconds and then I get a message “Oops, something went wrong. Please try again.” Is this the part that takes a while to update throughout the internet? I have tried this several times (it’s been about 6 hours)

One thing that worries me is I set up a website (using the same domain name) with the VPS before the rebuild using Word Ops. I previously used the linode name servers, so I’m trying to delete them and put in my own name servers. I hope that doesn’t cause problems for me.

1 Like

Hey @ksquirrel81!
I’m glad the VPS started working.
Regarding the DNS, that’s the biggest troublemaker on the Internet, because of the records required and the server cache that needs to refresh (most cases refresh between 15min up to 2 hours, but there are cases that can go up to 24 hours).

I had a fellow Admin who had a similar issue, but - as it turned out - his DNS were pointing at the Linode Name Servers (all 5 of them) and he had issues with his DNS records because of it. When you go to NameCheap, make sure the Custom DNS points to ns1.yourdomain.ext and ns2.yourdomain.ext (where “yourdomain” is your actual domain name, and “ext” is its extension).

If there is any other NameServer involved, then yes, you will encounter errors. You will notice that when you go to the DNS Health Checker tool (where you may get a “DNS Records Not Found” error).

Once the refresh is done, however, and the Name Servers are pointed at correctly, you will be fine.

Hey Vasileios!
I just wanted to let you know that I made it all the way through the complete server setup today! Thank you very much for the assistance! I have my own email server now and it works!
Now I will create my wife an email address too. I think it’s awesome that we can email each other securely on the same server and no one else can scan it along the way!

1 Like

That is so awesome and you are most welcome!
Enjoy your private life! :smiley:

Hi Vasileios
Followed the Video and this channel to get my VPS setup for cpanel, website, email and ftp. Many thanks
Never thought i would be able to do this ever

1 Like