Telegram audio oddity

I have this for a few weeks, but Telegram sound just stopped one day, (not after an update, just one minute it worked, the next gone), no sound at all, no notification sound, no video sound, nada.

All other programs including the OS sound works just fine.

Anybody got any idea what is going on?

Assuming this is for a Linux desktop, a few more details if you could.

What version of Telegram and its source for install? Telegram direct, flathub, snap?

What distro and its version as well as kernel are you running Telegram on.

Have you tried a simple uninstall and reinstall? Updating Telegram as well?

Yes, it is kubuntu 22.04 with all updates installed.

Version is 4.3.1, it is set to update automatically.

I presume you mean this:

Operating System: Kubuntu 22.04
KDE Plasma Version: 5.24.6
KDE Frameworks Version: 5.92.0
Qt Version: 5.15.3
Kernel Version: 5.15.0-53-generic (64-bit)
Graphics Platform: X11
Processors: 12 × AMD Ryzen 5 1600 Six-Core Processor
Memory: 7,7 GiB of RAM
Graphics Processor: NVA8

Yes, un and reinstall makes no difference, updating also makes no difference.

Thank you for your response.

do you happen to know whether your using alsa/pulseaudio/pipewire? I think Kubuntu 22.04 default is pulseaudio, did you by chance change this?

what does your performance settings under settings > advanced look like?

2022-11-19_10-08

No, I didn’t change this, that’s the weird part, I didn’t change anything. I have no idea where to find the Performance settings you show above, never saw them on my system. I didn’t install any of the programs you mention.

That is specifically in Telegram Settings > Advanced, scroll down a lil bit

You got me there I assumed Kubuntu settings, all three were on, turning them off — and restart Telegram — made no difference.

ok, you never did state which Telegram version you were using other then 4.3.1. Was it the flatpak, snap or Telegram desktop for Linux directly from Telegram(this is the one that I use) on Debian Bullseye with pulseaudio.

Telegram desktop for Linux directly from Telegram is the one I’m using too.

ok, lemmee look around and see what I can find.

Thanks for your help, if nothing comes up, I can live with it, it’s just weird.

ok, I’m going to suggest downloading a complete new package from TG directly.
Delete the TG folder you are running it from AS WELL as /home/yourusername/.local/share/TelegramDesktop/

Then extract the new package and run again, logging in etc.

I did, makes no difference, I told you it’s weird… :upside_down_face:

So if you download the video in TG and save as do you hear the audio through you own media player as well?

What do you setting in Telegram look like under “Settings > Notification and Sounds”?

Yes, that’s the only way for now to hear video audio, save the video to my harddisk and then play with my media player.

What happens when you click on “Play sound” in that Settings/“Notifications and Sounds” menu?

I can change the sound, but whatever option I choose, the whole Telegram application stays mute.

Suggestion, when you boot do you have an alternate kernel available?
Maybe a kernel downgrade would help? I seen where it had helped other KDE plasma users on different Ubuntu version and older TG versions.

There was also this link, not your exact problem but an audio issue with TG on KDE none the less:

Might be a place to look around.

One other possibility, have you tried the web api with your browser?