Problem loading drivers and programs

Hi all, trying to get things to load up after running updates etc…into Linux Mint on a HP Pavilion.

All updates loaded without incident. I was following a step by step on a Linux help website called Easy Linux Tips Project: 10 things to do First on Linux Mint 20.2 Cinnamon. I was instructed after doing a backup(Timeshift) to protect the base software(Improve Update Manager using hold command then load the driver. . .um that seemed to be a little backwards but I followed the instructions. Of course what the Nvidia driver needed was interact with the base programs to insert itself, lesson learned. So I followed the instructions on how to undo this protection using unhold and try to reload the driver, to no avail. Now I have portions that used to be read/write now just read only. . .uuggghhh!! Help please with how to get this right! I have been stumbling along with this HP for three weeks! Its a great learning experience but its time to get a good working copy complete so I can go on to how to use it not how to properly set it up!!! I will write a book on the right way on this particular Pavilion series!

Hey Paul! Welcome!

Can you post the link to the guide you followed?

What device are you trying to install drivers for?

I’m not familiar with the “hold” command, but most of the time all you need to do is open the terminal and enter the following:

sudo apt update

After that process finishes, enter:

sudo apt-get upgrade -y

This usually takes care of anything you need to get started.

I know it could be a pain, but one surefire way to remedy the problem would be to completely reinstall the OS and then run the above commands.

Here is the link: Easy Linux Tips Project: 10 Things to Do First in Linux Mint 20.2 Cinnamon

Nvidia driver, nvidia-driver-470, found in driver manager in mint. suggested by mint for my laptop’s video card (UHD Graphics 620)
I have become a pro at reinstalling OS, sooo. . . . It’d be nice to fix something for a change but if that would get it not to have any problems, I’ll do it!

I had problems getting Ubuntu 20.04 to find my Nividia 390.108, I tried Ubuntu 21.04 and it found the drivers no problem. Then I wanted to switch to Mint and I was thankful that it too found the drivers.

Yeah, I don’t think it is the drivers fault, it was the sequence of the list that I was following that put some block on the read/write files to a read only. I believe that if I cannot find a way to reverse that hold command issue, even after changing it back using the suggested unhold command, it will have to be completely reloaded. I think I have become the king of the reload, after starting this thing three weeks earlier! lol

I’ve reloaded several times too.

If you suspect that it is the sequence from the instruction you were following, you should skip the suspicious section. I’m currently using the open source drivers for my NVIDIA GTX1060 and everything seems to be working just fine.

Also, one of the other admins mentioned something about the NVIDIA Linux drivers going kaput after only a few months and suggested using the open source ones instead.

It seems that there is always a error during boot up on the free and open video driver. Every reload of the Linux seems to have that same error. Is this normal? It comes up really fast in two lines just before login appears. There doesn’t seem to be any issues after login but we’ll see. I will attempt to reload Mint again. Hope for the best!

Paul, Did you do a update from driver manager? I had to run the Nouveau driver until I updated the Kernel. Now I’m running the 470 recommended driver with no issues.

Ah, yes, the infamous Nvidia trouble! When the software manager or the graphical interface (even in terminal mode) does not work, we need to drop down to a “lower” level of the known “run mode”.

It’s something I faced time and time again, so it’s not hard to solve this. However, please allow me to describe the reasoning behind the solution I’m going to offer.

When you run in Cinnamon or any other desktop environment, you are running at level-5. To illustrate, the Linux kernel runs at level-1. When all drivers fail, you’ll need to drop down to level-3. There are two ways to drop down to that level.

  1. You exit your graphical environment via going to a strict terminal mode (initiated by a CTRL+ALT+F1 through F7, for example). These are called TTY, and your Linux - on average - can run 10 of them in parallel. Your graphical environment is one of them, and depending on your distro, it can be either the F2 or the F7.
  2. You can add a command in GRUB (your boot loader) to immediately boot into level-3. This is the cleanest method, but it requires a bit of timing. Any changes in GRUB command only function for a single boot, so there is zero risk of damage. This is the method I’ll expand on.

The Process

First and foremost, download the Unix/Linux Nvidia drivers from the official website.
The latest production build (stable) is in the following address:

This is the file you’ll need to run when in level-3. However, before we do that, we’ll need to do some clean-up operations. First, go to your driver manager and ensure that you do not have any Nvidia driver installed or selected. Revert to the NOUVEAU open-source driver.

Hopefully, this will wipe all APT Nvidia packages installed.

The second step is to blacklist NOUVEAU for good. Open a terminal and type in:

sudo bash -c "echo blacklist nouveau > /etc/modprobe.d/blacklist-nvidia-nouveau.conf"
sudo bash -c "echo options nouveau modeset=0 >> /etc/modprobe.d/blacklist-nvidia-nouveau.conf"

Now, while in the terminal, confirm that it is disabled by typing:

cat /etc/modprobe.d/blacklist-nvidia-nouveau.conf
blacklist nouveau
options nouveau modeset=0

This should pretty much do it.

The next step is to make sure you have DKMS installed. This module-builder will ensure that the next time your kernel is updated, the process will automatically compile your drivers so that you don’t have to do this process again. This is a very important part, so make sure you do the following:

sudo apt install dkms

If it’s already installed, then you’re all good! If not, it will be installed.

Once done, you are ready to reboot. This is where the fast timing comes in. So, please read this before you initiate a reboot. Once you do, hold down the SHIFT button until you reach the GRUB boot table where it shows you the kernel options. IMMEDIATELY tap the up or down keys on that menu so that the boot timer stops.

Then select the first option (the default loader) and tap the “e” key.

This will bring forth the GRUB boot parameters. Don’t be scared at this point. Any changes you do will be temporary and for that boot alone. You can do literally zero damage here.

You will see a line (or two, depending on the size of the text on your screen) that reads:
** kernel /boot/vmlinuz…**

Go to the very end of that line, add a space, and then the number 3.
Once you do, press F10, and the system will boot to Run Level 3.

You will be in text mode, so use your user credentials to log in.

Then it’s a matter of a few commands (assuming you downloaded your Nvidia driver in the default Downloads folder):

cd ~/Downloads
chmod +x ./

The process is simple, text-based. Remember, when it asks you to build the DKMS modules to select “YES”.
Once it is done and the installation is complete and without errors, you will exit to text mode. Then type in:


Now, your system will load back up normally, with full Nvidia and CUDA support.

OK there is no way the grub menu is coming up, tried it 20 times with 7 different ways of hitting that shift key. It just doesn’t work. This is Linux Mint 20.2, does this method apply to this software??? What is the correct method???

Hey @Paul !
The second way you can find the marked answer at the following link:

Simply be careful with the configuration file and only change the timer as the answer describes. :slight_smile:

The timer wait will make the boot menu wait for an X amount of seconds (the number you set).

Well. . . here we go again, the page you attached gives an instruction line to open the grub to change the timer. The line is as follows: gksudo getdit /etc/default/grub Then the terminal says commang ‘gksudo’ not found, did you mean: command ‘gfsudo’ from deb gfarm-client (2.7.15+dfsg-1) Try: sudo apt install
Soooo, I change it to command gfsudo. . . guess what, it says the same about gfsudo!! Ummm is this a crazy loop that is just there to confuse?? Please let me know how to change this thing. .

Instead of gksudo (which is a graphical interface for sudo) you can also type in:

sudo gedit /etc/default/grub

It will produce the same result, minus the fact that you will need to enter your password in terminal instead of a new window. :slight_smile:

it is now having a problem with
sudo: gedit: command not found

Ah… yes, choices, choices!
Mint uses XED as its text editor. So, the command goes as:

sudo xed /etc/default/grub

Sorry about that.

ok great, progress!! I am now in the menu but the 2nd line says GRUB TIMOUT STYLE=hidden, what do I do with this? The help narrative talks about true and false as the set values. What is the change, if any, to hidden?

1 Like

Simple. Just make it look like - an accident (!) LOL joking. You can turn that line to:


That will bypass the actual command. (Remember, place the # ahead of the line)
Then change the following line to:


That should give you a plenty of 10 seconds to press a key and stop the countdown. :slight_smile:

OK, we are now in the text mode, I typed in cd ~/Downloads and the next line it is: ~/Downloads$, do I write in the lines you gave me in the narrative? or was the downloaded program suppose to appear?

When you’re inside the Downloads folder, type in:

ls -l

The NVidia file should be there. Once you see it, then yes, continue from where you left off. :slight_smile: