Not able to add Printer- Cups Server Error

I am trying to add a Canon Pixma TR 4500 series printer. I am getting a Cups Server Error (Pic attached). I have tried using the USB and Wifi. Everything brings me to this error.

Any help would be appreciated.


Hello Nancy and welcome to the forums!
Let’s see if we can find out what has happened. Please open up a terminal and type in the following commands:

sudo apt install cups --reinstall
sudo apt install smbclient
sudo service cups restart

And try again to see if you can connect to your printer. :slight_smile:

Also, you might want to pay Canon’s site a visit at:

And download the highlighted driver:

Once you download it, uncompress it and open the folder. Then right-click on empty space and select Open in Terminal. Then type:

sudo bash ./

After that, I believe things will start rolling.

Please let me know how it goes. :slight_smile:

I completed the first set of instructions and I got the same cups error. For some reason when I click on the download link from Canon nothing happens at all.


I was able to download and extract. When I right click on empty space there is not choice of “Open in Terminal”


In that scenario, open up your terminal (from your start menu) and type in:

cd ~/Downloads/cnijfilter2-5.70-1-deb
sudo bash ./

It said “no such file or directory”

Can you open up your Downloads folder and post a screenshot of that?

I just realized, everything is downloading to the home folder!

Oh, that makes sense then! The default folder was the - well - Downloads one. :grinning_face_with_smiling_eyes:

In that case, your driver should be under the home folder. So, in terminal type:

cd ~/cnijfilter2-5.70-1-deb
sudo bash ./

Unless you moved it to the Downloads folder, in which case, the previous commands apply. :slight_smile:

I tried it again and it did not work. I have to go to work. Will check back later. Thank you!

1 Like

And I’ll have to get some shut eye too! We’ll talk later! :wink:

I tried it one more time and it is still not working. Here is the latest screen shot…


Hello Nancy!
Can you see the printer normally on the network from the other devices?
If yes, can you check the Network Settings on your printer, see its IP address and the SubNet mask? :slight_smile:

Okay! Can you open up a terminal and type in:

sudo apt install net-tools

And then take a picture of the output of:


Thank you!

The networks seem to agree. So, we’ll go a bit more technical with a couple of questions. :slight_smile:

  1. Do you have a VPN installed? (more important)
  2. Do you have a firewall running? (less important)

The reason I’m asking is that I see that your tun0: output drops the Subnet to

yes to VPN
IDK about firewall. I did not intentionally set one up.