NextCloud LMS Update

@vasileios I will use the 2TB HDD for the system drive and 2 new 4TB for the data RAID. That should do the trick, right?

1 Like

That should more than suffice, @BigDaveAZ!

1 Like

@vasileios the 2 4TB arrived today the new system arrives Saturday and hopefully I will be able to join the live stream on Saturday and then start on my NextCloud. Woooohooooo!!! Thanks for all your help the PDF is awesome I will be watching your LMS when I have some quiet someday - remodel from hell still going on!! Cheers!!

2 Likes

@vasileios At what point, if I am following the PDF for the NextCloud tutorial, do I do the BTRFS install? I am getting ready to pull the trigger on this, that is the reason for all the questions and messages. You ROCK!! Cheers!!

1 Like

Hey @BigDaveAZ!
It was great seeing you on the LMS today!
You can do the BTRFS installation at any time, as long as it’s before you format your additional drive. Once you perform the installation, there’s no need for reboot.

And by the way, you will need to run the KDE Partition Manager for the formatting, which offers the BTRFS option. Then you can build the RAID-1 based on the link I sent to your inbox.

At the end, when you mount (and set your RAID-1 to auto-mount via Gnome Disks), make sure you give permissions to Apache (www-data).

For example, if you mount the RAID-1 at the /var/www/nextcloud_data, then the command would be:

sudo chown -R www-data:www-data /var/www/nextcloud_data

That way, it will have the correct permissions for the drives to work.

Remember to setup the RAID drive before you log into your new NextCloud installation - where you create your administrative account (and import the database user, password, etc.).

In general, it’s good to create the folder first and then mount your RAID-1 into it. This would be like:

sudo mkdir /var/www/nextcloud_data

Then mount your RAID-1 (assuming its the device md0), and execute:

sudo mount /dev/md0 /var/www/nextcloud_data

And then set the correct permissions:

sudo chown -R www-data:www-data /var/www/nextcloud_data
1 Like

@vasileios I am ready to enter the ip at epik (the registrar for the new domain), just to double check I will be using the results of ifconfig.me, correct? once that is done, how do I add the domain to my server, I missed it during setup - do I need to run the whole setup again? I am full of hope and confidence (as well as piss and vinegar - lol). thanks for all your help. YOU ROCK :metal: :metal: :metal: :metal: :metal: CHEERS!!

1 Like

Hey @BigDaveAZ!
That is correct. Your domain at Epik needs to point at your public IP address, provided that you set the port forwarding on your router to reach the IP of your device.
Per placing your server inside the domain, all you have to do is edit the hosts file to read as I sent you in the DM - which you have already done. So, that one is already set. :smiley:

1 Like

@vasileios 2 things. when I ran the netstat -rn | grep default no error but no ip either which I guess is fine, as I have the same range as you. When trying to access the server from outside or even on the network itself, my thoroughly stupid, yet mandated by my cable company’s proprietary wireless (eero) blocks all requests. [Remember I have the silly topography of Modem → eero wireless → unmanned switch → router → my cloud server.] Is there anything I can do, short of replacing their eero system with my own personal wireless mesh? if that is the case - which is the best for the money I have at least 2 but up to four locations that need a Ethernet connection in addition to WiFi throughout the house. I have managed to format the RAID-1 with BTRFS, so the next step is to install Nextcloud, I guess. If I screw it up, I am confident that I can get back to this spot in just a couple of hours if I need to reinstall - again - I was able to add the domain this time. Cheers!
[Edit]
when defining my Storage Location (bottom of page 17 on the PDF)
sudo mkdir /var/www/nextcloud_data
should I make that sudo mkdir /dev/sdb/nextcloud_data ? I have the RAID-1 setup for this and I have it mounted at /dev/sdb per the BTRFS instructions I had found. which means I do not have to do the Gnome Disks thing, correct? Or do I need to do the Gnome Disks thing to add a label to the RAID?Sorry for all the questions in one email. Cheers!!

Hey @BigDaveAZ!
In your case, you will need to have every in-between router, that has a control panel, to allow port forwarding. If any of them blocks something, your domain will not be able to properly resolve to your server. The network switch doesn’t block anything, so you are good from there.

When creating the folder for your storage data, you always use the file system, not the devices. The mount command is the one that assigns the device the place in the folders. Also, if memory serves me well, the RAID device is named as mmcblk0 with p1 and p2 as its partitions. So, no /dev/sdb here.

Last but not least, adding a Label is always beneficial, so that you don’t get lost with having to deal with UIDs when mounting or looking for your drive. :slight_smile:

@vasileios I made it through all the RAID setup stuff. when trying for the SSL this is what I got


I feel like I am so close. is this because of the topology of my network? I will see if the EEro provided by my cable company will allow port forwarding through it. In the meantime is there anything I can do about the SSL step? Cheers!! and thanks again for all the help.
I looked at my Eero app and it gives me a completely different ip address than ip.me, apparently it will let me do port forwarding but now I am unsure which ip address to use at epik to point at my domain now. With the SSL step having issues I just get this
. I know that once we get past this or if we decide we cannot - I want to at least be able to access it from home. Looking forward to your answer, brother.

Here is the other screen shot I wanted to share

Hey @BigDaveAZ!
My very first suspicion is that your RAID needs to have the necessary permissions to allow Apache to read and write.
When you do an ls -l of your /var/www who does the Nextcloud_data folder belong to? If it’s root or any other user, that’s your issue. All the permissions of your RAID should belong to the www-data user.

This means you’ll have to execute:

sudo chown -R www-data:www-data /path/to/yourRAID

And replace the path to the actual folder your RAID-1 mounts on. Then try again to see if you can see your NextCloud via your browser. If yes, then you can go on ahead with the SSL.

@vasileios
Here is the last lines of output from the certbot try as well as the ls -al showing the permissions.


I have gotten as far creating a self signed certificate. I am just unsure where to copy the crt and the key files

Hey @BigDaveAZ!
Even though a Self-Signed certificate will work, you’ll keep on getting the pesky warnings - which is why I made the course with the LetsEncrypt service. At this point, it’s not so much an SSL error, but rather an access one. Once you are able to see your NextCloud even locally, then the certificate installation will not be an issue.

The steps to check are the following:

  • Does Epik correctly point to your public IP address? (The result you get from sudo curl ip.me without being connected to a VPN)
  • Have you locked the local IP of your server with your router?
  • Does your router’s port forwarding (80 & 443) point to your server’s local IP address?
  • Does your UFW allow ports 80 and 443?

If everything above is correct, then doublecheck the Apache configuration file under sites-available folder inside your Apache folder (in the /etc) and make sure the folders and server names are correct. Othe people who had the same issue discovered that there was a typo in the configuration file.

I will check all that because I could see the apache page at one point but after playing with the SSL and UFW settings (and removing that page) I cannot now, see the NextCloud page. I will go back and check all these again to make sure. I am pretty sure it has to do with the port forwarding that the eero will not allow me to do. I can feel how close I am but I am really close to starting all over again and then finding out exactly when I lost the ability to view that page - must I delete that page or will it interfere with being able to see the NextCloud page?

The only page you’ll need to delete is the original one from the sites-enabled folder. That’s basically a symbolic link to the original configuration (Apache’s default page) and it won’t be lost for good. Also, make sure you open the ports via the UFW to accept incoming connections, especially from your local network at the designated-only ports (80 & 443).

I will do that. By the way the eero is asking for a 4 digit port and will not accept a 2 or 3 digit port number. But it is cable provider provided so who knows how jacked the instructions will be?

Then give it a 0080 and a 0443 and see if that pans out. :wink:

I will try that as well. @vasileios . Thanks. Cheers!!

1 Like