Navigating the terminal

@vasileios I swear I love you. :smiling_face_with_three_hearts: That all worked fabulously.

Now as I start stage 6, in your demo, yours says root@localhost:/home/vasileios# (and then you’re starting wget for the cyber panel)
When I try to ssh into root I get the same error as before (I can ssh into jen and it looks like this: jen@localhost:~$)

When I try to log into root it looks like this:
jen@localhost:~$ ssh root@
The authenticity of host ‘ (’ can’t be established.
ECDSA key fingerprint is SHA256:WLrluLu6oHa8wa27u2UkEcpWmivAKU/T+IDCw06b2Ks.
Are you sure you want to continue connecting (yes/no/[fingerprint])? yes
Warning: Permanently added ‘’ (ECDSA) to the list of known hosts.
root@ Permission denied (publickey).

I’m not sure how I’ve manged to mess this up so much :face_with_diagonal_mouth:

1 Like

I found this command!!

jen@localhost:~$ sudo -i
[sudo] password for jen:
Sorry, try again.
[sudo] password for jen:

YAY! Now I’m trying to get it to say “home” on that line.

getting there! It now says this:
but doesn’t “~” already mean home? But there was no home file so I made one. Your line has no ~

So I made a file called jen!!! :joy:
It now says this:

cd /home/jen
:dancer: :dancer:
Now the line looks right! I tried to install the cyberpanel with the ~ and it didn’t seem to work. Now I can do it without the ~!

Well, now I am stuck, @vasileios as per screenshot. I re-checked upgrades and that’s all set so it’s not that. I also searched unmet dependencies, but I’m not confident how to integrate those idea with these command lines…

Hey @Jen!
We just wrapped up today’s live workshop. :slight_smile:
When you see the localhost, you’re already on your VPS, so you don’t need to do another SSH. :wink:

Let me guess, did this happen when you tried to install CyberPanel? If yes, then it’s a random thing that does happen. You’re not the cause of it. It’s the VPS provider. When they perform package updates (they like to host everything on their own servers), it’s a process that takes time. Thus, when you’re installing a package, like MariaDB (database), it may try to pull packages from the server while they are in the process of being updated.

I wouldn’t worry about it. The best thing would be to wait for a little bit and then try the installation process again. If it says there are errors, try the:

apt install -f

That fixes any broken installation packages, should there be any. :wink:

Note: I didn’t use the sudo above, as you’re already a super-user (root) when you’re up on the VPS.

Ok fantastic. I’ll try again later! (Yes, it’s the cyberpanel!)

I forgot about the live! I’m up to this workshop 24 and wanting to go in order!

1 Like

Hi @vasileios, I tried apt install -f both from root@localhost:/# and from root@localhost:/home:jen# and it still isn’t working. It gives the same error about broken packages.

Hi again @vasileios. It took me a while to think of this :woman_facepalming:t4:, but I just started a new VPS and the cyberpanel is installing. YAY!! Then I’ll delete the last VPS. :grin:

When I tried to ssh into root after the cyber panel install, I got the public key problem again. I re-followed your instructions above, so I can only ssh in as ‘jen’ not as root. Does that matter going forward with stage 6, deploying the cyber panel?

I also don’t see where it says "You have new mail in /var/mail/root

Hi again @vasileios. I’m really feeling stuck (but my wix renews on May 20 and I’m determined not to renew).

Per the problem above, I went back into LISH and changed rootlogin yes, but I still got a public key error when I tried to log into root (so that I could follow along with you on stage 7). So I redid the public key fix for the third time, but now I’m getting the error shown on the screenshot.

That is great to hear, @Jen and congratulations! I’m like a zombie as I’ve been doing a lot of work lately, so apologies for running a bit late with catching up. I’ll check your other messages now too. :slight_smile:

You don’t need to concern yourself with the mail part. It’s basically a report of the installation to your root’s inbox. :wink:

When you reach the CyberPanel installation, know that your root login is disabled, therefore you can only login via your non-root account.
However, as I see on your screenshot, you selected to create a new key. However, since you created a new key, the upload process requires that you have the password* option enabled. Otherwise it won’t budge.

This is something to always keep in mind. When you go through the SSH configuration and install the CyberPanel, after that point you always SSH as a normal user. So, you’ll need to go to Lish again and enable the password login in the sshd_config file. Then restart the SSH and copy your key again. Then, return to LISH and re-disable the password login. You should be good afterwards.

Always keep in mind that you SSH in as root only for the first session. :wink:

@vasileios no worries! I’m sorry you’re in zombie-land! I’ll read carefully in a moment, but yours says root in the middle or so of stage 6 - I took a screenshot. That threw me off. I don’t need to be in root there? And var/mail?

No worries, @Jen!
It’s about a friend I promised to help two years ago, so, he appeared a couple of weeks back!
And yes, I do have root, but I SSH as a normal user and turn into root while on the VPS. The command to do it is:

sudo su -

That’s how you see me as root in there. :wink:

@vasileios Sudo su
I’m dying! :rofl: I was considering uninstalling linux on the computer and really really starting over and that little command was all I needed!

I’m working on the cyberpanel now - post nameserver - so far so good!

One question - do I need to do the email that’s coming in this video to get my website working? I bought email from Rob Braxman a bit ago and am using it on Thunderbird, so if I can, I wouldn’t mind skipping that.

1 Like

No need for the email, @Jen! The important part is the website. Once that is done (alongside the DNS), then everything else is optional. I just put everything out there for those who want a complete solution. :slight_smile: