Mint Cinnamon backup when I can't login in?

My Mint Cinnamon system has worked beautifully for quite a long time. Recently I got warnings of no space at root, and suddenly I cannot log into my computer. Yesterday instead of just booting into it, I went to the advanced options and cleaned up the system, repairing, etc - I did everything offered there. This seemed to fix the problem temporarily, but today that no longer works and I cannot log into my system. Because it’s a dual boot installation with Windows, I am able to get to this site, but I HATE WINDOWS after using my beautiful Linux for so long. I made a boot USB stick for Mint Cinnamon, thinking that might let me access my files, but when I boot from it, I can’t see them at all. I suspect I may need to reinstall Linux, but need to backup files first. How can I do this when I can’t log in? I get no error message and I know my password is correct, but all I get is a return to the login screen.

Most common files taking up space on"/" are old kernels and old logs.

Boot your Mint partition, at the GUI login use <CTRL+ALT+F2> to get a physical tty terminal, login with your regular username and password.

Run sudo apt autoremove You will be promted for admin password. This will clean out unused libraries and old unused kernels not listed in GRUB, etc.

Next cd /var/log/
Then sudo rm *.gz
If you want to be real thorough, any *.old and .1 .2 .3 .4 .5 .6 .7 .8 .9 can also go.

When done, <CTRL+ALT+F7> will take you back to your GUI session where you should be able to successfully login now.

HTH

2 Likes

@MrDeplorableUSA , I love your username! Too fun! And the Punisher icon, too.

I followed your instructions carefully, including the “real thorough” ones. Unfortunately, it hasn’t resolved my problem. Phooey! (I initially forgot my username, it had been so long since I’d used it.) Everything seemed to work. I didn’t have any .8 or .9 to remove, apparently. What can I try next?

Did you attempt a reboot at anytime after clearing the files? I didn’t mention it but it can’t heart to try it. Also if You get any errors snap a pic with your phone and post them. I’ll try to sit down after work and look up some other things.

I’ve rebooted many times since this started, unfortunately. :neutral_face:

I was unable to sit down and look for other solutions last night, can you get back to a tty and run df -ah and post a screen shot or phone pic? What version of Mint is this is as well?

I gathered a few results this morning with my coffee before work that you can peruse.

These are a Mint 19 Tara issue in case your install is that old, If you’re not running Mint 19, ignore these:
Mint 19 issue
Mint 19 issue

These are other “login loop” issues that have been solved:
Mint Login loop --most promising
Mint login loop --last resort

@MrDeplorableUSA, I appreciate you immensely! However, I’m still stuck. Phooey! I’m running Mint 30.2 Cinnamon, for what it’s worth. I’m attaching a photo of the results I got from trying to run startx. I got similar error messages from the “last resort” option. I’m very concerned that I may need to reinstall Cinnamon and could lose data that is not backed up. In the meantime, things I need to do are dependent on that data. Unless there is a way to somehow make more space? Thanks in advance!

Mint 30? or 20?

It looks like you had a typo on the first line and forgot the “rm” command. Though the login that you used is your user login? Do you have another user or Guest acct setup on there that you can try to logon to the GUI as well?

I guess you can always peek in there in the /tmp and see what’s in there(may have to use sudo), though I have never had to clean anything out of that folder, system usually takes of that folder pretty good.

You may be looking at a desktop reinstall which I believe they covered in the bottom of that promising link.

The one line command with your user, that would be the exact username and password you would use for your GUI login session as well, logged in would be.
Understand that you cannot copy and paste it so I will spell it out since some things run together. My eyes are getting old and it’s hard to read these screens anymore.
That is:
r m [space] ~/.Xauthority [space] && [space] r m [space] ~/.ICEauthority
rm ~/.Xauthority && rm ~/.ICEauthority

If you login as any other user you would only delete their hidden .X and .ICE files.

Also a screen shot(little closer for these old eyes) of df -ah again if you would.

This evening quite unexpectedly I tried logging in and it worked! I’m still uncertain what I did, but I’m not getting any error messages (so far) about insufficient space, so I’ll take it!

You are right, I’m using Cinnamon 20.3 not the other way 'round.

Now I plan to ensure everything is backed up in case something decides to quit working again! Thanks so much for your help!

1 Like

Excellent news.
Glad to hear it’s running right again.

You might want to check your disk partitions and see what the used vs. allocated space is. I went through that on a thread I started here about a month ago:

I’m using Ubuntu, but Mint is based on Ubuntu IIRC, so the tools might be similar. I have been using the “Gparted” app to look at disk partitions. I was able to see that my boot partition and main partition had got filled up on an upgrade from Ubuntu 20.04 to 22.04. You can also see this information in a simplified form, with System Monitor (File Systems tab), which is a “Utilities” app that may already be on your system.

System partitions can be expanded if you have room, though I have yet to actually tray that. I believe your partitions have to be “unmounted”, which probably means using a USB-boot “live” version of Linux with Gparted (or similar app) available, to access the partitions.

If any of your partitions get filled up, I think it can cause serious issues. Particularly a Linux version upgrade is going to add space to your partitions, more than likely.

2 Likes

Really great thread! Lots of helpful ideas here.

One thing to always keep in mind is that your system has a finite storage space and overtime it will grow in size.

It is a good idea to keep track of your free space and be cautious if it gets over 80%.

One source of bad surprises is to not update and upgrade frequently. If you wait several months between updates the downloads can fill up the available space and the system will crash!

Personally I update once a week to keep the changes minimal and the total size of the update manageable.

In the terminal you can run the df command to see what % is available:
the “.” indicates the current directory.

df .
Filesystem      1K-blocks      Used Available Use% Mounted on
/dev/nvme0n1p2 1406307328 990292384 414173440  71% /home

71% of my system is used so I need to be cautious with any big updates or adding large files.

A while back @mcron shared this bash script that checks your system’s filesystem:

  1. Save this as a plain text file in your home directory as “df_notice.sh
  2. Make it executable by typing into your terminal command line:
  3. sudo chmod -x df_notice.sh
  4. (You will need to enter your password)
  5. Run the script in your terminal :
  6. sh df_notice.sh
#!/bin/bash

# Set the threshold for %used
threshold=80

while IFS= read -r line; do
  # Skip the header line
  if [[ $line == Filesystem* ]]; then
    continue
  fi

# Extract the %used column value using awk to pull the fifth (5) column

  used_percentage=$(echo "$line" | awk '{print $5}' | tr -d '%')

# Compare the %used value with the threshold

  if (( used_percentage > threshold )); then
    # Output a warning message
    echo "Warning: Disk usage exceeded $threshold% - $line"
  fi

  done <<< "$df_output"

This is the output I got this morning:

~ 
❯ sh df_notice.sh
Warning: Disk usage exceeded 80% - /dev/sda4       961G  851G   62G  94% /recovery
Warning: Disk usage exceeded 80% - /dev/sdb1        15G   13G  2.1G  87% /run/media/norse/PUBLIC_USB_

2 Likes