Mint 20.3 can't connect to wifi

I just installed Mint 20.3 on a Dell Optiplex 3010 desktop machine. I had to disable secure boot and delete the keys. After installing Mint, I am unable to connect to Wifi. I can see my network, but when I enter the password, it looks like it is trying to connect, but it is unable to connect. Not sure if this matters, but I am using a wifi adapter (usb) since the computer is only set up for a wired connection. I’ve rebooted, and when that didn’t work, I reinstalled Mint. Still not able to connect. . Can anyone help?

Hey, @Margo!
Can you open up your Mint terminal and then post the output of the following command?


Some USB adapters are a bit opinionated when it comes to them working out of the box. Perhaps take it out and then reconnect it too?

Otherwise, please send me the output of the above command and I’ll have a look at it.


Hi @vasileios, here’s the output:
Bus 002 Device 003: ID 0bda:8179 Realtek Semiconductor Corp. RTL8188EUS 802.11n Wireless Network Adapter
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 004: ID 093a:2510 Pixart Imaging, Inc. Optical Mouse
Bus 001 Device 003: ID 04f3:0103 Elan Microelectronics Corp. ActiveJet K-2024 Multimedia Keyboard
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Yes, I did try to pull it out and replace it. I had used this adapter on a Mint install I did on an HP computer a few months ago and it worked fine.

Thanks for your assistance!

Hey @Margo!
Let’s see if we can make this work. I’m typing from a 2008 laptop that I just revived with Linux Mint Debian Edition, so - this could bring some good luck!

As far as I have seen, your adapter has a module for Linux. So, let’s give it a shot. Open up a terminal and execute the following lines, one at a time:

sudo apt update && sudo apt upgrade -y
sudo apt install dkms build-essential git
sudo apt install linux-headers-$(uname -r)
cd ~/Downloads
git clone
cd rtl8188eus

Then reboot and check to see if your WiFi works as intended. :slight_smile:

Hi @vasileios, no luck. Upon running the first command, I got many errors, that went on for 6 pages, but here’s the beginning of it:
Err:1 Index of /ubuntu focal InRelease
Could not resolve ‘
*Err:2 Index of /ubuntu focal InRelease *
Could not resolve ‘
*Err:3 una InRelease *
Could not resolve ‘
*Err:4 Index of /ubuntu focal-security InRelease *
Could not resolve ‘
Err:5 Index of /ubuntu focal-updates InRelease
Could not resolve ‘
Err:6 Index of /ubuntu focal-backports InRelease
Could not resolve ‘
Reading package lists… Done
*Building dependency tree *
Reading state information… Done
37 packages can be upgraded. Run ‘apt list --upgradable’ to see them.
W: Failed to fetch Could not resolve ‘
W: Failed to fetch Could not resolve ‘

The very last line was:
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

So I ran apt-get update and got:

Reading package lists… Done
E: Could not open lock file /var/lib/apt/lists/lock - open (13: Permission denied)
E: Unable to lock directory /var/lib/apt/lists/
W: Problem unlinking the file /var/cache/apt/pkgcache.bin - RemoveCaches (13: Permission denied)
W: Problem unlinking the file /var/cache/apt/srcpkgcache.bin - RemoveCaches (13: Permission denied)

For sake of simplicity, is there a network adapter that you know will work with this dell computer? It’s strange, I used this same adapter with an HP desktop that I installed Mint on and it worked fine!

Hey @Margo!
I completely forgot to mention something fundamental and I apologize.
That’s the use of an Ethernet cable. This will allow you to connect your system to the router directly (or via a network switch) so that you can get the files you need.

I know, it’s funny. To get online you need to download material from the Internet! :laughing:

@vasileios, I feel silly! I thought Linux had all the answers built in. Lol

1 Like

@vasileios, I got through all the commands, except the last one:
./…—>No such file or directory

1 Like

Hey, @Margo!
I always find it curious that some distros automatically configure .sh files as executables and some remove that option. :slight_smile:
The simplest way to do it - let’s do the full failsafe one - is:

sudo bash ./

As long as you are inside the folder. Otherwise, if you’re on your home folder, you can type:

sudo bash ~/Downloads/rtl8188eus/

And it should install normally. :slight_smile:

@vasileios, Looks like it installed, but still am unable to connect after restart.

It should normally be working by now, but let’s see if there’s something else going on.
Does your system BIOS have Secure Boot enabled by any chance?

No, I disabled secure boot and deleted the keys before I installed Mint, thanks to you and this forum;)

1 Like

That’s great!
Before I go deeper, let’s see if a simpler solution can work.
Boot into your system. Then take the WiFi USB out and connect it again, preferably to a different port, just to test it out.
Then, go to your network icon to the bottom right and attempt to connect to your WiFi. It will probably tell you to take a hike, so we can try to return the favor.

Head for your Networking Settings and find the WiFi tab, which will show you all the available connections. Hover your mouse pointer over your network. Since you tried to connect in the past, it will show you an additional settings icon. Click on it.

A new window will pop. Go to the Security tab and retype your password in it and hit apply. Then, try to connect.

If this one works, I’m going to eat my laptop. :laughing:

Well, the good news is you don’t have to eat your laptop. The bad news is that did not work:)
Stepping away for the evening. Maybe my computer will change it’s attitude tomorrow. I appreciate your help @vasileios.

1 Like

@vasileios If you can think of anything else I can try in order to resolve this, please let me know! Thanks V!

Hey, @Margo!
My apologies for the delay. Family responsibilities claimed most of my time these past few days.

Everything we’ve done has been correct thus far, so there are two reasons why this is happening:

1. Power Fluctuations
The USB has some minor power fluctuations that result in some instability that affects the consistency of the WiFi signal.

I noticed this on one USB port of a laptop of mine - where I have a wireless adapter connecting to a mouse and keyboard. The mouse tends to freeze at intervals. When I switched the adapter to a different USB port, the issue was rectified immediately.

You can try different USB ports, or pick up a USB hub that has the option of being connected to its own power source (like a plug). This way, it will not require power from your computer and there will be no fluctuations.

2. WiFi hardware issue
The RTL8188EUS is a very old WiFi chip (I believe it first came out around 11 years ago or so), so there’s a chance that it may have its wear and tear.

I would recommend replacing the WiFi adapter with a more modern one. They are generally inexpensive - though when it comes to a desktop, wired is the best choice in terms of speed and stability of the network. However, if you still want WiFi, you can find some of the best adapters here:

1 Like

@vasileios who said you get personal and family time??? Can I speak to your manager, please? LOL. You deserve all the family time you need - remember - we ALL miss you when you are not here. Cheers!!


LOL if I have no family time, I have no family. If I have no family, I can’t be in the US! If I can’t be in the US, well, I’ll be on a vastly different timezone - which will also take me time to re-settle. My wife enjoys really long mountain hikes, which tend to incapacitate my tech thinking - as I need to recover from carrying 20+ lbs of backpacks up and down hill. :laughing:

As for personal time, I really do not know what that means. I haven’t taken any vacations in over 10 years!


@vasileios Just remember YOU ABSOLUTELY ROCK!! You are also a saint for putting with not only me but EVERYONE’S issues. We will allow for 20 minutes or so per week to say hi to your family - we are not monsters!! LOL


Thank you @vasileios. I will replace the adapter. We appreciate you Vasileious! I would’ve given up long ago if it weren’t for you.

1 Like