Log in Loop Issue Mint 21

Greetings. I’m stuck in a log in loop on my Dual Boot Dell Inspiron Laptop. I can get into the advanced options, but can’t seem to figure out what to do after that to resolve this. I can also log onto the “guest” account from the Log In screen successfully.

I do have my Mint 21 USB in hand as well.

One thing I recently did was to follow a suggestion regarding eliminating some of the requirements to enter my password, however I’m not sure this is what is causing it or not.

I simply am stuck, and humbly ask for any advice to set me straight and get me logged back in.

Thank you!

It would help to narrow down the issue if you could provide links to the suggestions you followed.

There are a couple avenues that cause login loops:

I suspect you attempted to utilize a depreciated function of “NoLogin” group under Mint 20. Simple fix, remove your user from that group using terminal(tty).

If that’s not the case, full drives from improper handling of log files, overflowing log files due to a recurring error, or a timeshift backups not setup correctly thus filling drive. From a terminal you can check that with df -h.

Worst case scenario is a missing or “moved” user folder of /home/username

Found this reply on the Mint forums that solved an similar issue as well:

Whenever the graphical login screen accepts the password, but then quickly returns to the login screen, then usually either of 2 causes applies:

  1. The root filesystem / is 100% full, thus preventing the system from creating or extending needed temporary files.
    or
  2. The files $HOME/.ICEauthority and $HOME/.Xauthority are corrupt. (Actually, it could be just one of them or both.)

In order to find out whether one of the 2 reasons applies in your case as well, please, proceed like this:

  • When the graphical login screen appears, do not enter your password, yet.
  • Instead switch away from the graphical login screen to the first console monitor by pressing the keyboard shortcut
  • Here you will be prompted to log in by typing your username. Next you have to enter your password.
  • Provided you have entered your login credentials correctly, you will be greeted by the command prompt, which is the $.
  • Check whether a filled filesystem is your problem by executing the commandline: df -h | egrep "^/dev/|Filesystem".
    In case one of the filesystems is at 100% usage, 0% free space left or very close to it, please, report here so and let us know which filesystem is affected.
  • In case a filled filesystem is not your problem, try to solve the second potential cause by deleting the 2 files, which had been named above.
    Removing these files will never do any harm, because they will be recreated automatically, when logging in to the graphical login screen later on.
    Please, execute the commandline rm .ICEauthority .Xauthority Note that both filenames start with a dot.

Now switch back to the graphical login screen by pressing the keyboard shortcut . - If does not work, try instead.
Now enter your password in the graphical login screen.
Does the graphical desktop start up and appear on the screen? Or are you returned to the graphical login screen within a few seconds still?
In the first case, your problem on the Samsung RV515 has been solved. In the second case, well, it sadly has not been solved, yet.

I wish I could find that suggestion, I have been looking for it ever since this began.

In regard to the posted Mint Forum information, I’m not sure what switching away from the graphical login screen to the first console monitor by pressing the keyboard shortcut means. Unfortunately while I’m a bit more advanced than a noob, I’m no expert. I do appreciate anyone that has taken the time to help me in the past, a year ago, when I began this journey thanks to Jeff Peterson.

Thank you for your reply to me as well. I’m trying to go through it and see if it’s helpful to me.

You get atty press CTRL+ALT+F1

To return to the gui you would press CTRL+ALT+F7.

Just an added note in case anyone is using a different distro.
Different distros can treat the CTRL + ALT + F(keys) differently. For instance, Fedora 36 uses the F1 tty as the X environment desktop for the initial user. It then uses F2 for subsequent logins and assigns an F key to any further X environments.
So, if you have any problems either getting to a tty or back to your X desktop you can cycle through the CTRL + ALT + F(keys) to find where you want to be.

1 Like

Unfortunately I can’t open a terminal using control + alt anything.

If (in your first post) you are getting to the advanced options from the initial boot up GRUB menu then you can try this:
Note: When you have successfully entered runlevel 3 you will be presented with a black screen with a login prompt. Log in as your regular user and then try he suggestions in post 2 above. If that doesn’t work or help then post back, there are more options for you.

( copied from link at bottom of post)

GRUB2 runlevel change to runlevel 3 – Howto Change Runlevel on GRUB2

1. GRUB2 standard screen

When GRUB appears, press the arrow button. Select (highlight) the kernel you want to edit and press ‘e’.

2. Add the unlevel parameter in the Linux line

Use the arrow keys to go to the ‘Linux’ line and then press the ‘End’ key to get the end of the line (or use the arrow keys to move the cursor to the end of the line). Write spaces and your runlevel number at the end of the line. Here I am using runlevel 3.

3. Boot to the selected runlevel

Press Ctrl + x or F10 to boot (esc to cancel).

I can in fact get to that edit command, but in the embedded example the images are dead, so there is no example for me to follow for the way it should look before I execute it.

I found another example and now am at the non graphical login screen, where it says login:. _

Now what to do next?

Try logging in as your regular user, with username (press enter) then password (press enter). Remember, the password does NOT show up as you type. Be careful you type it correctly then hit enter. Then you should be in your home directory. Type
ls -al
to double check then you can try the suggestions in post # 2.

Thanks. I got logged on.

The info that scrolled down the screen when I logged on, does that concern me?

I ran the DF -h and see my home directory (dev/sda7) is 88%. The others are much smaller.

That was just to double check to make sure you were in your home directory. It is in your home directory were you need to make the changes suggested in post #2 so make sure that in the terminal the prompt shows something like:
[your_username@your_computer ~]$

It does indeed appear to be my home directory

You can check to see if you /home directory is full using:
df -h
if OK then you can try removing the two files indicated in post #2

Home is 88%, and as you can see in that image I posted at the bottom, it’s saying they can’t be removed, no such file or directory. Even though in that initial screen from when I logged in I see .Authority.

The screen shot says .IDEauthority is not found but it may have removed .Xauthority

try
ls -al .X*

I switched to a lower case x.

Ok, so it did delete .Xauthority
You can now try to log in as usual.
You can try
startx
or restart your computer with
sudo shutdown -r now