Linux mint installation issues

Hey @Gerelyn222!
I guess my memory failed me here!
In any scenario, whatever you have installed, appears to be running from a tiny space, which is not your 128GB Card.
Your Raspberry must have come with a USB reader, where you can place your micro-SD card in. Use it to hook the card to a bigger computer and use the Raspberry Pi Imager I posted above. (Linux mint installation issues - #8 by vasileios)

Once you install the imager, run it and select your version and then the SD card to flash. Once it’s done, then remove the SD card from the card reader USB and place it on the front side of your Raspberry Pi. To be more exact, turn your Raspberry Pi upside down and place the Micro SD card with its markings facing you (brand, etc.). Once it sits nicely in, then that’s it. You can boot normally. :slight_smile:

Hi

I am still having trouble. I am guessing that the small SD card that came in the machine had more on it than just my attempt to load Linux Mint or Ubuntu. Now, I am getting errors when I try to install from the 128SD. The error I get is: Failed to execute child process “/usr/lib/arm-linux-gnueabihf/glib-2.0/gio-launch-desktop”

Invalid desktop entry file: "/usr/share/aplications/rpi-imager desktop

Invalid desktop entry file: "/usr/share/raspi-ui-overrides/applications/pcmanfm.desktop’

Invalid desktop entry file: '/usr/share/

Hey @Gerelyn222,
I would highly recommend you use another computer to properly flash the SD card so that you can then plug it into your Raspberry Pi. As far as the error messages go, I doubt it’s something that can be salvaged from within your Pi.

Thanks for sticking with me! I have been using my Windows 10 to flash the SD. However, my Pi is so fried it won’t bring up anything, including the terminal.

My error message is Failed to execute child process “/use/lib/arm-Linux-gnueabihf/glib-2.0/goo-launch-desktop “ (input/output error)

I have no idea where to go from here - maybe buy a new Pi.

No worries, @Gerelyn222!
I doubt your Pi is fried. I believe it’s mostly because of the filesystem confusion. Were you able to download and run the Raspberry Pi Imager?

I can run the Raspberry imager on my win10 and build the Sd. When I put the sd in I get the error message mentioned in my last message. Would it help if I sent a pic of my screen?

Yes, please. A photo would be great! Also a photo of the Linux version you select for your Pi. Some of them react different than others - or so my experience has taught me.

Also, do you connect the SD card to your Pi via the USB reader or do you plug it in on its own?

Hi @vasileios
Information to try to explain how I got to this point:

  1. I thought I would prefer the Linux Cinnamon Mint so I tried to make a SD card so I could add it to my Raspberry Pi 400. I didn’t have any problems with the card. I used Rufus-3.17.exe. I also tried Etcher with no luck. I was doing this using the 32gb SD card.
  2. I put a message on the board and received an answer that the Linux Mint was not compatible with the Raspberry Pi.
  3. I then changed to Ubuntu and put it on the 32gb SD card. I used Rufus and then Etcher. Also, I tried Ubuntu server at this point without success.
  4. At that point you suggested that I use the Raspberry Pi Imager. I started using it to flash the SD card. I began using the 128gb SD card.
  5. I realized I probably had more problems and started trying to flash the Raspberry Pi OS with desktop and recommended software, Kernel 5.10 Release Date: October 30, 2021.
  6. I couldn’t figure out how to send the pictures of my screen. Do you have an email that I can send them to?
  7. The screen does not respond to any action. It makes sounds when I insert the SD card so I know something is alive.
  8. I think most of my problem at the beginning was memory issues but then I didn’t think about putting the 128gb card in the Pi slot. I was using the adapter.
  9. Now I am not sure when I did it, but now the Pi is unable to do anything. I can’t get to the browser.
  10. I’m listing the files I have used to work through this.

Balenetcher-setup-1.7.0.exe
Imager_1_6_2_amd64.deb
Imager_1_6_2.exe
2021-10-30-raspios-bullseye-armhfull.zip
Ubuntu-20.04.3-desktop-amd64.iso
Ubuntu-21.10-preinstalled-desktop-arm64+raspi.img.XX
Rufus-3.17.exe

Hopefully you can make some sense of this. I am definitely in over my head right now. I’m not giving up! I’m going to do this (with your help, of course). Thanks so much for your help.

1 Like

Hey, @Gerelyn222!
Thank you so much for the detailed analysis! :slight_smile:
The Pis are definitely a strange bunch! As I found out myself via experimentation, is that when you use the traditional flashing methods with Rufus or Etcher, you just end up running a Live USB only. That’s what got into trouble in the first place. That and Mint not being compatible!

One worthwhile aspect to know is that the USB card reader is much slower than actually having the SD card in its native slot. Something to remember: when you hold your Pi upside down, the card brand must look toward you. The slot is not exactly ideal, so the card can be misplaced or not make perfect contact. The moment it goes all in, then you know you’re good!

I do have some good news though. You can install Mint’s desktop environment (Cinnamon) on Ubuntu. However, let’s get Ubuntu up first! Yes, you will need to run the Imager on your Windows, (the exe file). Then insert your card reader with the 128GB card, go to “General Purpose OS” and select the “Ubuntu 20.04.3”.

For illustration, you can check this link:

Now you can plug your SD card in and turn on your Raspberry Pi 4. The following are the final steps of the process:

Ubuntu can be a tad slow, due to its Gnome Desktop Environment, but once you manage to go through it, you can open up a terminal and type in:

sudo apt install cinnamon

Normally, it should ask you about a Window Manager and offer you the options between GDM and LightDM. Choose the latter.

If it does not offer you any option, then it bypassed the LightDM installation. In this scenario, we can change it manually.

sudo apt install lightdm

Once it installs, we will disable GDM (Gnome Desktop Manager) via:

sudo systemctl disable gdm

And enable the LightDM:

sudo systemctl enable lightdm

At that point you can restart and you will come through to a new login screen. Right above your password box (to the right) will be a tiny icon. Click on it to make sure you select the Cinnamon session.

Let’s see if this process works out for you! :slight_smile:

Please let me know of your results!

Hi, I am so happy! I have followed your instructions and my Pi is alive in the terminal. The problem is it is asking for an ubuntu username and password. I don’t think I ever got this far. I checked all my logs and no mention of an ubuntu username or password. How do I retrieve what is in the Pi so I can proceed?

Ah yes. Initially, the default values - as far as I received them too - for Ubuntu username and password are:
Username: ubuntu
Password: ubuntu
You can change the password, once you login, by typing the follow command:

passwd

It will then ask you for a new password. If you want to create a new user, go to the settings and select the Users tab. Click to unlock and add your new username. Select it to be an Administrator, so that you have sudo capabilities.

By the way, if the above ubuntu password doesn’t work, please let me know - so that I can check if the default values have changed.

I have used the username and password and updated my password. However since my internet information has been deleted Ubuntu couldn’t reach the internet to login.
I thought I could install Brave to resolve this issue but having trouble installing it.

My error is Err: 1 http://ports.Ubuntu.com/Ubuntu-ports focal-updates/universe arm64 apt-transport-https all 2.0.6
Failed to fetch
Also unable to fetch some archives, maybe run apt-get update or try with —fix-missing?
I ran the get update command
I am following the instructions on https://itslinuxfoss.com/howtoinstallBrave on Ubuntu

I am sorry to be such a pain. I appreciate your help!!

I have the Brave.exe file on my 32gb SD card. It is in my external hard drive.

No worries @Gerelyn222!
The file for Brave you have is a Windows version. Linux does not use EXE files. Unfortunately, it does not support the ARM64, which is the type of processor that the Raspberry Pi has.

Always keep it in mind when you attempt to install software on your Pi. Archtecture = arm64 :slight_smile:

I am not sure what is going on. It is almost like it thinks the link for Brave is within Ubuntu and it may be. However, Ubuntu is not connected to the internet so can’t get to the Brave link.

There is a process to install the Brave Browser’s repository and allow its installation. However, similar errors will occur, as the app itself is built for the AMD64 architecture (or X86_64) and not the ARM64 one. :slight_smile:

When I went to Ubuntu to get the right file, there is a note that the download link is broken. 😵‍💫😬

Since Brave doesn’t support the Raspberry Pi architecture, you could utilize a different browser. Brave is based on Chrome. Chrome is based on Chromium (which is the non-Google version, but supports all of Chrome extensions). You can do that in terminal, by typing:

sudo apt update
sudo apt install chromium-browser -y

Then you can install the two basic extensions, which will give you similar protection like Brave (or perhaps better). Once you install Chromium, open it and use it to click on the extension links below:

And…

:slight_smile:

I tried installing Chromium and received a similar error message
Failed to fetch http://ports.Ubuntu.com/Ubuntu-ports/pools/universe/c/chromium-browser/chromium-browser_85.0.4183.83-Oubuntu0.20.04._arm64.deb
Temporary failure resolving’ports.Ubuntu.com
Maybe if I uninstall Ubuntu and if so how?
Thanks again for your time and patience!

Or maybe even go back and reinstall the Raspberry Pi OS??