Laptop freeze

I have a compaq presario cq60 I’m beating my head against for the last few days.
It freezes up no matter what I do and have to hard reset it for it to work another couple minutes till it piles up again.
I have tried
Mint Cinnamon 20.2
Ubuntu 20-04.3
Switched the graphic driver on Cinnamon to Nvidia from generic (That made it so bad thats when I just loaded XFCE)
CPU is AMD anthlon Dual core QL 64 2100MHZ
3G ram
If its just that Nvidia stuff that’s causing the problem I would swap the card out for something else cuz its a nice little laptop otherwise.
Or is this just one of those machines that wont play nice with linux?

Hello @Majorchaos!
The easiest way to check if Nvidia is making your life hard is to give a shot a distro that comes with the drivers pre-installed. The distros that do that are the following:

  • Zorin (try the Core first - boot with the Nvidia support option)
  • PoP!_OS (download the Nvidia ISO)
  • Manjaro XFCE (boot with “proprietary drivers”)

The two first are on the LTS release side, which will is a safe bet on the stability. However, their desktop environment can be a bit heavier on systems with low RAM. Manjaro XFCE is lighter, but it’s more on the bleeding edge, which could be annoying if something crashes (I noticed some KDE settings crash lately, that’s why I’m suggesting XFCE).

Please let me know how it goes. :slight_smile:

1 Like

Thanks for the advice sir!
Here’s how I made out so far:

I installed Zorin and it seems a lot better but it didn’t like the Nvidia driver. It no longer just up and freezes after a couple minutes but the issue that remains is when you play a youtube video the screen starts to flicker after a couple minutes. If you pause the video and restart the screen is good for a bit and it starts again. The length of good playback seems to be connected to how long you pause for. Memory issue? I’ve dug around in the internet for a solution and there is some stuff using the command line others say fixed them up, but without some better understanding of what I am doing I am just blindly typing commands in and hoping for the best lol! If you give me the command to show what driver its using maybe I can get you that info here and it would be of some help troubleshooting?
Thanks for your time!

Hey @Majorchaos!
You are very welcome!

The best app to see everything that’s in your system is the inxi. You can install it via:

sudo apt install inxi

Once installed, execute it with the following parameters:

inxi -Fxxxza

I do find it funny that they put in the “x” three times, but that’s for the extra details. :laughing:
Once you get the output, please post it here.

Ok here is what it gave me:

Host: -________Compaq-Presario-CQ60-Notebook-PC
Kernel: 5.11.0-41-generic x86_64 bits: 64 compiler: N/A
parameters: BOOT_IMAGE=/boot/vmlinuz-5.11.0-41-generic
root=UUID=e61e3488-4c1c-4d68-82cc-4e88bd6ca8e3 ro quiet splash
Desktop: Gnome 3.38.4 wm: gnome-shell dm: GDM3
Distro: Zorin OS 16 base: Ubuntu 20.04 LTS Focal
Type: Laptop System: Hewlett-Packard
product: Compaq Presario CQ60 Notebook PC v: F.3E
serial: <superuser/root required> Chassis: Wistron type: 10
serial: <superuser/root required>
Mobo: Wistron model: 303C v: 08.60 serial: <superuser/root required>
BIOS: Hewlett-Packard v: F.3E date: 06/23/2009
ID-1: BAT0 charge: 0% condition: 47.5/47.5 Wh (100%) volts: 10.8/10.8
model: Hewlett-Packard Primary type: Li-ion serial: N/A status: Unknown
Topology: Dual Core model: AMD Athlon QL-64 bits: 64 type: MCP
arch: Turion X2 Ultra family: 11 (17) model-id: 3 stepping: 1
microcode: 2000057 L2 cache: 1024 KiB
flags: lm nx pae sse sse2 sse3 svm bogomips: 8399
Speed: 1050 MHz min/max: 1050/2100 MHz Core speeds (MHz): 1: 1050 2: 1050
Vulnerabilities: Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass status: Not affected
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Full AMD retpoline, STIBP: disabled, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Device-1: NVIDIA C77 [GeForce 8200M G] vendor: Hewlett-Packard
driver: nouveau v: kernel bus ID: 02:00.0 chip ID: 10de:0845
Display: x11 server: X.Org 1.20.11 driver: nouveau compositor: gnome-shell
resolution: 1280x720~60Hz
OpenGL: renderer: NVAA v: 3.3 Mesa 21.0.3 direct render: Yes
Device-1: NVIDIA MCP72XE/MCP72P/MCP78U/MCP78S High Definition Audio
vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus ID: 00:07.0
chip ID: 10de:0774
Sound Server: ALSA v: k5.11.0-41-generic
Device-1: NVIDIA MCP77 Ethernet vendor: Hewlett-Packard driver: forcedeth
v: kernel port: 30f8 bus ID: 00:0a.0 chip ID: 10de:0760
IF: enp0s10 state: down mac: 00:1f:16:d1:2b:13
Device-2: Qualcomm Atheros AR242x / AR542x Wireless Network Adapter
vendor: Hewlett-Packard AR5BXB63 802.11bg Mini PCIe NIC driver: ath5k
v: kernel port: 4000 bus ID: 07:00.0 chip ID: 168c:001c
IF: wlp7s0 state: up mac: 00:25:56:a3:0b:8a
Local Storage: total: 232.89 GiB used: 9.90 GiB (4.2%)
SMART Message: Required tool smartctl not installed. Check --recommends
ID-1: /dev/sda vendor: Toshiba model: MK2555GSX size: 232.89 GiB
block size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
rotation: 5400 rpm serial: 794ASCIOS rev: 2C scheme: MBR
ID-1: / raw size: 232.38 GiB size: 227.74 GiB (98.00%)
used: 9.90 GiB (4.3%) fs: ext4 dev: /dev/sda5
System Temperatures: cpu: 66.6 C mobo: N/A gpu: nouveau temp: 55 C
Fan Speeds (RPM): N/A
Processes: 206 Uptime: 5m Memory: 2.67 GiB used: 1.07 GiB (40.0%)
Init: systemd v: 245 runlevel: 5 Compilers: gcc: 9.3.0 alt: 9 Shell: bash
v: 5.0.17 running in: gnome-terminal inxi: 3.0.38

Hey @Majorchaos!
Right now I see you are running the Open Source drivers. The speed is slower, but at least you don’t have the freezes. What I am thinking is that you could be facing a decoder issue. Let’s install all the available codecs out there:

sudo apt install ubuntu-restricted-extras

Since Zorin is based on Ubuntu, I believe the “multiverse” repository is active.

There will be an EULA you’ll need to agree to (since it will install some standard MS fonts also), but it’s nothing to be concerned about.

Once installed, restart your browser (and install another one to check if the issue happens there too) and to a test. Please let me know how it goes. :slight_smile:

I gotta say this particular laptop is like wrestling a greased pig lol!

I ran the command as you typed but…
I didn’t know how to agree to the EULA so while I was searching how to do that the computer went to rest so me thinking maybe I didn’t actually have to click anything I tried youtube and no go.
I read more and figured out to use TAB to move in the window to agree to the EULA but in the article it said I had to
sudo apt-get --purge --reinstall install ttf-mscorefonts-installer

I took that as I had to remove something and reinstall something to try again so I typed in
sudo apt-get --purge --reinstall install ubuntu-restricted-extras (I took mscorefonts as just being what this guy was using but id see if the procedure was the same to make what you told me to work)

I then typed sudo apt install ubuntu-restricted-extras
I was able to agree this time and it seemed fine

In the window firefox said it needed to get some file but the window was glitchy that it wouldn’t let me type in my password before disappearing. I had to spam click it and have my password copied and ready to paste to get it into the window in time to hit enter before it would disappear. (hence my greased pig reference)

I loaded up youtube and thought I could declare victory because everything worked for 10 minutes.
However the screen started to flicker and even after restarting the whole machine repeatedly it now seams to show the original symptoms of machine freeze I had with Mint and ubuntu originally

Should I just try another distro at this point? Zorin is the only one I tried out of your original list

Thank you for a good laugh @Majorchaos!
Sometimes it’s not so much about the distro, as it is an issue of the browser. And I apologize for missing out the navigation on text pages. You can cycle around the options with the TAB key and select with the Enter.

Before you throw out Zorin, how about you try a Chromium/Chrome-based browser without the tracking? I am thinking of Brave browser. You can easily install it via the script I prepared in the following post. Give it a shot and let me know how it goes. :slight_smile:

I think we have this greased pig in submission now lol!
Yes it is much more stable on Brave. Like 99.5% better. There is still a little flicker after about 30min of viewing but a quick pause and its back working well and no issues freezing up the machine in general.
I think I will call that victory and move on.
Much thanks once again for you and your teams efforts!

1 Like