Keychain error pop up

@vasileios I put this as a new topic because it came back … the error " keychain password doesnt match log in password" I did the purge keychain and reinstall keychain as you stated in the brave browser chat. That went through easily and the problem was resolved until I rebooted the laptop. Now the pop up is back. I redid the process of purge and re install and no changes this time. The error still pops up. Is there anything else to try beside deleting it?

Hey @myundividedlife!
Since this persists, then I suggest we change the Keyring’s password to match your login password, provided you’re logging in using one. :wink:
Open up a terminal and type in:

sudo apt install seahorse

Once it installs, go to your menu (Windows or Command Key) and type in:

Passwords and Keys

Then you will get an image like the following:

Where you can effectively change your Keyring’s password to match. Once that is done, I pretty much doubt the pop up will bother you again. :slight_smile:

Provided you do type in a password to login.

ok great! yes i use password to log in . I can hardly wait to do this. will post what happens later. Appreciate your knowledge.

1 Like

My pleasure, @myundividedlife!
Looking forward to your success! :slight_smile:

Hi @vasileios . I finally got a few minutes to concentrate on this and use your info. I am looking forward to my successes with this too lol! but so far I am not there yet. :upside_down_face: but its making me chuckle a bit because it has now come down to a simple question. First, let me recap: I followed your above instructions; installed seahorse. went to passwords and keys windows and clicked on the change password in the drop down. A box pops up for entering my old keyring password so I can create a new one. I have no clue what the old one is. I tried every password I have in my files but none are accepted.

Now what ? thanks in advance as always. The thing I like about having these stumbling blocks is when the breakthrough happens. I learn a lot in the process too!

I thought I would add this too as I was trying to find out when it was created but there is no info.

Hey there, @myundividedlife!
In those touch scenarios, the best way is to start over. Don’t worry, I’m not talking about reinstalling your system. Just open up the terminal and type in:

cd ~/.local/share/keyrings/
mv login.keyring login.keyring.backup

Then, run Seahorse again. Under the Passwords (now empty), create a new keyring, which you’ll need to name as Login and you can put the password you like. Preferably, the one you log into your system with. :slight_smile:

ok @vasileios . I will do this and let you know again how it goes. Get back to you soon! :+1:

1 Like

hey @vasileios this worked PERFECT. YAY. I rebooted too to check it out afterward and still no more popup. Thank you !!

1 Like

You are most welcome @myundividedlife! Enjoy! :slight_smile:

Hi Vasileios, I am having the same issue when trying to use Nord VPN. I have followed the above steps and when I open Seahorse I still see a login which when I try and open it I get “Keyring is Locked” with a green “unlock” button, I click on it and nothing happens. I have tried putting these into the terminal together and as seperate entries “cd ~/.local/share/keyrings/”
“mv login.keyring login.keyring.backup”
after which I open up Seahorse and then go to passwords and keys only to have the same issue. I will try and upload a pic of the error message I am getting when I try and update the password.

Thanks in advance to anyone able to make sense out this,

I think I managed to get it sorted out :slight_smile:

So what did you do to sort it out, @Billy ?

Hi there @nwarren, honestly, I have no idea. I am guessing that I was not doing something correctly from the beginning. I just kept trying over and over and it finally started working. I wish I understood more so that I could actually be of some help to others.