Is there a workaround for "PAE" Linux install issue?

I have a ~20 year old Dell Latitude D600 laptop that I had tried to install Linux on, and every time I tried to boot it up (running a “live” instance of Linux) I got a PAE error. Something like “PAE not present”. It looks like the Linux kernel wants to see PAE associated with the CPU. I did read somewhere that this era of Dell laptops (2004-ish) has PAE disabled by default, but I didn’t see anywhere in the BIOS to change that.

I was trying to install a 32-bit version of Linux, as the laptop is surely 32-bit, I think it was Peppermint OS (one that I have on a Ventoy drive). Anyway, I couldn’t get anywhere with the “PAE not present” issue when trying to do the install. Does anyone have experience with this, or know how to enable PAE - and specifically on a Dell Latitude D600 laptop, if possible? Thanks.

Hey Stan
Back in April I was Playing around with a 32bit IBM … using a Mint Cinnamon 32bit on boot-able drive … when the start screen showed up it had a “start with PEA forced” option …

did the Peppermint start screen have this option … this is from the tread I did at the time … Old IBM T42 32bit storage locker find .... or how fast can I install Linux on this Oldtimer The sad thing is that 32bit is getting less and less support as time goes on …

1 Like

Thanks for the reply I.B. No, Peppermint did not give me that option. I tried it again to see what exactly the error message was. Here it is (after booting off USB to Peppermint launch):
“Warning: PAE disabled. Use parameter ‘forcepae’ to enable at your own risk!
This kernel requires the following features not present on the CPU: pae
Unable to boot - please use a kernel appropriate for your CPU.”

At that point I’m not able to type anything or move forward, so I just have to shut the laptop down. There is no ‘forcepae’ option when the Peppermint list comes up.

I guess I could try that 19.3 Mint 32-bit like you did. I found this page that has an image of the Mint boot-up screen. It does not include a ‘forcepae’ option, but maybe that will present itself on my machine? I guess it would only show up as needed.

Here’s the link to just that image on the above page:

Stan … when I was doing this “KatM” mentioned Debian 32bit …


May '23

“I went with the Debian 11 32 bit because its supposed to be supported until at least July 2024. It was also pretty easy to find and install the missing firmware, it was for the wifi driver. Just had to edit my repository config to add non-free and installed the missing firmware. Its a little on the slow side compared to my other computers, but it works. If you have too many issues with the Mint install, try the Debian, when you have time of course.” (end of KatM quote) I was going to try the Mint LMDE 5 … and was able to install it at the time … however with the IBM I ran into the Wifi problems for the first time and didn’t follow up with the install … thought it was RAM related so finally installed Q4OS … had the same Wifi problems but, realized that to update/upgrade I needed to make a direct Hard-Wired Network connection and the Wifi worked perfectly there after … Wanted to go back and retry LMDE but summer set in and I ran out of “me-time” … wound up giving the IBM to a friend who was interested for it’s use on his job that required transferring software updates to industrial machines … haven’t messed with 32bit since … good luck and hang in there …

1 Like

Thanks! Yes, I see that Mint install 32-bit version support expired in 2023, so Debian is an option.

Now I have 2 more options to try for ‘forcepae’, thanks for the advice!

I just wanted to follow up on progress. The first install of Mint failed, I had Windows XP on there and tried installing next to it. When the setup says “remove media and hit Enter” to restart, it didn’t seem to restart. So I shut it down. Powered back on and the OS menu came up but did nothing else. I did a 2nd install and wiped the drive with only Mint installed. XP was making it too slow anyway. I’m hoping Linux will improve the performance a bit. I went with Mint Xfce, as it said it was the ‘lightest’. I had the same issue with it not rebooting after install, but it came up okay this time, just a little slow as I guess it was still setting itself up. It’s working alright now, doing a bunch of updates.

So I may try Debian later. I have a few months if support ends in July. But this laptop only needs to function on a basic level, so if Mint does the job I may leave it. Obviously, the “Force PAE” thing worked (it was in the menu just like in your image), but that took a little while too before Mint ‘live’ came up.

1 Like

Congratulation … yes I learned the hard way … you have to be patient … wait for it to “do it’s thing” before going to the next step, especially with 32bit … The good news is that after the updates things might improve as far as the overall speed …Ha … I’m old enough to remember when XP was considered “Fast” … anyway I did the same thing … and shut down an install when I thought it wasn’t working … that’s how I “Had to Learn about Grub Repair” … Depending on what you are using this computer for … “Support” is not such a worry … My Wife’s laptop is still running Linux Mint 19 … as mostly a word processor … and as long as it works for her I won’t try and mess things up by “fixing it”… when I see the “do you want to restart or continue using live session” during a set up … I will click continue and when the set up disappears … then I manually shut down the “live Session” and wait for the computer to Completely Shut Down … (some times this take time) … then remove the flash drive and hit the starter … with fingers crossed … :grinning:

1 Like