Installed Proton VPN from firefox now no internet connection

I am connected with and ethernet cable it and it says connected to the wired network. after i installed my VPN service it worked fine then the next time i turned on my desktop it wont connect to the internet. i have since uninstalled the VPN client and it still wont connect. any help would be great appreciated

Hello @coryd331 and welcome to the forums!
Yes, Proton VPN has a service that masks the DNS and an Internet Kill Switch. So, when it’s not running, it allows no Internet to go through.
Let’s start with flushing the DNS cache it created. Start a terminal on your system and execute the following commands:

sudo systemctl systemd-resolved --flush-cache
sudo systemctl systems-resolved --statistics

Once the DNS is cleared, go ahead and restart the Network Services:

sudo systemctl restart systemd-resolved
sudo systemctl restart NetworkManager

Give it a few seconds on each of the above commands, then type in:

ping -c 3 google.com

What response does that give you?

1 Like

after entering the above in the terminal, it tells me systemctl: unrecognized option ‘—flush cache’

Hey @coryd331!
My apologies. I took the commands to the “Daemon” (background services) level, when I should have taken it to the front-end. That’s besides a typo my auto-corrector decided to fix (I have to fight with that all the time, when I type commands).

The option commands should then be as follows:

sudo systemd-resolve --flush-caches
sudo systemd-resolve --statistics
1 Like

did the 2 lines of code you sent. but i get this when i put in the ping -c 3 google.com

Let’s see if it’s only DNS related. Please execute the following command:

ping -c 3 8.8.8.8

And please let me know of what message it produces.

I typed it in and got this response

So, you do have internet, which means the DNS service is having a few issues. Let’s see what they are. If during the process we need access to packages or updates, I can temporary give you full DNS, which will reset after your next reboot, so let’s begin.

In your terminal, please execute the following command and send me the output. :slight_smile:

sudo systemctl status systemd-resolved

Done

And there lies your problem! Your system looks for a DNS resolution onto its own self.
Can you open up your network connections and select the properties for your connection? There should be a few tabs over there and I will appreciate if you can send me the screenshots of your IPV4 and IPV6 tabs. :slight_smile:


Great, thank you!
I would recommend you disable the IPV6 completely, and then on the IPV4, add the following additional Name Servers:

1.1.1.1, 1.0.0.1

Then click Save, go to a terminal and type in:

sudo systemctl restart NetworkManager

Then execute:

ping -c 3 google.com

And let’s see what that now gives you.

1 Like

it doesnt give me the option to click save no matter how i type the 1.1.1.1 or the 1.0.0.1, am i doing this correctly? i have disable the IPv6 settings also.


Not the IP addresses. Use those for the Additional DNS servers. :slight_smile:
(Make sure you delete the static IPs or you won’t have internet at all)

Okay! Seems that some issues remain still. Let’s go a bit deeper:

sudo su
mkdir /etc/systemd/resolved.conf.d/
nano /etc/systemd/resolved.conf.d/dns_servers.conf

When it opens, add the following content:

[Resolve]
DNS=1.1.1.1 1.0.0.1

Press CTRL+O and then Enter to save. Then CTRL+X to exit.

Then execute:

systemctl restart systemd-resolved
resolvectl status
systemd-resolve --status
resolvectl query google.com

Does the last command give you any IP addresses?

Ah, you’ll need to press Enter at the end of each line - as they’re all different command sets. :slight_smile:

tried it twice, says cannot create directory, no such file or directory?

In that scenario, you can bypass the mkdir line.