Install Epson WF-3820 printer

I have tried to install using the add printer option. I chose the correct printer and it doesn’t work when I send a test page. I don’t know where to go from here.


Which Linux distribution and version are you running?
Have you tried looking at the Epson website? The following link is for Linux in generall

If you happen to be running Linux Mint then this website may be of help. I find this page a little complicated to navigate, Look for the “Next Page” immediately following ‘the Contents’ as you scroll down.

Post back here with info and questions.

I did the download, however there was a list of them and here is what I get when I download one of the .deb ones. It says I already have it installed but I have no idea how to find it. I use the add printer again and it can’t find the drivers. Can we do a teamview?


Did you get your driver download from the Epson .com link posted above? Looking at your screen shot I assume your CPU is an AMD because your driver shows as an “_amd64.deb”.

If it came from the Epson website, did you happen to notice a note before clicking the file to download? Similar to the one I am posting below? Note the blue highlighted section “Ubuntu: # apt install lsb”.
If your processor is an AMD then possibly you may have received a different note if the Epson website is serving different pages for AMD processors. You may want to go back and check by trying to download the driver again.

Let me know what your find out.

I downloaded both because I did not know which one to download. I have no idea what processor I have. I do have linux mint. I have tried to delete both, but if I download again it says that I already have it. I really don’t have any idea what is going on.

I think the driver you downloaded is the correct one for your printer and if you have an AMD processor (CPU). If you still have it keep it. But we will probably need to do another thing first then reinstall the driver.

Can you go back to the download page and show me a picture similar to the one I posted that shows the “Filename” and “Filesize” for the different downloads. And try to get the “Information” that may show up below them like in my picture.

After posting the picture here then on your computer open a terminal and type:
then press enter.
Just a few lines down will be a line, “Model Name” what does that line say?

Then still in a terminal type:
cat /etc/os-release
then press enter.
All we need from that is just probably the top two lines:
NAME= {your distribution name}
VERSION= {your version}

Please post the information here and we will try to get the driver installed.
I am pretty sure you need one of the drivers that ends in .deb .

Model name: Intel(R) Core™ i5-8250U CPU @ 1.60GHz

NAME=“Linux Mint”
VERSION=“20.2 (Uma)”

looking forward to hearing back from you.
Thank you

At the download page in your image above you want to click the “Download” button for the top line showing the Module Name “ESC/P-R Driver 2 (generic driver)”. The page will change and show you more selections, you may have to click the “Accept” button to show the list of drivers.
You should then see a list of drivers similar to my screenshot (above). You want to click “Download” for the (second line in my screen shot)
"epson -inkjet-printer-escpr2_1.1.55-1lsb3.2_i386.deb"

Read the [Notice] in my screen shot just below the list of drivers. You will also see (in my screenshot the highlighted in blue)
“Ubuntu # apt install lsb”
We will need to that before installing the driver.

Make sure you get the
"epson -inkjet-printer-escpr2_1.1.55-1lsb3.2_i386.deb"
downloaded then come back here to follow the instructions I will post below.

After you have downloaded the correct driver, open a terminal and first we will check to make sure everything is up to date. Then we will install lsb .
Then we will uninstall any previously installed Epson print driver. and after that we will install the newly downloaded driver.

Remember, when using sudo it will ask for a password, that password is your user password, sometimes when using sudo multiple times within 5 minutes it will only ask for the password the first time and then again if 5 minutes has passed between sudo commands.
In a terminal type:
sudo apt update && sudo apt upgrade -y
then press enter.

Once that is done, still in the terminal, type:
sudo apt install lsb -y
press enter
if it says already installed then you are good to go or if it installs with no errors then you are good to go. If any errors post the errors back here.
Now to uninstall any previously installed Epson drivers, still in a terminal type:
sudo apt show -a epson*
press enter
(Post back here if you have any questions on which one(s) to remove)
If that shows any installed Epson drivers we should probably un-install them before installing the correct driver. So still in a terminal type:

sudo remove {the name of the driver you want un-installed}

That should remove the un-needed drivers.

Next, still in the terminal, type:
cd ~/Downloads
press enter
ls -al ep*
press enter.
That will show a list of everything in your Downloads directory starting with the first two letter “ep”. You will be looking for the newly downloaded
Now still in the terminal type:
sudo apt install epson-inkjet-printer-escpr2_1.1.55-1lsb3.2_i386.deb

All went well until the last thing…see pic

OK, I had an extra space in the command.

sudo apt show -a ep*

then remove any that show up with:
sudo apt remove {the driver name}

Then the install command should be:
sudo apt install epson-inkjet-printer-escpr2_1.1.55-1lsb3.2_i386.deb

I am confused a bit. What am I removing? and from where?

Sorry, I had hoped to edit the post above before you got to it. I was too late for that.
To remove the drivers you previously install for the Epson, in a terminal type:

sudo apt show -a epson*
press enter.

Then to remove any epson driver in a terminal type:

sudo apt remove {the name of the driver}
press enter

That should remove the previously install epson driver

after the first instruction it says …
nancy@nancy-Lenovo-YOGA-730-13IKB:~/Downloads$ sudo apt show -a epson*
N: Unable to locate package epson-inkjet-printer-escpr2_1.1.55-1lsb3.2_amd64.deb
N: Unable to locate package epson-inkjet-printer-escpr2_1.1.55-1lsb3.2_i386.deb
E: No packages found

I do not see where you installed lsb ??
If you have not installed lsb then in a terminal type:
sudo apt install lsb
press enter.

After that we will install the epson driver

ok, just did that last one
sudo apt install lsb

install lsb first

Then change the epson driver command to include ~/ like below,
sudo apt install ~/epson-inkjet-printer-escpr2_1.1.55-1lsb3.2_i386.deb
press enter

nancy@nancy-Lenovo-YOGA-730-13IKB:~/Downloads$ sudo apt install ~/epson-inkjet-printer-escpr2_1.1.55-1lsb3.2_i386.deb
Reading package lists… Done
E: Unsupported file /home/nancy/epson-inkjet-printer-escpr2_1.1.55-1lsb3.2_i386.deb given on commandline

I’m sorry, I shouldn’t try to hurry.
The command should be:
sudo apt install ./epson-inkjet-printer-escpr2_1.1.55-1lsb3.2_i386.deb

nancy@nancy-Lenovo-YOGA-730-13IKB:~/Downloads$ sudo apt install ./epson-inkjet-printer-escpr2_1.1.55-1lsb3.2_i386.deb
Reading package lists… Done
Building dependency tree
Reading state information… Done
Note, selecting ‘epson-inkjet-printer-escpr2:i386’ instead of ‘./epson-inkjet-printer-escpr2_1.1.55-1lsb3.2_i386.deb’
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
epson-inkjet-printer-escpr2:i386 : Depends: lsb:i386 (>= 3.2) but it is not installable
E: Unable to correct problems, you have held broken packages.