I have a mac but want to install ubuntu on a PC

Hello. I have a Mac Air but I want to install Ubuntu on an old Gateway PC I have from a USB.

Does anyone have a good video or support page I can follow.

One thing I’m confused about is, do I install a mac usb bootable program or a PC one.

Hope that makes sense.

Thanks for your help.

Balena Etcher is compatible with MacOS. You should be able to make a USB using that and use it on a PC.

Thanks. I’m following this video and it’s flashing right now. Let you know how it goes!

Hello,

I installed the USB drive with the downloaded Umbutu file successfully.

When booting up the pc I want to install on, I have 2 options of booting up.

  1. Boot Menu
  2. BIOS Menu

When I go for the boot menu I get this message about my file being corrupted.

When I go try to boot through the BIOS menu, it’s strange but when I press the enter button when choosing my flash drive, nothing happens.

Should I be booting from the BIOS menu or the Boot Menu? When I do, what could it be that I am doing wrong? Thanks.

Doing either should work, but I’m noticing that you have a different problem. Broadcom components tend to be a real hassle with Linux. This could potentially also be causing your “isolinux.bin missing or corrupt” error. But there is something else we can try first.

I don’t know if this will work, but it might be worth trying. Before you flash the ISO to the USB, try replacing the .iso with .bin in the filename of the ISO image. It may be that the computer you’re attempting to put it on is looking for a .bin file and is not finding one because you flashed a .iso to the USB.

So I’m trying to do that. When I try to mount the USB again on my Mac so I can erase it, it gives me this message in the Disk Utility:

Otherwise, I can’t flash it again on my Mac because it won’t mount.

Appreciate your help on this.

1 Like

Does this occur right after it finishes making the ISO on your Mac?

Not right after but after the ISO didn’t boot on the pc, I put it back into the mac so I could flash the usb again with the .bin like you said but the usb won’t mount because I get that error.

What happens is that Etcher has to format the USB and it is not a format that Macs or PCs recognize as a general use drive. The alert message that you’re getting is typical and nothing to be concerned about.

Additionally, when I use Etcher and I get that alert, I just ignore it and Etcher will still recognize the USB even though it doesn’t mount to the desktop.

Some other general points on the ISO:

Make sure you’re using an LTS (Long Term Service) version of Ubuntu (current is 20.04 i believe).

Always download from official sources. One way to ensure this is to follow the ISO links from distrowatch.com

If your PC is older, try downloading an older version of Ubuntu.

You can also try a different distro like Linux Mint and see if that works.

I tried the LTS, didn’t work. Got the same error as the photo below.

Not sure which version of Ubuntu I would download for older laptop but I tried the 32 bit version of Lubuntu. I still got the same boot error that I posted here below. I tried Mint and got the same error. Not sure why it says .bin file when I have been flashing the drive with .iso files from the direct download.

Another thing to try would be to use version 20.10 or 21.04. They are not LTS like 20.04, but they might interact with you PC differently.

I found this link for 20.10 but it’s 64bit whereas I think I need 32 bit. Can’t find a link for 32 bit.

https://releases.ubuntu.com/20.10/

I’m downloading 21.04 now and I’ll try that but I think I tried that one already.

And that my friend could be the culprit of your woes.

I do not believe that Ubuntu is compatible with 32-bit systems. However, there are distributions that do support 32-bit. I can’t think of any off the top of my head, but you can peruse distrowatch.com for one that does. It should show up on the main profile for the particular OS under “Architecture.” It will say “x86” for 32-bit, and “x86_64” for 64-bit (which is the one you don’t want).

So my system is 512 ram and I thought that was why the the iso was not loading was because the distros I was trying had higher ram requirments. I followed the video below which gives options of different 32 bit distros which are available. I tried Bodhi Linux but still got the same error that I had before which says that isolinux.bin is missing or corrupt. I thought this would work but still the same thing.

Just tried a 32bit version of Mint and got the same corruption error.

For Mint you have to go back to 19. ? for 32 bits. The rest are 64 only. Top 14 Linux Distros That Will Support 32 Bit Systems

Now I am getting this error for every distro that I try to flash to the usb. This part was working fine up to now but Belana Etcher is failing every time now. I have tried closing and restarting my computer but it’s the same.

try a different flash drive and use Rufus. It’s the only one I have ever used.

Just bought a new usb but and it flashed but the old pc is not recognizing the new usb. Is it possible that this usb is newer and that’s why the pc is not seeing it? They look exactly the same.

What capacity is your new USB drive? Normally, any thumb drive should be backward compatible.

1 Like