Fresh install, no network search

I can’t figure out how to connect to my home internet network. There is no wifi symbol because the laptop is not searching for the network at all. I’m assuming the install deleted a driver. The symbol at the bottom with the arrows opens the network boxes, but there’s nothing in them, and nothing I’ve tried so far has worked.


Let me see if I can help you, although I’m not a Linux master yet, I have decades of experience with software and computers and is a lifelong hobby. May I first ask you what hardware are you using and which Linux Distro have you installed? This will help me navigate my questions to your Linux flavor.

This same thing happened when I installed Mint on my wife’s laptop, and was an simple fix.


1 Like

Michael, Thank you for your reply. It’s a Dell with Intel 13. That’s all I know, as it was my son’s old computer and the other info was on a sticker that has since been removed. I installed Cinnamon.

1 Like


No worries at all, and when you say Cinnamon I’m assuming its Mint Cinnamon. Let’s first rule out that the install has a driver ready but forgot to load it for some reason.

Click on you LM icon on the bottom left corner, which should bring up a menu of applications. Find the one named System Settings and double click to open it. This will bring up some administration programs and at the very bottom there should be an icon that is titled Driver Manager. Double click on this and it will ask you for your password to start the search.

Let me know if it finds any drivers that are not installed. If it does find a network driver, it should present you with a selection to install it. When complete do a reboot and see if you now have wifi enabled.

If it does not, then we’ll have to dig a bit deeper.

Can you open up a terminal window by pressing Ctrl + Alt + T
Maximize that window, to view the output easier without word wraps, and type the following

inxi -Fxzd

You should see a full report on your machine specs and if you can let me know what the System: and Network: options say exactly. (I’m assuming with no internet connectivity you can’t just copy and paste the entire output easily to a reply)

1 Like

Hello @Stacey!
And thank you @mva for coming in to the rescue!

If you can, please take a photo of the bottom right of your desktop (the bar) to see if there’s an icon for the WiFi. This will let us know if it’s connected. If there’s a red “X” next to a computer/wired network, then it means it cannot find your WiFi module. If that is the case, then we can dive deeper to fix it. :slight_smile:

Thank you for replying. See screenshot below.

Thank you for replying. See screenshot.

Hello @Stacey and Merry Christmas!
Normally, your Broadcom chip has a support package for Ubuntu (and Mint). You will need the DKMS package installed (the Kernel Module Management), which should be present. If it’s not, open up the terminal and execute:

sudo apt install dkms

Then, execute:

sudo apt install wireless-bcm43142-dkms

If the system cannot find the package, then you can download it from:

And save it to your Downloads folder. Then, open up a terminal and execute:

cd ~/Downloads
sudo apt install ./wireless-bcm43142-dkms_6.20.55.19-1_amd64.deb

Once installed, try a reboot and see if your WiFi is active. :slight_smile:

Thank you @vasileios! How do I get out of this?

Hey @Stacey!
Tab will highlight the area. Once it does, hit Enter. :slight_smile:

I give up. I followed all the steps and got this error. I rebooted just to see, but no network.

No need to give up just yet!
Without reading the logs, my first thought is that the make command itself maybe missing. You can rectify that by running:

sudo apt install build-essential

After that, go back to your Downloads folder (where you saved the deb file for your WiFi) and execute the following:

cd ~/Downloads
sudo dpkg -i --force-overwrite ./wireless-bcm43142-dkms_6.20.55.19-1_amd64.deb
sudo apt update
sudo apt install -f
sudo apt autoremove

Please let me know how that goes!

Now no matter what I do I get the message: Waiting for cache lock: Could not get lock /var/lib/dpkg/lock-frontend. It is he…that’s all I can see, and it repeats over and over.

Ok, stand by. I need twenty characters to reply…

1 Like

If that indeed takes long, you can get rid of it via:

sudo mv /var/lib/dpkg/lock-frontend /var/lib/dpkg/lock-frontend.backup

Normally you can just remove it, but let’s keep it for now.
Once you do that, then you can re-issue the above commands.

I tried it twice. It did stop the process, but as soon as I typed sudo apt install build-essential
it started again.

Then its background update must be working and is stuck. We can bypass it immediately (and stop it from taking so long in the future), by combining commands. Do this first:

sudo rm /var/lib/dpkg/lock-frontend && sudo apt install -f && sudo apt autoremove

Then try the previous commands again.

Nope. Didn’t stop. \0/

Ok, it did stop. But it won’t let me type anything without that message.