DIsplay Mirroring using Dell Rugged Tablet 7202 and Auxillary Display Link

Hello, I’m fairly new to Linux and so far have converted two MS OS laptops to Mint Cinnamon without much fanfare. Both installs, one on an HP, the other on a Dell, have gone well. Everything seems to be working fine except for screen mirroring from the Dell Rugged Tablet, model 7202 using an auxiliary display link. It worked fine in MS Win10. With Win10 i used an HDMI cable for the mirrored monitor. Since this didn’t immediately work with the Linux distro, i purchased a dedicated displayport cable to no avail. The monitor does not recognize the displayport cable at all. The monitor is a Dell model no. 2408 WFPb
With the HDMI cable the monitor enters powersave mode. When the HDMI cable is disconnected from the monitor, the monitor displays a popup indicating “No HDMI Cable”. As soon as the HDMI cable is plugged back into the monitor, the monitor enters powersave mode.
My next experiment would be to purchase an HDMI to USB cable to go direct from the tablet to the monitor. If this works it will provide some temporary relief, but long term I would prefer having the additional available ports on the display line for keyboard and mouse support and reading/writing thumb drives.
There is a 15 pin display connection on the Display Link. Not sure I have any of those cables around anymore? Maybe this is another experiment?
In System Settings, under Display the second monitor is not recognized, The “mirror displays” and “set as primary” buttons are both grayed out. Only “Laptop eDP-1” is available.
What am I doing wrong? Any suggestions are appreciated.

Thank you,


First I would disconnect your external display and go check the mint display settings and make sure “mirroring” is enabled prior to attempting to connect the external monitor.

the Old vga 15pin should work accordingly but you may have to use the fn+? for your particular model laptop, that may possibly work aswell for your mirroring monitor.

Mine looks like a “projector” on my f7.

another thing. some laptops(particularly my thinkpad 460, have a dedicated FN key by pressing Fn+Escape that “blocks” out the sound, brightness etc… unless I press them with the Fn key depressed.

Hope this is of some help

1 Like

Thank you for the quick response. I disconnected the monitor, rebooted the tablet and checked the display settings. Nothing changed. The “mirrors display” button is still grayed out. Found a 15-pin VGA cable and plugged it into the monitor and into the display link. it acts just like the displayport cable. That is, the monitor is powered and popup window indicates “no HDMI cable”. Next step would be to purchase HDMI (monitor) to USB (tablet) cable and see what going directly to monitor from tablet would indicate.
Will do some research to see if i need to change settings on the monitor to use either the displayport cable or the VGA cable as primary data link?

Thank you again.

You keep referring to a “tablet”, you do mean laptop? What modelbrand are you using? I do remember you are on Mint.

Sorry just went back and reread your original post, Dell Rugged 7202.

let me do some digging.

This thread on Github seems to offer up a solution though since I do not have Mint I cannot test this particular problem out.

Mint mirroring issues

It’s a laptop that acts like a tablet. It’s circa 2016-17 so the buzz words back them were tablet vice laptop, best i remember. i like the device, but this display link box and trying to mirror to the monitor has me stumped. i have changed the input source from HDMI to displayport to VGA. in each of those cases when i insert the corresponding cable, the monitor goes into powersave mode. When i remove the cable, the monitor is powered and the monitor indicates that the corresponding cable is not present. Thank you.

To be honest the below looks foreign to me. I executed the xrandr command based on the thread you provided. Not sure what to do next?

pj@pj-Latitude-12-Rugged-Tablet-7202:~$ xrandr
Screen 0: minimum 320 x 200, current 1366 x 768, maximum 16384 x 16384
eDP-1 connected primary 1366x768+0+0 (normal left inverted right x axis y axis) 256mm x 144mm
1366x768 59.94*+ 48.02
1360x768 59.80 59.96
1280x720 60.00 59.99 59.86 59.74
1024x768 60.04 60.00
960x720 60.00
928x696 60.05
896x672 60.01
1024x576 59.95 59.96 59.90 59.82
960x600 59.93 60.00
960x540 59.96 59.99 59.63 59.82
800x600 60.00 60.32 56.25
840x525 60.01 59.88
864x486 59.92 59.57
800x512 60.17
700x525 59.98
800x450 59.95 59.82
640x512 60.02
720x450 59.89
700x450 59.96 59.88
640x480 60.00 59.94
720x405 59.51 58.99
684x384 59.88 59.85
680x384 59.80 59.96
640x400 59.88 59.98
576x432 60.06
640x360 59.86 59.83 59.84 59.32
512x384 60.00
512x288 60.00 59.92
480x270 59.63 59.82
400x300 60.32 56.34
432x243 59.92 59.57
320x240 60.05
360x202 59.51 59.13
320x180 59.84 59.32
HDMI-1 disconnected (normal left inverted right x axis y axis)

below the xrandr they suggest removing the xserver-xorg-video-intel package and rebooting with corrected problem.

I’ll give it a try and let you know. Thank you

1 Like

Still nothing on the monitor. System Setting Display remains same. Still cant get to “mirrors display” button as it is grayed out.
Had some weirdness when rebooting though. Dell logo popped up 4-5 times and LM logo twice before bringing up the desktop.
going to sleep on it for the night. Greatly appreciate your assistance. Thank you

1 Like

no problem,I will do some more digging tomorrow when i get a chance at work.

We’ll figure this out!

1 Like

I appreciate your patience. Thank you.

Have to head out of town for the weekend and will have the HP with me. I’ll check settings in the system settings, display menu to see if there is anything different. I’ll have a different monitor to try and mirror to. Will let you know what I discover.

1 Like

I had a similar problem on my computer and the issue turned out to be graphics drivers on my system (NVidia, of course.) You might check those. For me, updating to better drivers resolved my issue.

1 Like

Updated all the drivers before hopping on the forum. Will get the the HDMI to USB cable this weekend and embark upon narrowing down the issue a bit further. Thank you

Out of curiosity. Have you looked through the bios to check for an option to enable/disable external graphics?

I have not tried that. I’ll look s soon as I get back. Thank you

Finally got back in town. Tried the USB to HDMI cable directly from Tablet to monitor with same results. Looked at BIOS but didn’t see anything out of the ordinary nor did I see an option to enable/disable external graphics. BIOS indicated that the video controller was Intel HD Graphics with BIOS version 1038v03, 64MB. WIll take another look at video drivers and see if I can read anything in notes.

1 Like

I have Mint running on an old HP dual core laptop and have successfully mirrored the screen to a 24" Insignia TV/monitor using an HDMI to HDMI cable. i still cannot successfully mirror my Dell 7202 screen to the 24" Dell monitor, either directly from the laptop to the display or via the Dell Display Link. I have a few more things to try. 1. Try to mirror the known good Insignia display monitor to the Dell 7202 laptop. 2. Try to mirror the known good HP laptop to the 24’ Dell monitor. 3. if successful with either 1 or 2, try to mirror using the Display Link and, 4. Continue researching video drivers for the Dell 7202. Will post progress as am able to test things.


Found this command inxi -Fzx ont the Mint forums. Run it and c/p the output here so we can check your modesetting for graphics I haven’t seen much on Intel HD Graphics 5300 but seen more then a few mentions of 530.

Thank you again for your patience. I am again out of town and will endeavor to run the command when I return on Monday.