Converting 2007 Mac to Linux

I want to convert an 2007 Mac OS X version 10.5.8.
When trying to open www.ubuntu.com from Safari or Firefox I get server security error.
I tried all suggested fixes I could find on Youtube but nothing helped.I would greatly appreciate any assistance. Thank you!

Hello @isheinblat and welcome to the forums!
Since your computer’s software has been out of date (thanks to Apple), your browser cannot visit any website. You will need to flash your Linux USB on another system. Regarding the possible compatible distros, can you go to the apple logo on the top left, select the “About this Mac” and send me a picture so that I can get an idea about the specs?
Thank you!

Hi @vasileios ! Thank you for your response, here is the photo with Mac info…

Thank you for posting this, @isheinblat!
From what I can see, your CPU is 32-bit, therefore you should give Zorin Lite a go, the 32-bit.

You can download this from another system and flash the USB there to make it bootable for your Mac.

Are you familiar with the process?

@vasileios , I have a Dell Windows laptop which is my main computer that I can flash the USB on, but I have never done this before, any pointers would be greatly appreciated!

You got it!
First, go to your Dell and download the 32-bit ISO from the link I posted above.
Meanwhile, go to:

Download and install Etcher.

Then, run Etcher. It’s all about 3 steps:

  1. Select the ISO file you downloaded (Zorin Lite)
  2. Plugin your USB (4-8GB or more) and select it on Etcher
  3. Hit Flash and wait for it to record and verify.

There’s a video here too. Just keep in mind that the guy is using a different ISO, but the process is the same.

Once you’re done, plug the USB to your Mac and start it up, keeping the Option Key pressed. It should present you with two disks. The main one and the UEFI/USB. Select the latter and boot to it. From there on, follow the instructions on installing Zorin.

Remember to backup any files you have on your old Mac first.

I flashed the USB as per your instructions, then when I tried to restart the Mac with the USB inserted while holding down the Option Key, it only showed the main disk and not the USB as well, am I doing something wrong?

You’re doing nothing wrong. There are some old Macs that do not boot via USB. Yours just happened to be one of them. You might want to try recording the ISO on a DVD. Does any of your systems have a DVD recorder?

I have an external DVD drive…

Then you can use that to burn the ISO file to an empty DVD disk and use that one to boot via the same way (with the option key).

I burned the DVD and now when trying to boot the Mac from the DVD this is the screen I get…

Hey @isheinblat!
As far as my knowledge goes, this message appears (with the frozen keyboard) when you boot into a 64-bit version of Linux. Did you happen to burn that one by mistake? (you will need the 32-bit)

Yes, @vasileios


it was the 32-bit one, these are the files on the disk

Okay! In this scenario, I believe the best course of action is to replace the boot loader - so that the old OS does not give you any more trouble. I looked up for a guide and found one for a system a year older than yours. So, there are good chances it will work!

1 Like

Wow, thank you @vasileios ! I installed the rEFInd boot manager utility on tha Mac and it actually let me boot from the USB and strangely when I tried to boot from the DVD it gave me the same frozen keyboard and screen. So now I went through the steps of installing Zorin and clicked on restart to install and since then the Mac has been on a black screen for about an hour now - is this normal?

Hey @isheinblat!
Does it go through the boot menu when it starts or is it permanently stuck on a black screen without showing anything?

Well I haven’t touched it after I clicked on ‘restart the system to finish the install’ and it’s displaying the black screen - should I try to turn it off?

Hey @vasileios I went ahead and restarted the Mac after it was stuck on the black screen
and it booted up Zorin! But why when it boots up the “num lock” key comes on?

Sometimes a service may hang temporarily, which causes the black screen. Most of the times, it is not persistent and I’m glad this was the case with you!

Per the Num Lock, that is normal, so you don’t need to worry. If you have the extended keyboard (with the numeric pad) then nearly all operating systems do that. :slight_smile:

Thank you so much for all your help and guidance @vasileios !!!

1 Like