Boot Manager Is Missing

Trying to install Zorin on Toshiba Satellite L755 running Windoze 7.

When boot from USB is selected I get "Boot manager is missing. Press crtl+alt+del to continue.

I followed these instructions:

and got the same response booting from USB. When booting from HHD I now get asked if I want to boot from Windows 7. There is no other choice.


It sounds like your Toshiba is not yet trying to boot from the USB drive and is still looking for the windows boot loader on your hard drive. Have you performed the following prerequisites?

  1. Created the Zorin USB install device by burning the .iso image onto it using a program called rufus or balena?

  2. If you plan to dual boot linux with windows, you have to create a second partition for the Linux OS as it requires a different filesystem. (Unless you are planning to erase windows completely and just want linux on this machine)

  3. Entered your Toshiba BIOS and changed your boot order to boot from the USB first in the boot order listing?

  4. Turned off the secure boot option, if present, in your BIOS?

If you need any help with the above, please let us know


1 Like

@mva Michael,

Yes, thank you, I still need help.

  1. ISO burned to USB with Rufus… going to try Balena Etcher next as per a @Vasileos suggestion in a different thread. Have successfully installed different Distros on two other laptops.
  2. No Dual boot. Will be booting into “test” mode and install on external drive/2nd drive. Waiting for adapter to swap out DVD tray for HHD. Eventually going to make Windoze a distance unpleasant memory.
  3. F2 to check/change Bios settings including boot order. Legacy Boot; Normal boot speed. F12 direct to boot selection.
  4. No Secure Boot option.

Have spent way too many hours on this. All my research results are about problems with machines booting into Windoze. My Windoze boots just fine. Only have the problem when boot from USB selected so starting to suspect that problem is with the USB and NOT the Win 7 Boot Manager?

Does the Linux ISO burnt onto the USB contain a “Boot Manager”? I see mention of “GRUB” but not sure if that applies here.

My first two laptops were “dead”. Linux did a Lazarus on them and opened the door to a new world. Sadly the hardware is too outdated. The Toshiba is my workhorse and I had hoped to convert it to Linux.



Sorry you are still having trouble.

Yes it might be the USB stick format program being the culprit, so have a go with Balena.

Another thought I have is how about you also try burning a different Linux distro on it as well? I tried to install Zorin on my 2011 Thinkpad and I also had trouble with the installer and it never loaded correctly for me. However, MX-Linux, Ubuntu, Manjaro, Mint and PopOS all loaded and work flawlessly on it.

I’m confident we will find a way to get Linux running on it.



Happy New Year Michael,

Tried Zorin via Balena… no success.

Will now try other distros.

One of the options in the boot menu is “FDD”… which drive is that? I keep an SSD card “permanently” inserted as a backup medium for my very important files when away from the house (I don’t trust “The Cloud”)

My optical drive is dead, otherwise I would have tried burning the ISO onto a disk. Once I have a second HHD in the DVD bay I was hoping to put Linux on that. I’ve been reading about “persistence” as an option on some installs and wondering if that is a way forward?

I love your optimism. I am not ready to give up either.


Typos in above HHD = HDD and SSD card = SD card :wink:


You are a wise man, as I too don’t trust any cloud service with anything of mine. I make a few exceptions here and there, but act as if I’m purposely dropping my wallet at a train station during rush hour :wink:

FDD stands for Floppy Disk Drive and many moons ago, all computers had them for external storage and for installing older operating systems like DOS. Today it is obsolete and I’m not sure why it even still exists in the BIOS.

It is my understanding that “persistence” in terms of Linux installations is for portability purposes only, where you would just run Linux on your machine from a USB Live drive and use the hard drive for data storage only. You can then take the USB on the road and have your desktop wherever you go. Not sure of the benefits on a Linux home computer though.



FDD - Floppy WAS my first guess… then I told myself not to be so stupid… :slight_smile:

Slowly running out of options.

Tried Mint - no luck

Just for shits and giggles I plugged the USB into the Missus’ Toshiba and booted into Linux with no problems… why me Lord, why me?

I think He is telling me it is time for a new PC.

Gonna wait for my drive adapter before throwing in the towel.



If I understand you correctly, your USB stick is not the problem as you were able to boot to it using your wife’s computer. So logically your computer’s USB ports are either faulty or maybe not capable of reading the newer version of USB standards. Is your USB stick a 3.x type or the older 2.x type? Usually the 3.x sticks use a blue colored plastic on one side when you look inside the port. (It could just say it on the Stick if you have great reading eyesight, unlike me however). The new sticks should always be able to be read using a 2.0 reader, but who knows if this could be a rare exception. Any other sticks lying around? Just thinking out load.

Also, sometimes the USB ports on a laptop get dirty with dust and shooting some compressed dry air in there could clean it out to possibly work again. Again, just something to try maybe in the meantime.

Other than that when you enter your BIOS boot order screen do you see any other options like “Removable Flash Media” or even “SD cards” mentioned? My thought is if your computer does have an SD card slot and your BIOS can identify it for booting, we could try burning the .iso to that and boot Linux just like a USB stick. (My old Thinkpad does have an SSD card reader but my BIOS shows no option for it in the boot loader, so that would be a no go for me, but I have seen others do it successfully if its an option)

If all these suggestions don’t allow you to jump this hurdle then I guess the last “easy” option is try your drive adapter as an alternate medium for booting.

Taking the route of replacing USB reader hardware on the laptop motherboard or buying USB adapters for expansion slots would cost extra money and probably not guarantee success anyway.

Keep me posted and will gladly help you further if I am able.




USB ports are not the problem.
USB sticks are not the problem.
Already tried the SD card route. Flashed no problem, but no option in boot menu, hence the straw clutching re FDD.

Seems you and I are on the same page thinking outside the box.

I must have run over a chinaman…


Hey @Minty,
Thank you @mva for your input on this thread! I was hoping it would get resolved thus far, but it would appear that the Toshiba is a bit stubborn.

First, I would retry Rufus with Zorin. This time, I would recommend the recording to be done in DD mode rather than ISO. This tends to fix a lot of boot-up issues, as I’ve personally experienced.

Second, if you have Windows 7, your system should have the UEFI, which includes the Secure Boot. In some scenarios, one needs to set an Administrator/Supervisor password for the UEFI to full activate its options and allow you to disable Secure Boot (and delete the keys). Though I believe this to be somewhat secondary for the moment.

Since your USB worked on another system, then this means it’s a boot-loader issue.

Can you upload a few photos (just drag and drop them on the text window of your response) of your BIOS so that I can get a clear view of what it allows you to do and what it does not?

Thank you!


Will try “DD” mode


1 Like

Thank you for sending those, John!
Your system is indeed a 64-bit. And the changes you did in the end are good. The USB should be first in line for it to boot.
Please let me know how it goes.

in Rufus now… cannot find “DD” mode…


Do I need to download a different type of file? “DD” as opposed to “ISO”?

It will ask you when you begin the recording. If that doesn’t work, then you might want to activate the option for “old BIOS” to generate additional partitions that they may need in order to boot.


Okay, found it on the next window that opened up after I clicked [Start]…

Flashing now.

1 Like


I just finished reading the blog where I found the answer to why I did not initially se the “DD” option… WOW… people get really persnickety over this stuff???

Okay it’s done… going to reboot… see you on the other side…