Boot Manager Is Missing

@vasileios @mva

It took awhile but I’m back. I wont bore you with ALL the details of my trials and tribulations unless you are really curious.

Here is where I am so far:

My laptop is over 10 years old and has done yeoman service, all be it running windoze. With Linux on it, it may out live me. Came with three usb ports but I am now down to one that is reliable. Very dodgy connection on the other two. I run two 24" monitors (1 on VGA + 1 via USB. The HDMI port is dead) plus the laptop screen. I have a 7 port powered USB adapter plugged into the one reliable laptop port plus a 4 port powered USB adapter plugged into one of the 7 port outlets.

I just bought 5 new 32GB USB 3.2 sticks.
Rufus is unable to flash the ISO files onto the new drives. I get “Access Denied” and I have been unable to figure out a way around that.
Balena Etcher was able flash Mint and Zorin onto the new USBs w/no problem.
Rufus was able to flash Peppermint onto an old 2GB stick
Nothing will boot off USB via the 4 port adapter.
Mint on new stick and Peppermint on old stick boot just fine from both jury rigged dodgy laptop port and 7 port adapter.
Zorin on new stick started to install on old dodgy port and then “hung”. Have not tried 7 port yet.

Have fried an old 8GB USB stick… now unusable
Back when I was trouble shooting with Michael I was using an old 4GB USB stick that I now think as he queried may be unreliable. Will do some more testing to confirm.
Need a Linux driver to power USB connected monitor.

Bottom line… I will be able to put a Linux Distro on the old girl. Was really looking forward to a test drive with Zorin as I get the feeling Vasileios has a soft spot for that one.

Thanks a bunch guys for your time and input.

Hey John AKA @Minty!
One thing I have noticed with USB packs is that they don’t always get along with many systems. I suffered with them on my main desktop when trying to install Arch and Gentoo. When I used an older PNY one, it went through nicely. Sandisk ones are even better at it.
PNYs are decent, but are kind of slow in my experience. However, when I used them, I was able to install Linux (Manjaro and Ubuntu) about a year back on my MS Surface Laptop 3. I did that with a powered 4-USB 3.0 hub and it worked perfectly. The SL3 only has one USB-A port and one USB-C port, which is ridiculous (not to mention it overheats like there’s no tomorrow). And at that time, I needed to have a keyboard and a mouse connected - as the Kernel needed patching for those to work. So, I needed 3 ports (mouse, keyboard, and USB thumb drive).

What I would recommend is to grab a fast SanDisk USB and give it a shot. If you have another Linux system, download the ISO there and then right click on it and select “Open with Disk Image Writer”. It can manage 99% of all ISO recordings on a USB to say the least. I never had a boot issue with that.

The reason I’m recommending that is that the good USB thumb drives have better cache and fail-safe mechanisms in place to counter any USB port disruption issues. Those are rarely visible when you’re connecting a keyboard or a mouse, but become all too evident when you have a drive connected to problematic ports. Even a tiny data disruption will result in a hang, like the one you’re experiencing.

Please let me know how that goes. :slight_smile:

1 Like


Wow… so much to learn. Did not think the brand of USB stick would make such a difference.

Everyone keeps saying it, but we really mean it when we say we cannot thank you enough.