Bluetooth adapters not found

I’m running Linux Mint Cinnamon Uma. I set Linux up as a virtual machine using Oracle VM VirtualBox. The host OS is Windows 10. My computer is a HP All-in-One desktop bought new in 2020.

So far Bluetooth is not working on the Linux side and I keep getting a “Bluetooth adapters not found” error. It works fine on Windows 10. I’ve done a little searching around on my own in Linux Mint forums, but haven’t found a solution.

Any help is appreciated. Thanks!

Try installing either blueberry, or blueman in the terminal of the Linux Mint VirtualBox environment and see if either of those options will work for you. Though you should only try one at a time. If you install them both at the same time, it could cause conflicts and crash your system.

sudo apt install blueberry


See if it works. Then, if it doesn't, do:

sudo apt remove --purge blueberry


Then try the other one (blueman) in the same manner.

I tried both as you suggested. Blueberry gave me the “bluetooth adapters not found” message. Bluetooth Manager gave me the error “Connection to BlueZ failed. Bluez daemon is not running, blueman-manager cannot continue. This probably means that no bluetooth adapters were detected or bluetooth daemon was not started.”

Try this:

Open the terminal and just type:

bluez

Press Enter and see what happens.

bluez: command not found

Just curious, did you put “sudo” in front of it? You shouldn’t use “sudo” for this particular application. Sorry, should’ve mentioned that.

No, just bluez only.

okay then, well that rules out possibility of it being a needed startup process not being called. On the VirtualBox menu, there might be an option to enable bluetooth. Have you seen anything like that? I can’t remember the name of the menu, but I think I remember seeing something to that effect.

I hid the menu at the top of the screen. Do you know how I can get it back? LOL

If you’re in full screen mode, you should be able to just put your mouse at the top edge and it should show up. If not, you may have to power off the virtual machine and restart it.

Well, I tried. I checked the box in User Interface in VirtualBox to show the menu at the top, but that didn’t bring it up. I went through the VirtualBox menu outside of Linux and didn’t see a Bluetooth option anywhere.

Okay, the only other thing I can think of is to actually install Linux on your machine. That would be the only other way to test and see if it would work. But I’m assuming you’re using VirtualBox to test it out? Or are you wanting to permanently use VirtualBox?

I was going to test it out. I have an old Dell Inspiron laptop I may put it on.

Looks like doing Right Ctrl + Home gets the menu back.

If you’re not concerned about losing the data on that laptop, it wouldn’t be a bad idea in general. But the point is that you’re trying to test it out on your all-in-one.

If you want to ultimately put Linux on your all-in-one then we will need to get this figured out on that machine.

Got it. Thanks for the help!

No problem! Sorry I couldn’t do more for you!

That’s alright! I’m not ready to commit to putting it on my desktop computer yet, but I don’t mind trying it on the Inspiron!

Spoke with one of the other admins and they mentioned that there are some additional tools that need to be installed in order for VirtualBox to function properly. He provided several links of articles describing what it needs:

https://www.studytonight.com/post/how-to-install-virtualbox-guest-additions-on-linux

https://www.configserverfirewall.com/windows-10/virtualbox-guest-additions-windows-10/

https://duckduckgo.com/?q=virtualbox+tools+in+Mint&t=brave&ia=web

1 Like

Thanks for the information!

I’ve installed Guest Additions and was able to set up a shared folder between Windows and the virtual machine. I found this link helpful too in setting up a shared folder:

My Bluetooth situation seems unchanged, but I’m learning!

1 Like