Beginner driver disaster do I need to reformat and start over?

I’m an absolute beginner who does not know how to use the terminal. While trying to update my wifi driver by watching a youtube video, I must have deleted something important because now my Ubuntu will not let me install the driver for my wifi. I can not connect to the internet even with a cord. The computer says I have a strong signal but it just won’t connect. When I go to Software and update it shows the driver but when I choose it nothing happens for a long time, then it times out. I’m really stuck. Can anyone help? Is there a way to get it from another computer or do I need to start from scratch?

1 Like

Hello @Suzanne !
What is the model of the computer you are running Ubuntu on? Normally, if you plug in an ethernet cord that goes directly to your router, or switch, you should be able to connect. If not, then it could be a DNS issue - which means it cannot “translate” the IP addresses to the actual Internet name of the server it tries to reach.

Also, if you connect via the cable, can you go to the Network Properties for the Wired Connection and post a picture of each tab?

Thank you!

I have a 2011 Macbookpro with only Ubuntu. It recognizes the internet connection both with and without the cord until I start Ubuntu. It won’t boot to the flash drive only the hard drive.
It does not see the WiFi in Ubuntu.
It has the correct driver listed but when I choose it it just times out.

Thank you for responding. I have been working on this for two days and I’m so bewildered. Best Suzanne

This was my hardware info taken before I goofed up the computer.

Thank you for the info! I did a thorough search and found out that your system needs the firmware for your adapter (which happens to be from the same - infamous company). I’m attaching a ZIP file that I picked up. Please download it and copy it to your troublesome computer. :wink:

Decompress it and enter the folder via terminal. Once inside, type:

sudo ./

Once done, reboot and hopefully, everything will be up and running!

Here’s the file: (30.4 KB)

Please note that the firmware is for your WiFi, which I believe is the more important to you, correct?

If the above command doesn’t work, then re-write it as:

sudo bash ./

I am so grateful for your time and expertise. I will copy the file to a usb and then to a folder on my computer. I’m ashamed to say I don’t yet know how to enter the folder from the terminal. Is there a command to enter to get there?

By default, your browser will put those files in your “Downloads” folder. To get there, open your files and it will be right there in that folder, or press the Super button (Command key) and start typing “downloads.” The downloaded file should be there.

To decompress it, right click the file and select, “Extract here.”

1 Like

Thank you for the file. I downloaded it to a usb and extracted it to downloads but I’m not sure how to navigate it to the terminal. Please forgive my stupid question but I have not learned my way around Linux yet.

Hey, @Suzanne !
Open up the firmware folder, then right click in the empty space and select Open In Terminal.

It will open a window and you can execute the code right in there. Just to be on the safe side, type in the following

sudo bash ./

This should work. :blush:

1 Like

This is confusing.

Hello @Suzanne !
It would appear it is looking for an internet connection that is apparently not there - for the time being. First, please delete the file you received earlier and its folder that came out during its decompression. Then please download the file again here (I renamed the DEB packages - as their symbols could cause issues) and decompress it. (30.3 KB)

Then enter the newly created folder until you see the three available files. Right click on empty space and select Open in Terminal. Then, instead of executing the .sh file, type in the following:

sudo dpkg -i ./firmware-b43-installer_all.deb

Please let me know what messages you receive from it.

Thank you!

1 Like

I tried with a cable but no luck. It says connected but it’s not working. Thank you for not giving up. I don’t want to fail.

Is there a way to reinstall Ubuntu to the original install? I don’t mind losing data. The WiFi was working until I tried to update the driver. When I reboot holding alt I don’t get a usb option.

You can use an external hard drive or a different USB thumb drive so that you can back up your data.

Once you do, then yes, you can reinstall Ubuntu. Once done, I highly recommend installing and running TimeShift, a backup tool (like Mac’s Time Machine). You can find it in the software manager of Ubuntu or run the terminal command:

sudo apt install timeshift

It will at least give you peace of mind.

From your experience, it appears the update overwrites the firmware of your WiFi. This is what causes your troubles. I encountered the same with my Surface Laptop 3. However, I kept a copy of it and forced Ubuntu to use my backup instead of the update. If I weren’t exhausted, I would tell you how, this instant. But I’m with 2.5 hours of sleep working on support and materials for everyone. :blush:

Tomorrow I can be of more help. :blush:

Thank you. I hope you sleep well. Tomorrow if you have time perhaps you could walk me through how to reinstall.

Blessings Suzanne

1 Like

Thank you so much, Suzanne!

As promised, I’m here to help.

The issue you’ve encountered is in the firmware file called “board.bin”. It comes in a variety of versions, depending on the hardware version. Once you install Ubuntu, do not update. Open up the terminal and install ONLY the following utility.

sudo apt install mlocate

This is a quick file scanner that indexes all files on your system at incredible speeds.
Once installed, run the following commands:

sudo updatedb
locate board.bin

This will spot all the firmware files for both your Ethernet (cable) and your WiFi controller.

For example, I did it on Mint (same command - same process):

When you do a system update, these files are replaced - which is the core of your problem. However, there is a way to create override files that will ignore the update.

As a next step, please execute the above and take a photo of it. That way, I’ll know exactly the directory structure and I can help you take it from there.

Most likely, I shall write a script for you, which you can use every time you have an update issue. You will be able to run it and revert the firmware back to its original state. :blush:

When I boot up hitting the alt key I do not get the option to reinstall in Umbuntu. It looks like we might have to reinstall the Mac OS first if they will allow me to do so on my computer. I bought it on eBay so I don’t have software rights. Should I try the commands you just gave me in Ubuntu?

Does it give you that while you have your Ubuntu installation USB thumb drive attached?