Battery level display problem and virtually freezing problem

I have successfully installed linux mint onto a Satellite c870-155 and it appears to work fine apart from 2 big problems.

  1. The battery shows no level, nor gives any indication as to when it runs out. It only lasted 40 mins, so bought new battery and the new one is the same. It does show charging or not charging and that is all.
  2. After 10/15 minutes use say with telegram and brave, the computer almost grinds to a halt and it takes about 5 minutes to even go through shut down process.
    Would love some help thanks

Does the battery icon display a decreasingly full battery in the system tray when unplugged? I just fired up my Linux Mint Cinnamon VM and it too did not show, a percentage or time, I right clicked and selected configure, under “Hide Label” drop down it gave the option to show time remaining, percentage and both. Immediately my percentage came up but not time since its a VM and plugged in.

As for the sluggishness perhaps first thing to do is make sure all your packages are up to date. Not sure what avenue of how you installed Telegram or Brave, can you enlighten us there and what their versions are? Brave Official current version as of writing this is Version 1.36.116 Chromium: 99.0.4844.74 (Official Build) (64-bit) and Telegram Official current version is 3.6.1.

1 Like

Thanks Mr D
I hadnt seen the configure button but it has made no difference, even after switchign computer on and off , just 0% at all times, and with charging flash when power cord is in.
Brave, i downloaded with Vas code, and it says
Version 1.36.116 Chromium: 99.0.4844.74 (Official Build) (64-bit)

Yet to find where it says the telegram version, but wanted to get this written before it freezes again, it is not sudden freeze but gradual. Downloaded it via software app, only one with blue telegram icon iirc
will keep searching for version

1 Like

ok found it - v 3.6.1 16.03.22
I never know where to reply when i do two replies, do i reply on my reply or yours? do you still see either way.


I think something runs all the time in the background, from the sound it makes.
I left computer for half hour and it takes 6 or 7 minutes for screensaver to go off and put my password in and then have to shut everythign down. , I dont know whether this tells you anything i just took

@foxy, @MrDeplorableUSA will be notified as soon as you post in any topic he has replied on. If you are worried about notifications, simply type the @ symbol before his username.

1 Like

I usually reply to the last message concerning the conversation. I see nothing off in the processes, obviously since you started system monitor it would be at the top followed by the environment your running and then telegram. Personally, if you do not need a password where your at I never use them for wake-up or login, on my laptop at home I just let my user login automatically, security issue yes but not where I live.

You made need TLP, you launch it in terminal, run system as normal and it analyzes the power usage TLPUI give you a graphical interface. Being a 2GHz and 4mb ram(unless you have a corrupted memory stick I would think is more then sufficient. Or you check with other Cinnamon users or Mints’ community forums to see if anyone else is working the same problem.

Lets see what these output(individually and you may possibly need to post output to file or a pastebin if it scrolls to far):

inxi -Fxz

df -Th

systemd-analyze blame

Also, have you attempted another desktop environment, I seen one post reply on Mint forums stating a “like” system to yours maybe a little lite on resources for “Cinnamon” and to maybe try Mate.


@MrDeplorableUSA sorry for delay.
I had sent off for more ram, which i fitted, i switched on then it needed a linux kernel update, after which computer froze when switching off just on mint logo, so i am not 100% its taken.
I did those things in command that you said and these are screenshots whilst i was waiting for linux kernel update.
Computer seems faster presumably due to added ram, but have not been on long enough to see if it freezes.
I realise screenshots will now be out of date so will do them again, but thought best to include old ones.

@MrDeplorableUSA These are the new screenshots .
As for the passsword, no i dont need in for local circumstances, i want to get rid mailnly but dont know how yet. It insisted on one when installing it seemed to me.

@MrDeplorableUSA As for " post output to file or a pastebin if it scrolls to far" i am not sure how to , but if screenshot too small i will try something

1 Like

Just getting a chance to look it over, my phone with the “app” wasn misbehaving today and couldnt hardly read anything.

As for outputting them pastebin is a simple process. typically (command) | pastebinit.
Pastebin is pretty common program from repos. if it doesn’t work you can always use (command) > filename.txt With either option leave the parentheses off.

I’ll look through the images as best I can.

SDA5 root file system seems pretty full, possibly software cache or old kernel updates needing removed, might try sudo df -Th instead.
systemd_analyze has got some huge number at the top from almost 30 secs down… ms is cool but numerous high time apps maybe causing issues as well, possibly a memory leak or something. Cinnamon is pretty high resource demand DE, may want to look into either Gnome or Mate for 2GHz and 4MB ram system. For KDE/Cinnamon I would suggest at least 8MB of ram, 2GHz is probably fair.

Possibly and an app called ZRAM might help, worth a shot, you can always uninstall it if it makes no difference.

I would definitely look in to whats filling SDA5 up.

~$ sudo df -Th
[sudo] password for jt:
Filesystem Type Size Used Avail Use% Mounted on
udev devtmpfs 3.8G 0 3.8G 0% /dev
tmpfs tmpfs 785M 1.4M 784M 1% /run
/dev/sda5 ext4 586G 134G 422G 25% /
tmpfs tmpfs 3.9G 87M 3.8G 3% /dev/shm
tmpfs tmpfs 5.0M 8.0K 5.0M 1% /run/lock
tmpfs tmpfs 3.9G 0 3.9G 0% /sys/fs/cgroup
/dev/sda1 vfat 511M 4.0K 511M 1% /boot/efi
tmpfs tmpfs 785M 16K 785M 1% /run/user/1000
jt@gate:~$ pastebinit
nothing happened on pastebinit, i dont understand what is meant to?
last night before i read your reply i got a message saying filesystem.root has only 700mb left and to delete trash would help. Unfortunately i tried to screenshot but it refused to do it and then the message disappeared

@MrDeplorableUSA 17.449s systemd-journal-flush.service
14.743s networkd-dispatcher.service
10.252s udisks2.service
9.547s accounts-daemon.service
9.349s dev-sda5.device
9.112s ModemManager.service
7.967s ubuntu-system-adjustments.service
6.089s polkit.service
5.597s NetworkManager.service
5.585s avahi-daemon.service
5.331s thermald.service
5.327s systemd-logind.service
5.322s wpa_supplicant.service
3.497s gpu-manager.service
3.300s apparmor.service
3.104s ufw.service
3.000s systemd-udevd.service
1.974s colord.service
1.967s grub-common.service
1.918s rsyslog.service
1.674s lightdm.service
1.668s plymouth-quit-wait.service
1.497s systemd-resolved.service
1.450s systemd-modules-load.service
1.370s hddtemp.service
1.295s lm-sensors.service
1.288s alsa-restore.service
1.073s systemd-tmpfiles-setup.service
993ms grub-initrd-fallback.service
983ms e2scrub_reap.service
933ms systemd-tmpfiles-setup-dev.service
933ms systemd-fsck@dev-disk-by\x2duuid-3D04\x2dA65A.service
898ms dns-clean.service
860ms setvtrgb.service
838ms pppd-dns.service
774ms systemd-random-seed.service
772ms networking.service
752ms systemd-sysctl.service
660ms systemd-sysusers.service
645ms keyboard-setup.service
538ms systemd-backlight@backlight:intel_backlight.service
484ms kerneloops.service
452ms ifupdown-pre.service
419ms systemd-journald.service
378ms upower.service
377ms swapfile.swap
484ms kerneloops.service
452ms ifupdown-pre.service
419ms systemd-journald.service
378ms upower.service
377ms swapfile.swap
358ms systemd-udev-trigger.service
238ms systemd-timesyncd.service
226ms systemd-remount-fs.service
208ms dev-hugepages.mount
207ms dev-mqueue.mount
207ms sys-kernel-debug.mount
206ms sys-kernel-tracing.mount
203ms blk-availability.service
194ms boot-efi.mount
193ms systemd-rfkill.service
174ms user@1000.service
165ms kmod-static-nodes.service
165ms lvm2-monitor.service
143ms console-setup.service
122ms plymouth-read-write.service
89ms systemd-update-utmp.service
43ms rtkit-daemon.service
36ms user-runtime-dir@1000.service
19ms systemd-user-sessions.service
18ms plymouth-start.service
15ms systemd-update-utmp-runlevel.service
9ms sys-fs-fuse-connections.mount
9ms finalrd.service
7ms openvpn.service
4ms sys-kernel-config.mount

@MrDeplorableUSA on the above i dont know whether i got it all in two copypaste, but the command thing jsut seeemd to freeze, so had to close it. On reopen did this , but nothing…
jt@gate:~$ command > filename.txt
Cant seem to do the command pastebinit, as i cant work the verrtical line. On my computer it is on a key with two other symbols and i cant work out the combination to get it.

@MrDeplorableUSA sorry for so many messages, i just dont want it to freeze on me and i forget.
Ok i worked out the vertical line it is alt gr and the key, so i do systemd-analyze blame which seems to need me to press retrun for each of last 20 lines, but then i cannot write (command) | pastebinit as it wont let me, it wont let me do anything in terms of writing commands at the end of the output of systemd-analyze blame. this is so frustrating

I have downloaded xram or the only app that came up ending in xram and it has no launch button, what happens with that ? I am taking a break for few hours, head is fried

1 Like

Looks like you cleaned up a lot of space on / or sda5 so that should help.

Still see a lot of “high time” apps under analyze.

command literally means the command you’re using such as inxi -Fxz > inxi.txt would output inxi -Fxz straight to a text file in your current directory named inxi.txt. Useage of pastebinit if installed would be inxi -Fxz | pastebinit and it should return you a url in the terminal to share with the full out put on a webpage.

Once Zram is installed it runs in the background and starts as a system service, iirc. IF I said xram I am sorry I did not scroll back to check.

I am really leaning toward Cinnamon being to memory intensive for your system. If you have a descent enough connection, I would suggest to install a different desktop environment such as Mate or XFCE, no need to remove Cinnamons desktop, it would simply be to see if your system still becomes sluggish in your description.

Install Mate desktop alongside Cinnamon

Don’t worry about so many messages thats what it’s here for and we can always look back through it. Sorry I cannot reply as often during my work day.

@MrDeplorableUSA I took a couple of days off, disillusioned and then now i cant get in on that computer. Computer will not let me even type the password in for some reason, nothing happens when i type. so i cant get in that computer. Any ideas?
No my mistake on xram, i meant zram
As for too much memory cinnamon, i added another 4 ram, so 8 should be ok?
How do i get rid of password if ever i get in?


Ok it gets worse. I went back to an even older computer that i had first tried and installed mint xfce or whatever it is called, which also had a login password to start. I thought first thing is to get rid of that, So i went to settings, then unchecked or checked a box that said automatic login. Now i jsut get what is on the photo, . It just says log in and when i click or press return it jsut comes back to same screen. So now i cant get in either computer.