ASUS Vivobook 15 M3500Q Hangs After Boot

I’ve loaded Linux Mint Cinnamon on two older computers and it worked fine. Both of them are reaching end of life and I wanted to upgrade to a newer computer. So I purchased this ASUS with the latest graphics cards (2). The Nvidia card gets its correct driver, but the AMD card shows no driver installed. If I upgrade the kernel to 5.11, the graphics cards are correctly installed but almost immediately, the laptop hangs and freezes. I used the command “inxi -Fxxxrz” to get a look at the drivers but it freezes before I can make a copy. Rebooting and holding down the shift key does not get me to the grub menu so I can’t revert to the earlier kernel which was 5.4. I’ve thought about switching distros to something more bleeding edge like MX-Linux but that didn’t help at all. I also noticed a very brief warning the nouveau chipset was not recognized at boot up. Any thoughts or solutions that I might consider would be helpful. Thanks,

Here is the output of my system while running Kernel 5.4. I’ve been unable to capture the output while using a newer kernel but I did notice that both graphics drivers were installed (Nvidia 470 and AMDcpu) before the system freeze.

talon65@MikesASUS:~$ inxi -Fxxxrz
Kernel: 5.4.0-91-generic x86_64 bits: 64 compiler: gcc v: 9.3.0
Desktop: Cinnamon 5.0.7 wm: muffin 5.0.2 dm: LightDM 1.30.0
Distro: Linux Mint 20.2 Uma base: Ubuntu 20.04 focal
Type: Laptop System: ASUSTeK product: Vivobook_ASUSLaptop M3500QC_M3500QC
v: 1.0 serial:
Mobo: ASUSTeK model: M3500QC v: 1.0 serial:
UEFI: American Megatrends LLC. v: M3500QC.301 date: 08/16/2021
ID-1: BAT0 charge: 51.8 Wh condition: 64.1/63.0 Wh (102%) volts: 12.0/12.0
model: ASUSTeK ASUS Battery type: Li-ion serial:
status: Discharging cycles: 2
Topology: 8-Core model: AMD Ryzen 7 5800H with Radeon Graphics bits: 64
type: MT MCP arch: Zen 3 L2 cache: 4096 KiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
bogomips: 102208
Speed: 1197 MHz min/max: 1200/3200 MHz boost: enabled Core speeds (MHz):
1: 1197 2: 1198 3: 1198 4: 1195 5: 1197 6: 1196 7: 1396 8: 1397 9: 1197
10: 1197 11: 1197 12: 1197 13: 1197 14: 1197 15: 1198 16: 1198
Device-1: NVIDIA vendor: ASUSTeK driver: N/A bus ID: 01:00.0
chip ID: 10de:25a2
Device-2: AMD vendor: ASUSTeK driver: N/A bus ID: 04:00.0
chip ID: 1002:1638
Display: x11 server: X.Org 1.20.13 driver: ati,fbdev
unloaded: modesetting,radeon,vesa resolution: 1920x1080~77Hz
OpenGL: renderer: llvmpipe (LLVM 12.0.0 256 bits) v: 4.5 Mesa 21.0.3
compat-v: 3.1 direct render: Yes
Device-1: AMD driver: snd_hda_intel v: kernel bus ID: 04:00.1
chip ID: 1002:1637
Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor
vendor: ASUSTeK driver: N/A bus ID: 04:00.5 chip ID: 1022:15e2
Device-3: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel
v: kernel bus ID: 04:00.6 chip ID: 1022:15e3
Sound Server: ALSA v: k5.4.0-91-generic
Device-1: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel port: e000
bus ID: 02:00.0 chip ID: 8086:24fd
IF: wlp2s0 state: up mac:
Local Storage: total: 476.94 GiB used: 9.44 GiB (2.0%)
ID-1: /dev/nvme0n1 vendor: SK Hynix model: HFM512GD3JX013N
size: 476.94 GiB speed: 31.6 Gb/s lanes: 4 serial: rev: 41000C20
scheme: GPT
ID-1: / size: 244.40 GiB used: 9.43 GiB (3.9%) fs: ext4
dev: /dev/nvme0n1p2
System Temperatures: cpu: 52.0 C mobo: N/A
Fan Speeds (RPM): cpu: 2800
No active apt repos in: /etc/apt/sources.list
Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list
1: deb uma main upstream import backport #id:linuxmint_main
2: deb Index of /ubuntu focal main restricted universe multiverse
3: deb Index of /ubuntu focal-updates main restricted universe multiverse
4: deb Index of /ubuntu focal-backports main restricted universe multiverse
5: deb Index of /ubuntu focal-security main restricted universe multiverse
6: deb Index of /ubuntu focal partner
Processes: 320 Uptime: 1m Memory: 15.11 GiB used: 1.37 GiB (9.0%)
Init: systemd v: 245 runlevel: 5 Compilers: gcc: 9.3.0 alt: 9 Shell: bash
v: 5.0.17 running in: gnome-terminal inxi: 3.0.38

Hope this fills out more of the problem.

Hey @Mike19 and welcome to the forums!
Nvidia and AMD combo can be quite the recipe for Mint!
The AMD will only be needed for low battery consumption situation, so - if you are more stationary, it should be a secondary option. The switching can be a bit troublesome between the graphics chips.

I would recommend you give Zorin ( a shot and run it with the Modern Proprietary drivers at bootup. Then install it and see how that goes.

By the way, if you want the high-speed proprietary drivers for your Nvidia chip, you do not want Nouveaou to be installed. :wink:

Thanks for the reply and suggestions. I’ll try Zorin out and let you know how it goes.

1 Like

Thanks for the suggestion on using Zorin. I was unable to get it to boot up because it couldn’t connect to my wifi. Probably because I had a very slow internet connection for a few days. I did get Ubuntu 20.04 booted up with a 2.11 kernel and it was able to get both the Nvidia and AMD graphics cards installed and working great. I’ve got a blazing fast laptop with beautiful graphics and am loving Ubuntu. I didn’t like it at first, but since it solved my graphics card problem I’m slowly learning to get the full benefits. One last question before we close out the topic. I now have a dual booting laptop with Linux Mint and Ubuntu. How do I get the boot order rearranged so that it will automatically boot into Ubuntu instead of Mint? Thanks again for all your help.

1 Like

I’m so glad to hear it, @Mike19!
In order to change the boot order, we’ll need to instruct Grub to do so via its configuration file. There are two ways of doing that, but I’ll give you the easy one, just in case there are Kernel updates and Grub decides to shift - again - as to which distro loads first!

There is a handy app that lately has become part of the official repositories. It’s called Grub Customizer. You can install it via:

sudo apt install grub-customizer

Once installed, open it up and you’ll get all the options per the distros installed.
On the first tab, which is the List Configuration, drag and drop your Ubuntu option to the top. Then, go to the second tab, the General Settings and up on the top, under the default entry, select the previously booted entry.

This way, it will always default to the OS you previously booted which, in your case, will be Ubuntu. :slight_smile:

Thanks Vasileios, I knew that there had to be a way to do it, just couldn’t find anything on line
Here’s a new one that I just noticed My computer has decided not to allow periods in my text Is that weird or what? Commas and questions marks work fine but no periods

You’re very welcome, @Mike19!
No dots? I do find that interesting. Try to reset the keyboard underlying service by opening up a terminal and typing:

sudo ibus-daemon &

Then restart your browser and see if it persists.

Thanks Vasileios, that worked … Unfortunately, the rearranging of my boot order did not. I got the program downloaded, installed and working, so maybe I just don’t understand what I was supposed to do with it to make the switch.
I tried making a screen shot of the customizer home page, but can’t figure out how to insert it into this post. It looks like it has the boot order listed correctly and I did hit save before exiting, but the reboot still tries to start up in Mint. Thanks for getting my periods back…

1 Like

Hey @Mike19!
One victory at a time! By the way, you can simply drag and drop the screenshot on the response window. :slight_smile:

Thanks again. You really are on top of all of this stuff. We could be pen pals for a long time, I have lots of little inconsequential questions. I guess it’s time to sign up for the learning modules on I may know just enough to keep up at this point. One of my weak spots right now is figuring out how to find and download apps. The package management system and github are eluding me. There was a little icon, looked like an orange briefcase, that did nothing when I clicked on it. It was supposed to take me to someplace that I could download apps, I think. Anyhow, you’ll probably see me in your class soon. Thanks again.

1 Like

You’re most welcome @Mike19!
Well, I started with computers back in 1984, so I better know something! :laughing:
Yes, the Software Manager looks like a little shopping bag. You can also look it up on your apps/menu as Software. At times it may not open as it can get busy updating the databases.

I will be preparing two courses for the LMS (Learning Management System). One will be about drivers, that will include GitHub and the other will be about encrypted containers. So, fear not. :wink:

OK great!!! I’ll signup. My son and I started in computing in 1979, with a gigantic server and a phone in a bag to hook up remotely. We graduated to a Tandy Radio Shack CoCo with a tape cassette and learned enough DOS to program a game called “Pong.” He made a career out of tech and I’ve forgotten all I learned back then.

1 Like

I was 4 years old back then, so you’re beating me there! :laughing:
However, computers can be like a bike. Once you get back on it, you get the hang of it much faster. I’ve helped people here in these forums who were on the same boat as you, and now they’re going through things like it’s nothing. :wink:

That may be true, but at 78 years my brain is working quite a bit slower. I signed up at the LMS site but when I tried logging in, it wanted a password. I don’t remember picking one, so I’m waiting on them to send me a password reset code.

Hey @Mike19!
Welcome to the LMS! Did you get a second email? There are two that are sent out and the 2nd one may end up in your spam folder. If you still have an issue, then please DM me your full name and the email address you registered with and I’ll manually make the account for you. :slight_smile:

And never underestimate yourself. You are doing great!

Sorry, but I’m not familiar with how to DM. I did get the email and password but I still couldn’t log in. Says wrong username or password. I registered under as Mike Lesley. I made the assumption that the LMS site would be under a different user name and password than the forums site. Maybe that was my first mistake.

1 Like

OK, I’m good. Mis-typed the password. Sorry for the confusion, I transcribed it into bitwarden and got it wrong. Thanks again for your help, see you in class.

1 Like

Hey @Mike19!
I’m glad you got this sorted out! Awesome!
I’ll see you also in our live workshop, if you can make it, this Saturday, at 17:00 EST. :slight_smile: You should be getting the invite this Friday or - worst case scenario - Saturday morning. Please let me know if the invite email does not reach you. :slight_smile:

As for the DMs (Direct Messages), you just click on my name and hit “Message”.

Thanks Vasileios, Saturdays are not good for me, so I’ll catch up when I can. I liked your welcome video, good job. I’m about half way through Jeff’s opening video and have really enjoyed the You Tube videos in the first two lessons. They answered a lot of my questions on file structure. I’ll probably have to go back and review them a few times before they stick in my brain. :grinning_face_with_smiling_eyes:
OK, I got the DM procedure, how do I do emojies?
If nothing else, this exercise will go a long way toward staving off dementia by keeping my brain exercised.


1 Like

Oh, I see now that once you hit reply, the emojie gets inserted. Cool.

1 Like