After Manjaro install I can't run windows os with dual boot setup

I recently installed Manjaro in place of Mint Cinnamon, because I couldn’t get my speakers to work with Mint. That problems has been resolved with Manjaro. However, I have a much bigger problem now. I partitioned my drive to have windows os alongside Manjaro. However, I after spending much time, I have not been able to enter the windows os since I installed Manjaro. Windows is not an option in the grub menu. And even when I go into BIOS to menu to select windows it just runs Manjaro.

Another issue is although the resolution is correctly set to my laptop, the environment is extremely small and I don’t know how to enlarge.

Could really use some help as I am a Linux beginner. thank you.

Hey @analyst1776,

If you were already dual-booting, then chances are that Manjaro formatted the boot partition where your Windows EFI file was located. Before we go to that mode, let’s verify.

On the last screenshot you sent, choose boot from EFI file. Enter any partition it shows you and look if you find a folder named Microsoft. You can use the arrow keys and the enter to navigate. If you find the folder, then all is good and the file is not deleted. You can select the .efi file and Windows will boot.

The fact that you still see the Windows Boot Manager on your boot menu is a good sign.

So, if you do find the Windows .efi and it allows you to boot, then you’ll need to reboot into Manjaro and see if it can recognize the boot loader. Once you enter, open up Konsole from your menu and execute the following commands, one at a time (press Enter at the end of each line):

sudo pacman -S os-prober
sudo grub-mkconfig -o /boot/grub/grub.cfg

At the end of the second command’s output, it will tell you if it located the Windows Boot Loader.

Please let me know how it goes.

Per your screen, which Manjaro did you download? Gnome, KDE or XFCE? Each one has a slightly different way of global enlargement under the Display part of its Settings.

Thank you so much for your help @vasileios !

I am unable to find a folder named Microsoft. Please let me know what you think I should try next.

Regarding display, I was able went with KDE environment. Everything is much better after adjusting some settings. The only thing is icons in the Task Manager bar and system tray on the bottom of the screen remains extremely small.

1 Like

Per the KDE panel and tray icons, the solution is simple, but your right clicks (especially for the tray) have to be somewhat precise. Look at the screenshot of my Debian KDE below for guides.

On your Windows EFI missing, there appears to be a solution that can be performed via rEFInd. For this purpose, I would recommend you download and flash a USB with Arch Linux (same commands as Manjaro), which is much easier to boot into terminal and start the repair procedures. Once you boot from it, I believe a good guide to restoring your Windows’ EFI loader is the one below (restore it via Linux):

Please let me know how it goes!

KDE panel and tray icons solved thanks @vasileios

However still having trouble with Windows boot.

I was able to install rEFInd, but only Manjaro is available from the boot menu.

In trying to follow the steps for “Restore Windows UEFI boot,” I am lost.

First ‘output of `bcfg boot dump -v’ returns “command not found” in terminal.

"Boot into Linux and mount your windows partition, then copy the existing file into where rEFInd was expecting to find it." - I can’t figure out how to mount my windows partition.

Again, I really appreciate the help.

Hey @analyst1776!
The guy in the article mentioned that he had to obtain a specific shell via the Arch Wiki. I looked it up and it’s indeed the edk2-shell. While booted into your live Arch USB, you can install it via:

pacman -S edk2-shell

I trust that should give you the command you need (the bcfg boot).

In order to mount your Windows partition, we’ll need to know how your partitions are structured and named (based on the device name, if it’s a HD, SSD or NVMe). The following command will list them:

fdisk -l

Once it prints them out on the screen, can you send me a photo so that I can see which one is your Windows boot area?

Thank you!

Thank you for posting it, @analyst1776!
There are 3 areas where the file you’re seeking may be residing.

I would mount all three. So, first, let’s make a folder for each.

mkdir /mnt/windows1
mkdir /mnt/windows2
mkdir /mnt/windows3

On a first suspicion, Arch can’t read NTFS out of the box. So, you might need to install the NTFS file system module. You can do that by typing:

pacman -S ntfs-3g

This will allow you to mount them. Now, let’s do so:

mount /dev/nvme0n1p1 /mnt/windows1
mount /dev/nvme0n1p3 /mnt/windows2
mount /dev/nvme0n1p4 /mnt/windows3

The /mnt/windows1 is your main EFI boot section, where Linux boots from, so it might be unlikely you’ll find the EFI - but it’s worthwhile to look.
The /mnt/windows2 is the central Windows installation area.
The /mnt/windows3 is the recovery area, so it could be likely that the file is there.

At this point, it could be chaotic to try and find any .efi files there. So, let’s make life a bit easier by building a file database. First, we’ll need to install the indexer utility:

pacman -S mlocate

Once it installs, instruct it to scan the mounted drives by executing:


Then you can search for any file. To look for any file that has the extension efi.

locate *.efi

Hopefully, one file on its list will be the Windows one.

Thanks for the help @vasileios, here are my results:

I tried this process in Manjaro so I can share screen shots, if you think it is necessary I can try in Arch live boot.

Hey @analyst1776!
I was thinking that you were to perform the commands under the Arch boot USB, which always places you as root (I posted the commands for it). The updatedb requires elevated privileges to build, that’s why it’s not finding anything. It hasn’t been able to build the database.

I’d recommend giving the above commands a shot directly from the Arch.

Thank you for your patience and continued guidance @vasileios . As you can see I installed the shell, but I am still unable to perform the bcfg command

I do not find the windows .efi using locate command

Hey @analyst1776!
Repairing Windows material is always quite the mountain to climb. So, let’s try to make things a bit easier. Do you have a Windows installation USB? If not, do not fret. We can build a bootable USB via Ventoy and use the Windows 10 (or 11, depending on what you have installed) and force it to do the EFI repair for us.

First, boot into your Manjaro and download the Linux version of Ventoy here:

Pick up the tar.gz version, as shown below:

Once you download it, find it in your Downloads folder, right-click on it and select Extract here. It will create a folder. Don’t go into it just yet. We’ll first need to download a Windows 10 ISO.

You can download it here:

Once you download it, find yourself an empty USB flash drive (8GB or more will do the trick).

Now, instead of doing the command-line version, we will execute a specific script via the terminal so that it gives you a graphic user interface for easier access. Fist, plugin your USB. Then navigate to your Downloads folder and enter the directory of Ventoy. Right click in empty space and select Open in terminal. Then execute:


It will ask you for your password and will open a window like this:

It will detect your USB flash drive. Select it and hit Install. The process will take a few moments, as it’s not a big file. Once it’s done, you will have a new drive named Ventoy on the left panel of your file manager. Open it and copy the Windows 10 ISO into it.

Once the copy is done, you can safely reboot and boot from your new USB. It will produce you a list of the ISOs available inside. Select the Windows 10 ISO file and wait until it boots into the installation screen. Follow the steps I’m highlighting in the screen captures below:

Once you enter the Command Prompt - execute the following line:

bcdedit /set {bootmgr} path \efi\microsoft\boot\bootmgfw.efi

The process should be very quick and successful. This means that you now have a Windows EFI in your system.

Now, reboot back into your Manjaro and open up a terminal to have Grub and OS-Prober scan your system and add the Windows boot option:

sudo grub-mkconfig -o /boot/grub/grub.cfg

Once you reboot, Windows should be there.

@vasileios Almost there!!!

for some reason I am unable to perform this command:

bcdedit /set {bootmgr} path \efi\microsoft\boot\bootmgfw.efi

Hey @analyst1776!
My apologies for the delay. The research, tests and experimentations on a demanding LMS took away my time for a bit.

I see your problem. You are using the forward slashes for directory change (which are the /). On Windows, you need to use the backslash (the ) as I included in the code above. :wink: