After Manjaro install I can't run windows os with dual boot setup

@vasileios Sorry for the oversight. Thanks for the help. I think I entered it correctly and still receive the same prompt.

No worries, @analyst1776!
That’s quite interesting. Perhaps do a cd \ and then a dir to see which folders are available. Perhaps there’s another EFI inside the actual efi folder. Or at least cd and dir around until you find one so that the utility can place it. That’s all you basically need. After that, Linux will detect and include it in the boot-loader via the:

sudo grub-mkconfig -o /boot/grub/grub.cfg


I found efi folder in “windows/boot” but I am unable to set path there

Do a cd \Windows\EFI and check to see what that folder holds. Though the EFI itself should be around the root area.

Also, when you are to install the boot manager in a different folder, you will need to alter the path in the installation command - which should look like this:

bcdedit /set {bootmgr} path \path\to\your_efi_boot\bootmgfw.efi

Where you will need to replace the “\path\to\your_efi_boot” with the corresponding directory.

Still, I believe it should be on a root folder. Perhaps it’s in another drive letter. In the Windows command prompt, try this:

wmic logicaldisk get name

And check the folders there. You can change the drive you’re on by typing the letter name, followed by the : symbol.

@vasileios, have a look what i found:

here is the result of sudo grub-mkconfig -o /boot/grub/grub.cfg:

also found efi folder in E:

1 Like

Excellent find, @analyst1776!

As I highlight in the above image, that’s where the bootmgfw.efi should be. If it’s there, you’ll need to copy the entire folder out and into your Manjaro’s boot area under the /boot/efi folder. Then you can run the grub-mkconfig command. That way, it will spot your Windows installation.

checkin now, how would I go about copying and into Manjaro’s boot area?

don’t see bootmgfw.efi there:

Hi @vasileios, hope you are well. I know I’ve taken a lot of your time with this conundrum, but I’m still stuck without access to my windows system. I haven’t been able to install the boot manager into the ‘microsoft’ folder. I appreciate your willingness to help in this matter, you are very generous with your time.

Hey @analyst1776!
My apologies for the delay. The NextCloud LMS has taken the full of my time. Personal and private files are of utter importance for you guys, so I had to nail it down to perfection so that you don’t risk getting hacked when you deploy your server. I’m happy to declare that this time investment was a success (with an A+ security ranking).

On your Windows part, the EFI file doesn’t need to be found there when you list its directory. What you’ll need to do is copy it there from the folder you found it. :slight_smile:

No worries @vasileios , thank you for bearing with me as I go through this. I look forward to getting back to the LMS when I find some spare time. So my understanding is that you are suggesting I copy the bootmgfw.efi file into the microsoft dir? I tried to copy bootmgr.efi file there but was prompted with an ‘access denied’. I subsequently realized this was not bootmgfw.efi.

nevertheles you mention copy bootmgfw.efi to windows directory from the folder I found it. Unless I am missing something, I’m not aware of finding it yet, haha.

I also tried the bcdedit command: bcdedit /set {bootmgr} path E:\efi\microsoft\bootmgfw.efi to no avail.

let me know what you recommend I try next please.

Thanks again.

1 Like

Why don’t you give it a shot via Linux?
Do an su so that you get full privileges. Then mount the Windows drive and look for the bootmanager of Windows (the EFI) and then copy it to the /boot area. If there’s no Microsoft folder, create one with the mkdir command. It will not deny you any privileges there.

Once you’re successful, do a (as root):

grub-mkconfig /boot/grub/grub.cfg

And see if that helps. :slight_smile:

@vasileios, I think I am getting closer. I was able to copy the bootmgr.efi and bootmgfw.efi into the Manjaro boot area. Two new boot options have appeared on my rEFInd menu, while it feels like a breakthrough, sadly still unable to boot Windows.

this wasn’t here before:

but this is where it takes me:

Good job! I have a desktop with three Linux distros and an external Windows drive. If you can give me some time, I’ll check on it and see if it has any extra file that it may require.

1 Like