After a few weeks on Ubuntu, there are several frustrations

It was really not that difficult to download the ISO use Rufus to install on flashdrive, test it and then install it on a brand new dual boot hard drive. Getting rid of Firefox was also not to difficult with expert help and getting used to Terminal. Installing Brave, Telegram also not too hard.

I am very grateful for having been able to at least partially divest from Windows 10 but not quite there…

I am having several problems that I thought would be easy to resolve but have proven difficult.

Taking a Screen shot, found YouTubes, still cannot get it to work using simple Keyboard comments like Alt, Print Screen, very frustrating

Installing Bit Torrent, downloaded Linux version to desktop, Cannot use Sudo commands to get it to install, very frustrating

When attempting to log out and shut down grrrr. Tried going to upper right corner inverted triangle selecting either Power off or log out works but when logging back on it says did not shut down properly… Very frustrating

Any help for any of these issues greatly appreciated!
Have spend some time researching other distro’s including Cin Mint, Solus, Zorin and suspect that one of these would have been less frustrating…

1 Like

It would be most benificial for us to know which Ubuntu you are running, your Desktop, etc.

Typically, with ALL Ubunut derivatives, “PrtSc” key will take your screenshot and prompt you for a name and to specify a different location. If you’re using a different screenshot app that would be pertinent info in helping you.

As for BitTorrent, from where and what did you download. I see you said it was on your desktop.

Have you completed and update and upgrade yet? you may be interrupting the process and that may well be causing issues. In which case we may need to update fix-missing or something else.

Sorry, latest Ubuntu 20.04 LTE, got Bit Torrent from their site, and did an upgrade.
I am using a wireless Logitech keyboard, for the laptop, did not consider trying the command from the laptop keyboard…

Desktop is reference to a file location.
In Linux /home/yourusername/desktop/ would be an allowable location for you to save files etc. Under desktop, you would have Documents, Downloads, Pictures, Videos etc.

The wireless keyboard is in material in functionality so long as it functions in sending proper characters.

Since I’m not currently on a PC/laptop( it detects if i open download for Android). I personally recommended transmission for torrent and HIGHLY suggest running them from behind a VPN.

Thanks, did not think keyboard was a problem since it works just fine.
Desktop is as expected. I was also unable to get Surf Shark VPN for Linux Working.

Did discover folder with info have question mark icon on it. I use the laptop with 40" monitor via HDMI dual screen instead of desktop at this point…

When I installed Ubuntu and selected partition it did not ask me about space allocation and just partitioned 225 GB to Windows and the remainder of ITB to Ubuntu so also wondering if and how to repartition?

You can download and use GParted. It is a simple intuitive GUI partition editor.

There are going to be some frustrations dealing with Linux at first, but it does become worth it in time. Ubuntu is definitely one of the better distros to use starting out.

For the VPN issue, I would recommend you follow these instructions:

1 Like

I believe the suggested practice is to reuse your LiveCD and use Gparted without them mounted though I have no experience doing it this way whatsoever, in fact I have never ran a dual boot. You may want to create a separate topic about adjusting partition sizes without loosing data, or do a quick search on the forums, I’m certain someone has gone about it that way a few times and successfully.

As for VPN. You can save your udp/tcp opvn files to say a folder under Documents named VPN_configs. and setup the OpenVPN with Ubuntu instead of the providers application. I did so with Ubuntu network manager, OpenVPN and ProtonVPN files.

Hey @mauip!
A great application to annotate and highlight screenshots is shutter.
Also, per the shortcuts, normally the PrintScreen works and automatically saves the screenshot into your Pictures folder.
This is how it looks on my Gnome 42 (which I believe will be part of the new Ubuntu):

I’m running Linux on a MacBook, which doesn’t have a PrintScreen key, so I manually set the shortcuts.

Per Bit Torrent, I’d highly recommend using Transmission. It’s an amazing alternative.

When it comes to the shutdown, something must be getting stuck while you’re trying to shutdown. Once the screen goes black, during shutdown, hit the ESC key to see if there’s a service it’s trying to close before it goes off. If you press CTRL+ALT+DEL 7 times within 2 sec, it will force a shutdown.

thanks, will get GParted, Yes figured it would be somewhat frustrating although it got off to a relatively easy start. Will try again with Surf Shark although thought I had followed instructions…

jogging my memory, Transmission has been around quite some time, Is it easy to install in Ubuntu?

1 Like

Hey @mauip!
Very much so. It’s available on the Software Center. :slight_smile:

oddly Software Center in Ubuntu is largely vacant and no Transmission
Also bug returned in Ubuntu not allowing password in Terminal, very frustrating this distro

If I change to Mint, do I have to uninstall Ubuntu, and if so can you please tell me how?

You can regain password functionality, by typing:

faillock --reset

And then install transmission by executing:

sudo apt install transmission-gtk

Please let me know if that works for you. :slight_smile:

Finally figured it out, Terminal does not show anything happening when one types, but after imputing password and hitting enter its works fine. I was clueless.

just tried to install shutter using: sudo apt install shutter-gtk
that does not work, can you please assist?

It seems shutter was removed from Ubuntu 20 but returns in 22s repos. There is a way to get it.

There was a second set of instructions below this screenshot that do not need performed.

On a side note I used Flameshot(which I’m relatively new to) to take these screens, usually use print screen key, then open in GiMP and do the manipulation resize/crop etc.

When you click take a screenshot from tray for Flameshot, it asks you to select the are you want then it opens lightens your selection and provides many tools around the edge of the selection for manipulation. make your adjustments/annotations and then click the “save icon” which looks like a floppy disk lol

1 Like

thank you, transmission installed, but not sure where to find it?
will tackle shutter next

1 Like

typically “Transmission” falls under “Internet” in your menus. I do suggest you run it from behind your VPN as well.

1 Like

Never found Internet, but found Transmission under Applications. Now I do not know how to get it to left had bar menu and if I click on it nothing happens. Did not have this problem with Brave or Telegram.

You are on gnome desktop? Click the program dots, locate the program you want and simply drag an drop or right click and “Add to Favorites”.

So th application will not start?

1 Like