Zorin 16 laptop freeze

I am a new Linux user (less than 1 year) and I am enjoying the experience this time around. But, I am having an issue that I don’t know how to fix or troubleshoot to determine the cause.

I have a Dell XPS 2-in-1 that came with Windows pre-installed. I tried a number of distros before I settled on Zorin based on the look, ease of use, and the installed apps. Periodically, I have issues with the system freezing. There isn’t a consistent thing that causes the freeze. I could be using LibreOffice and scroll too fast with wheel on the mouse and the system would freeze. Other times I could change a tab in the Brave browser and the system could freeze. Sometimes the browser is an issue where I just have to wait for the dialog box to pop up to shutdown the browser and then everything is okay.

The type of freeze I am referring to is where the mouse completely stops moving and my only option is to either hold the power button to turn the system off or use the Linux RESUIB key combinations.

I am not sure if there is a hardware issue that is causing problems or if some of the installed software/drivers are causing the problem. i would prefer not to leave Zorin, but, if there is a compatibility issue I may not have a choice.

Any help or guidance would be greatly appreciated.

PS: I saw in another thread in the forum of a way to take a snapshot of the system details using inxi…

Kernel: 5.13.0-48-generic x86_64 bits: 64 compiler: N/A
parameters: BOOT_IMAGE=/boot/vmlinuz-5.13.0-48-generic
root=UUID=ab7002cd-6410-405e-8628-1d3a3dcbe15e ro quiet splash
Desktop: Gnome 3.38.4 wm: gnome-shell dm: GDM3
Distro: Zorin OS 16.1 base: Ubuntu 20.04 LTS Focal
Type: Convertible System: Dell product: XPS 13 9310 2-in-1 v: N/A
serial: Chassis: type: 31 serial:
Mobo: Dell model: 0062CR v: A00 serial: UEFI: Dell v: 2.7.0
date: 12/11/2021
ID-1: BAT0 charge: 41.3 Wh condition: 41.8/50.0 Wh (84%) volts: 8.5/7.6
model: BYD DELL DD9VF11 type: Li-poly serial: status: Charging
Topology: Quad Core model: 11th Gen Intel Core i7-1165G7 bits: 64
type: MT MCP arch: Tiger Lake family: 6 model-id: 8C (140) stepping: 1
microcode: 9A L2 cache: 12.0 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
bogomips: 44851
Speed: 1029 MHz min/max: 400/4700 MHz Core speeds (MHz): 1: 732 2: 1281
3: 1211 4: 896 5: 938 6: 1106 7: 1203 8: 1095
Vulnerabilities: Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Device-1: Intel vendor: Dell driver: i915 v: kernel bus ID: 0000:00:02.0
chip ID: 8086:9a49
Display: x11 server: X.Org 1.20.13 driver: i915 compositor: gnome-shell
resolution: 3840x2400~60Hz, 1920x1080~60Hz
OpenGL: renderer: Mesa Intel Xe Graphics (TGL GT2) v: 4.6 Mesa 21.2.6
direct render: Yes
Device-1: Intel vendor: Dell driver: snd_hda_intel v: kernel
bus ID: 0000:00:1f.3 chip ID: 8086:a0c8
Device-2: Altec Lansing type: USB driver: hid-generic,snd-usb-audio,usbhid
bus ID: 3- chip ID: 04d2:9801
Device-3: Logitech C922 Pro Stream Webcam type: USB
driver: snd-usb-audio,uvcvideo bus ID: 3- chip ID: 046d:085c
Sound Server: ALSA v: k5.13.0-48-generic
Device-1: Intel vendor: Bigfoot Networks driver: iwlwifi v: kernel
port: 3000 bus ID: 0000:00:14.3 chip ID: 8086:a0f0
IF: wlp0s20f3 state: down mac:
Device-2: Realtek RTL8153 Gigabit Ethernet Adapter type: USB driver: r8152
bus ID: 2- chip ID: 0bda:8153 serial:
IF: enx00e04c056488 state: down mac:
Device-3: Realtek RTL8153 Gigabit Ethernet Adapter type: USB driver: r8152
bus ID: 2-1.4.5:6 chip ID: 0bda:8153 serial:
IF: enx98fdb49aa495 state: up speed: 100 Mbps duplex: full mac:
IF-ID-1: virbr0 state: down mac:
IF-ID-2: virbr0-nic state: down mac:
Local Storage: total: 14.13 TiB used: 12.02 TiB (85.1%)
SMART Message: Required tool smartctl not installed. Check --recommends
ID-1: /dev/mmcblk0 model: GFAQK size: 476.91 GiB block size:
physical: 512 B logical: 512 B serial: scheme: MBR
ID-2: /dev/nvme0n1 model: KBG40ZPZ1T02 NVMe KIOXIA 1024GB size: 953.87 GiB
block size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4
serial: rev: 10400105 scheme: GPT
ID-3: /dev/sdb type: USB vendor: Western Digital model: WD My Book 25ED
size: 12.73 TiB block size: physical: 4096 B logical: 512 B
serial: rev: 1031 scheme: GPT
Hardware-1: Intel Volume Management Device NVMe RAID Controller
driver: vmd v: 0.6 port: 3000 bus ID: 0000:00:0e.0 chip ID: 8086.9a0b
rev: N/A
ID-1: / raw size: 953.37 GiB size: 937.40 GiB (98.33%)
used: 743.70 GiB (79.3%) fs: ext4 dev: /dev/nvme0n1p2
System Temperatures: cpu: 56.0 C mobo: N/A
Fan Speeds (RPM): N/A
Processes: 398 Uptime: 2h 35m Memory: 31.07 GiB used: 5.89 GiB (19.0%)
Init: systemd v: 245 runlevel: 5 Compilers: gcc: 9.4.0 alt: 9 Shell: bash
v: 5.0.17 running in: gnome-terminal inxi: 3.0.38

Hello @diamondre and welcome to the forums!

From what you described, I am starting to think that it’s an issue having to do with your CPU changing states (in frequency), which also affects your graphics, since it’s basically the same chip.

My first step would be to direct the kernel to load the graphics module the moment your desktop environment shoots up and not before - to avoid any possible conflicts with any CPU extensions. Also, to add a directive to limit the CPU from jumping too much or too hard.

Both are doable by adding the corresponding parameters to the boot-loader that fires up the kernel.

When you boot in, open up a terminal and edit the basic GRUB configuration (boot loader):

sudo nano /etc/default/grub

Seek the line that says GRUB_CMDLINE_LINUX_DEFAULT. It should be including the words quiet and splash in there. After those (leave a blank space), add the following two values, inside the quotation marks:

nomodeset intel_idle.max_cstate=1

Press CTRL+O and then Enter to save. CTRL+X to exit.

Once back at the terminal, inform GRUB of the changes by executing:

sudo update-grub

Then reboot and see how your system behaves.

@vasileios thanks for the response. I will give this a try and let you know how things turn out. I never know when the system will freeze and it can be annoying when in the middle of something important.

Thanks for the welcome.

1 Like

If your system decides to misbehave, then you can hold down SHIFT (or tap the ESC button right after the BIOS completes and the screen goes black for the boot-loader), so that the GRUB menu appears. Then, select the 1st entry (automatically selected) and press E.

It will produce you the boot-loader configuration. Navigate with your arrow keys to the end of the line that starts with linux and also includes quiet splash and add the number 3 at the end. Then, hit F10 for it to boot with that temporary change (it will revert on the next reboot). It will drop you out to a terminal login, where you can enter your system via text (TTY) and do the above changes without your system freezing. :slight_smile:

My machine restarted without misbehaving, but, my secondary monitor is not detected. I am using a Thunderbolt 4 hub. Not sure if this is related to the changes entered, but, the other items connected to the hub are working. This is a portable monitor that uses usb for power.

update: @vasileios I may have a cable problem because I tried another hub and the same problem is exhibited (may be something else). I changed the settings back to the way they were before you made the suggestion and the monitor is shown in the display dialog (though the monitor does not light up; still shows to check cable). One of the reasons I went back was because I wanted the second monitor today for a meeting (but I still do not have it :frowning:). The other reason I changed back was because I was unable to change the resolution on the laptop…I could only use the full resolution (3840 x 2400) which makes everything very small. If I wanted to change the resolution I no longer had that option. I believe I changed the scale when both monitors were detected and it would change resolution in proportion to both monitors.

update 2: this one is sort of embarrassing to admit…I had the cable on the monitor plugged into the wrong hole :rofl:). But, the initial issue about the second monitor not appearing and not being able to change the resolution still remains if I make the change you suggested.

Hey, @diamondre!
Multiple displays can be a mess at times when dealing with certain graphics setups - under specific modules and desktop environments, that is true.

Go back to configuring Grub at ‘/etc/default/grub’ and take out the nomodeset but keep the intel one in. Save it, perform the sudo update-grub, reboot and see how it goes. If there is still trouble, then alternate them (take out the Intel and put the nomodeset back in).

I too had a 2nd monitor issue with one of my laptops. It blatantly refused to work with a KVM, so I ended up doing the switch from the monitor itself, by using different types of cables. So, I feel you!

@vasileios I removed the nomodeset and both monitors are functioning and I am able to adjust the resolution for each monitor. I will keep you posted about the original issue (freeze). I am going out on faith and believing that the issue has been resolved. thanks for your help.

1 Like

Thank you, @diamondre!
When that freeze happens, please jot down the time on your desktop environment. Then reboot and open up a terminal to execute:

sudo cat /var/log/syslog

Then copy a couple of pages of the area around that timestamp you jotted down to see what might have caused it & paste it here.

Thank you again!

I hope my laptop does not freeze (so far so good), but, if it does I will follow your advice.

Thank you

1 Like

It is always my pleasure, @diamondre! I truly hope things will settle down for you. :slight_smile: