Wireless network printer install problems with Manjaro

I have a Lenovo ideapad 310 running Manjaro Sikaris 22.0.0 XFCE. I’ve been through a ton of tutorials and how-to’s for days trying to figure out how to get it to print to my wireless networked Epson ET-2760 printer. I finally figured out how to get “Print-Manager” working. It was not installed apparently but now I’m stumped. Due to my ignorance of Linux I don’t even know what questions to ask to move forward. Could someone point me in the right direction?

The pages on this site can be a little hard to navigate at times. On the left ‘half’ of the page, look for the “Next Page” on the right or “Previous Page” on the left.

1 Like

I have had issues with Manjaro staying connected to my Epson (ET-3760). I wrote it all down and when I find what I did I’ll post again. One things was in print settings click on Server then Connect and make sure under CUPS server that it is the same as the server named along the bottom of the print settings window.

is your idepad a 2-in-1 laptop/tablet touchscreen? how does that distro work on it?

Thanks! I’ll check it out.

Td, thanks for the response. When you find those notes please respond to this thread.

Manjaro works fine on my laptop. I had issues with Brave browser asking for some kind of a Keyring password when starting up but if I waited long enough it would go ahead and run. Entering my root p/w didn’t make it happy… After installing another application… then my root p/w worked in the keyring window when starting Brave. weird.

One thing that comes to mind regarding your ET-3760 connectivity issues; I did read somewhere that if your modem is turned off and it’s using DHCP to connect to the printer, then when you power it up and it boots it will dynamically assign a new I/P address to the printer. If you have static I/P assigned in the printer setup on your laptop then it would lose communication every time the modem was started up.

The above may make absolutely no sense whatsoever. I’m a networking idiot. I just throw it out there in case it may trigger a thought that would help.


That does make sense. The only other thing I had was to make sure the printer status is enabled in print settings. It seems to toggle itself off. My parents have the same laptop setup as me but with an hp printer and theirs is much pickier. I think it’s an hp issue. I did check drivers and work through the cups server setup. I had to uninstall the printer and use the cups address for my printer to set it up.

I also had that keyring issue. Very annoying. There were some brave bin packages I uninstalled and quit updating and it went away.

As for Brave, on first run you should have only had to provide your regular user account password once to connect the keyring and your user account securing any sensitive auto-fill, save passwords, cc, sync etc, then from then on when you launch brave if you signed in to your desktop it wouldn’t bother you. If you use automatic login you will have to provide the password every time you launch Brave I believe

Got to step 5 and now I get the following error. Don’t know what to do about it.

gpasswd: group ‘lpadmin’ does not exist in /etc/group

Got it going. I forgot I had the printer running on another network. Switched to that network and was able to find the printer in Print Manager… test page printed successfully.

Thanks for the help folks !

(post needs to be 21 or more characters so had to add part of this line)

Awesome! Glad that worked.