Wifi on Fedora

I installed Fedora on a new Lenovo Flex 5 and wifi is not even showing. I think I’ve narrowed down that I may need the Realtek driver. Has anyone dealt with this? I’m finding a few options online for getting it done but each one is a little different. Has anyone done this that has a concise workable solution?

If you want “a concise workable solution” we need some “concise readable information”.
Which version of Fedora did you install?
Does your machine have an ethernet port?
What does lspci show for Ethernet Controller?
What does lspci show for Network Controller?
What does ifconfig show for enp and wlp?
(both enp and wlp will have more letters and digits appended)
Were you connected to the internet during the install?

I’m connected to the internet via ethernet adapter plugged into usb c thunderbolt. This was my internet source during installation as well.

lspci resulted in:

(note: technically no ethernet but it’s using one of the usb thunderbolts)


ifconfig output:

Your wifi device appears to be too new for the Linux kernel.
I think I can provide an answer for you but until your device’s kernel module is accepted into the kernel repositories you will need to compile and install your own module every time you update the kernel, if you want the wifi to work.
This entails making sure you have the kernel-headers and kernel development packages installed.
If secure boot is turned off then the process should be easier but you will still need to compile a new module after every kernel update. After reading the two links posted below if you want to continue post back here.

This first link is an abbreviated set of commands, at the very bottom, to compile and insert the module needed for your Realtek Device b852. Note the instructions are for Ubuntu so will need to be modified to work with Fedora’s dnf and you would need to be sure the kernel-headers and development tools are installed as in the second link.

This, second link, is a git repository of the module you will need to compile and insert to allow your wifi device to work. Please read through this and take note of the Fedora requirements as well as all distros requirements.

Let me know if you want some help working this out. I will help you get it running in Fedora if possible.

1 Like

Thank you!
I’m working through it. It makes sense. I’m getting a connection timed out error when creating the git file but that is likely due to our super slow internet the past few days (after getting 5 inches of snow…) not sure why but it’s been dragging.

I’ll update with my progress.

I also assume that at some future kernel update the developers might account for this new wifi device so until then I’ll need to compile after every kernel update.

I’m progressing but I’ve hit a roadblock.
First off, I had to use the https://github… instead of git://github…
This is because github closed down git:// (apparently due to security issues).

And since my laptop secure boot is enabled I’m having to go through setting up the public/private key. I’ve made it as far as ‘Signing Kernel Module with Private Key’ and it’s not recognizing a file. See link for the resource I’m using. Error shown in photo.


I should clarify that I also tried ‘sudo make…’ with the above and received the same error

You should be running the command as root.
In your link under the section Signing Kernel Module with the Private Key , note that they are logged in as root and are in root’s HOME directory. You can see ~]# before the make command. In your screen shot you will see the $ instead of he # . The $ is used for a regular user and the # is used to denote root. Also, the ~ (tilde) is used to denote the users HOME directory.
make is looking for the Makefile in the HOME directory of a user noted by the $ which in your case is tara as seen in on the far left of your screenshot,
Before entering the make command you will want to switchuser to root using su and the - (hyphen) will switch the user to root and will put you in HOME of root.
So before you enter the make command do:
su -
then your command line should show something like
[root@LIdeaFlex22 ~]#
That shows that you are logged in as root and in root’s HOME directory.
There are other commands further up in your link that ran the commands as root. If you have followed that link from the top then you will most likely need to start again and make sure you are the user root before running commands that have the # in front of them.
When working on something like this it is a nice idea to have two terminal window open, one that is logged in as your regular user and one where you have used
su -
to become root. Then make sure you are in the correct terminal to run the commands for the regular user $ or the root user # .

Kernel module work is persnickety so take your time and double check. It is also a good idea to take notes and copy the commands in order to you notes. That way in the future you will have your own ‘tutorial’ specific to what you need.

Note: if you encounter a command that shows something besides the ~ to the left of the bracket ] then they have probably use cd so change to a different directory and that should be noted before they want you to run the command.


Sooooo…it was simpler than my last message.

I first did a Timeshift before starting.
Then I checked to see if it was in secure boot (this matters later)

$ mokutil --sb-state
Secureboot enabled

From this link that you provided:

After making sure all of the packages were installed, I simply did the following from my user terminal:

$ git clone https://github.com/lwfinger/rtw8852be.git
$ cd rtw8852be
$ make
$ sudo make sign-install
(note: if secureboot was not enabled it would be sudo make install)

It then asks for you to create a password and re-enter it.
Then you reboot and at the blue screen press any key.
Select Enroll MOK
(enter password)


So I had to combine the two options since git:// wasn’t available BUT secureboot was enabled.

Thank you so much!

It looks like you pretty much solved it on your own, good job.

The articles did mention that after a kernel update you will need to recompile the module, correct?

“BAZINGA!” :smile: never heard/saw that before!

Bazinga is a Big Bang Theory saying.

Yes, it will need to be recompiled after kernel updates, which it looks like fedora will be getting soon…so I’ll get to practice that.

I’m seeing a couple of options which only differ by ‘make clean’ and I’m wondering if I would need to do the ‘sudo make sign-install’ again. Probably?

Screenshot from 2022-10-27 21-33-57

Well, I haven’t watched hardly an TV since 911 2001, I knew then that the television Main Stream Media was a farce and just figured the entire industry was corrupt. But, I could be wrong!

You do not need to update your kernel every time Fedora offers a kernel update, but it is not a bad idea. Depending on if security updates are in the new kernel you could skip a couple of kernel updates.
I like the idea of the make clean in your white screen shot. Use it, it will clean up any leftovers from the original make.
And yes you will need the sudo make sign-install every time.